]> git.pld-linux.org Git - packages/lighttpd.git/blobdiff - branch.sh
exclude files which change version
[packages/lighttpd.git] / branch.sh
old mode 100644 (file)
new mode 100755 (executable)
index ce1964c..cdd909f
--- a/branch.sh
+++ b/branch.sh
@@ -1,14 +1,52 @@
 #!/bin/sh
 set -e
 svn=svn://svn.lighttpd.net/lighttpd
-tag=lighttpd-1.4.21
+package=lighttpd
+tag=lighttpd-1.4.36
 branch=lighttpd-1.4.x
+out=lighttpd-branch.diff
+
+# old version of this code used to create tarball.
+# leave it around
+if [ "$1" = "tarball" ]; then
+       v=1.5
+       svn co $svn/trunk $package-$v
+       r=$(svnversion $package-$v)
+       t=$package-r$r.tar.bz2
+       tar -cjf $t --exclude-vcs $package-$v
+       ../dropin $t &
+       exit 0
+fi
+
+d=$-
+filter() {
+       set -$d
+       # Excluding files which change version or were not in dist tarball
+       filterdiff \
+               -x 'CMakeLists.txt' \
+               -x 'configure.ac' \
+               -x 'SConstruct' \
+               | \
+       # remove revno's for smaller diffs
+       sed -e 's,^\([-+]\{3\} .*\)\t(revision [0-9]\+)$,\1,'
+}
 
 old=$svn/tags/$tag
 new=$svn/branches/$branch
-echo "Running diff: $old -> $new"
-LC_ALL=C svn diff --old=$old --new=$new > lighttpd-branch.diff
+echo >&2 "Running diff: $old -> $new"
+LC_ALL=C svn diff --old=$old --new=$new > $out.tmp
+revno=$(sed -ne 's,^[-+]\{3\} .*\t(revision \([0-9]\+\))$,\1,p' $out.tmp | sort -urn | head -n1)
+echo >&2 "Revision $revno"
+[ "$revno" -gt 0 ] || exit 1
+
+sed -i -e "1i# Revision $revno" $out.tmp
+filter < $out.tmp > $out.tmp2 && mv -f $out.{tmp2,tmp}
+
+if cmp -s $out{,.tmp}; then
+       echo >&2 "No new diffs..."
+       rm -f $out.tmp
+       exit 0
+fi
+mv -f $out{.tmp,}
 
-echo "Excluding files which change version or were not in dist tarball"
-filterdiff -x 'configure.in' -x 'SConstruct' -x 'CMakeLists.txt' lighttpd-branch.diff > lighttpd-branch.diff.tmp
-mv -f lighttpd-branch.diff.tmp lighttpd-branch.diff
+../md5 *.spec
This page took 0.088871 seconds and 4 git commands to generate.