]> git.pld-linux.org Git - packages/lighttpd.git/commitdiff
exclude files which change version
authorElan Ruusamäe <glen@delfi.ee>
Tue, 18 Aug 2015 10:07:35 +0000 (13:07 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 18 Aug 2015 10:07:35 +0000 (13:07 +0300)
branch.sh

index 63bad8818c94855d48eb651b729b5bb3968c710a..cdd909f32bd4baf580b6b84634a49606c73846dc 100755 (executable)
--- a/branch.sh
+++ b/branch.sh
@@ -21,6 +21,12 @@ fi
 d=$-
 filter() {
        set -$d
+       # Excluding files which change version or were not in dist tarball
+       filterdiff \
+               -x 'CMakeLists.txt' \
+               -x 'configure.ac' \
+               -x 'SConstruct' \
+               | \
        # remove revno's for smaller diffs
        sed -e 's,^\([-+]\{3\} .*\)\t(revision [0-9]\+)$,\1,'
 }
This page took 0.09862 seconds and 4 git commands to generate.