]> git.pld-linux.org Git - packages/lighttpd.git/blobdiff - branch.sh
exclude files which change version
[packages/lighttpd.git] / branch.sh
index 05e1c6cee33e9eae37663bf51dba9838d815bbd4..cdd909f32bd4baf580b6b84634a49606c73846dc 100755 (executable)
--- a/branch.sh
+++ b/branch.sh
@@ -21,6 +21,12 @@ fi
 d=$-
 filter() {
        set -$d
+       # Excluding files which change version or were not in dist tarball
+       filterdiff \
+               -x 'CMakeLists.txt' \
+               -x 'configure.ac' \
+               -x 'SConstruct' \
+               | \
        # remove revno's for smaller diffs
        sed -e 's,^\([-+]\{3\} .*\)\t(revision [0-9]\+)$,\1,'
 }
@@ -42,3 +48,5 @@ if cmp -s $out{,.tmp}; then
        exit 0
 fi
 mv -f $out{.tmp,}
+
+../md5 *.spec
This page took 0.036756 seconds and 4 git commands to generate.