]> git.pld-linux.org Git - packages/lighttpd.git/blob - lighttpd.spec
- add .rpm mimetype
[packages/lighttpd.git] / lighttpd.spec
1 # TODO:
2 # - test ldap and mysql (failed at this time)
3 # - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
4 # - fam over gamin is possible, just configure doesn't check other than gamin
5 # - feature stat-cache-fam (doesn't work)
6 #
7 # NOTES:
8 # - fcgi-devel is only used for the test-scripts
9 # - disable largefile, if you have 2.4 kernel to get sendfile() support, and don't need > 2GB file requests,
10 #   see http://article.gmane.org/gmane.comp.web.lighttpd:722
11 # - please make subpackages of modules that depend other modules than:
12 #  - pcre (core binary needs it too)
13 #  - openssl (core binary needs it too)
14 #
15 # Conditional build for lighttpd:
16 %bcond_without  xattr           # support of extended attributes
17 %bcond_without  ipv6            # IPv4-only version (doesn't require IPv6 in kernel)
18 %bcond_without  largefile       # largefile support (see notes above)
19 %bcond_without  ssl             # ssl support
20 %bcond_with     mysql           # mysql support in mod_mysql_vhost
21 %bcond_with     ldap            # ldap support in mod_auth
22 %bcond_with     lua             # LUA support in mod_cml
23 %bcond_with     memcache        # memcached support in mod_cml / mod_trigger_b4_dl
24 %bcond_with     gamin           # gamin for reducing number of stat() calls. 
25                                 # NOTE: must be enabled in config: server.stat-cache-engine = "fam"
26 %bcond_with     gdbm            # gdbm in mod_trigger_b4_dl
27 %bcond_with     webdav_props    # properties in mod_webdav (includes extra sqlite3/libxml deps)
28 %bcond_with     valgrind        # compile code with valgrind support.
29
30 # Prerelease snapshot: DATE-TIME
31 #define _snap 20050116-1743
32
33 %if 0%{?_snap}
34 %define _source http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
35 %else
36 %define _source http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
37 %endif
38
39 %define         _rel 1
40
41 Summary:        Fast and light HTTP server
42 Summary(pl):    Szybki i lekki serwer HTTP
43 Name:           lighttpd
44 Version:        1.4.7
45 Release:        %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}
46 Group:          Networking/Daemons
47 License:        BSD
48 Source0:        %{_source}
49 # Source0-md5:  4d1b02e2008e5f35e4df7defee186fdd
50 Source1:        %{name}.init
51 Source2:        %{name}.conf
52 Source3:        %{name}.user
53 Source4:        %{name}.logrotate
54 Source5:        %{name}.sysconfig
55 URL:            http://www.lighttpd.net/
56 %{?with_xattr:BuildRequires:    attr-devel}
57 BuildRequires:  autoconf
58 BuildRequires:  automake
59 BuildRequires:  bzip2-devel
60 %{?with_gamin:BuildRequires:    gamin-devel}
61 %{?with_webdav_props:BuildRequires:     sqlite3-devel}
62 %{?with_webdav_props:BuildRequires:     libxml2-devel}
63 BuildRequires:  libtool
64 %{?with_mysql:BuildRequires:    mysql-devel}
65 %{?with_ldap:BuildRequires:             openldap-devel}
66 %{?with_ssl:BuildRequires:      openssl-devel}
67 %{?with_lua:BuildRequires:      lua50-devel >= 5.0.2-5.1}
68 %{?with_memcache:BuildRequires: libmemcache-devel}
69 %{?with_gdbm:BuildRequires:     gdbm-devel}
70 BuildRequires:  pcre-devel
71 BuildRequires:  rpmbuild(macros) >= 1.202
72 %{?with_valgrind:BuildRequires: valgrind}
73 BuildRequires:  zlib-devel
74 PreReq:         rc-scripts
75 Requires(pre):  sh-utils
76 Requires(pre):  /bin/id
77 Requires(pre):  /usr/bin/getgid
78 Requires(pre):  /usr/sbin/groupadd
79 Requires(pre):  /usr/sbin/useradd
80 Requires(post,preun):   /sbin/chkconfig
81 Requires(postun):       /usr/sbin/groupdel
82 Requires(postun):       /usr/sbin/userdel
83 Provides:       group(lighttpd)
84 Provides:       httpd
85 Provides:       user(lighttpd)
86 Provides:       webserver
87 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88
89 %define         _libdir         %{_prefix}/%{_lib}/%{name}
90 %define         _lighttpddir    /home/services/%{name}
91 %define         _sysconfdir     /etc/%{name}
92
93 %description
94 lighttpd is a secure, fast, compliant and very flexible web-server
95 which has been optimized for high-performance environments. It has a
96 very low memory footprint compared to other webservers and takes care
97 of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
98 Output-Compression, URL-Rewriting and many more) make lighttpd the
99 perfect webserver-software for every server that is suffering load
100 problems.
101
102 %description -l pl
103 lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
104 serwerem WWW, który zosta³ zoptymalizowany pod k±tem
105 wysokowydajno¶ciowych ¶rodowisk. Zajmuje bardzo ma³± ilo¶æ pamiêci w
106 porównaniu do innych serwerów WWW oraz dba o zajêto¶æ procesora.
107 Szeroki zestaw opcji (FastCGI, CGI, uwierzytelnianie, kompresja
108 wyj¶cia, przepisywanie URL-i i wiele innych) czyni± z lighttpd
109 doskona³e oprogramowanie web-serwerowe na ka¿dy serwer cierpi±cy z
110 powodu problemów z obci±¿eniem.
111
112 %package mod_compress
113 Summary:        Output Compression
114 Summary(pl):    Kompresja wyj¶cia
115 Group:          Networking/Daemons
116 URL:            http://www.lighttpd.net/documentation/compress.html
117 Requires:       %{name} = %{version}-%{release}
118
119 %description mod_compress
120 Output compression reduces the network load and can improve the
121 overall throughput of the webserver.
122
123 Only static content is supported up to now.
124
125 The server negotiates automatically which compression method is used.
126 Supported are gzip, deflate, bzip.
127
128 %description mod_compress -l pl
129 Kompresja wyj¶cia zmniejsza obci±¿enie sieci i mo¿e poprawiæ ca³kowit±
130 przepustowo¶æ serwera WWW.
131
132 Jak na razie obs³ugiwana jest tylko statyczna tre¶æ.
133
134 Serwer automatycznie negocjuje, która metoda kompresji jest u¿ywana.
135 Obs³ugiwane s± gzip, deflate i bzip.
136
137 %package mod_cml
138 Summary:        Cache Meta Language module
139 Summary(pl):    Modu³ Cache Meta Language
140 Group:          Networking/Daemons
141 URL:            http://www.lighttpd.net/documentation/cml.html
142 Requires:       %{name} = %{version}-%{release}
143
144 %description mod_cml
145 CML is a Meta language to describe the dependencies of a page at one
146 side and building a page from its fragments on the other side using
147 LUA.
148
149 %description mod_cml -l pl
150 CML to metajêzyk s³u¿±cy z jednej strony do opisu zale¿no¶ci strony i
151 z drugiej strony do budowania strony z fragmentów przy u¿yciu LUA.
152
153 %package mod_mysql_vhost
154 Summary:        MySQL based vhosting
155 Summary(pl):    vhosty oparte na MySQL-u
156 Group:          Networking/Daemons
157 URL:            http://www.lighttpd.net/documentation/mysqlvhost.html
158 Requires:       %{name} = %{version}-%{release}
159
160 %description mod_mysql_vhost
161 This module provides virtual hosts (vhosts) based on a MySQL table.
162
163 %description mod_mysql_vhost -l pl
164 Ten modu³ udostêpnia wirtualne hosty (vhosty) oparte na tabeli MySQL.
165
166 %package mod_trigger_b4_dl
167 Summary:        Trigger before Download
168 Summary(pl):    Wyzwalacz przed ¶ci±ganiem
169 Group:          Networking/Daemons
170 URL:            http://www.lighttpd.net/documentation/trigger_b4_dl.html
171 Requires:       %{name} = %{version}-%{release}
172
173 %description mod_trigger_b4_dl
174 Another anti hot-linking module.
175
176 %description mod_trigger_b4_dl -l pl
177 Jeszcze jeden modu³ blokuj±cy bezpo¶rednie linkowanie.
178
179 %package mod_webdav
180 Summary:        WebDAV module for lighttpd
181 Summary(pl):    Modu³ WebDAV dla libghttpd
182 Group:          Networking/Daemons
183 URL:            http://www.lighttpd.net/documentation/webdav.html
184 Requires:       %{name} = %{version}-%{release}
185
186 %description mod_webdav
187 The WebDAV module is a very minimalistic implementation of RFC 2518.
188 Minimalistic means that not all operations are implementated yet.
189
190 So far we have
191 - PROPFIND
192 - OPTIONS
193 - MKCOL
194 - DELETE
195 - PUT
196
197 and the usual GET, POST, HEAD from HTTP/1.1.
198
199 So far mounting a webdav resource into Windows XP works and the basic
200 litmus tests are passed.
201
202 %description mod_webdav -l pl
203 Modu³ WebDAV to bardzo minimalistyczna implementacja RFC 2518.
204 Minimalistyczna oznacza, ¿e jeszcze nie wszystkie operacje s±
205 zaimplementowane. Jak na razie s±:
206 - PROPFIND
207 - OPTIONS
208 - MKCOL
209 - DELETE
210 - PUT
211 oraz zwyk³e GET, POST, HEAD z HTTP/1.1.
212
213 Jak na razie montowanie zasobu webdav pod Windows XP dzia³a i
214 podstawowe testy lakmusowe przechodz±.
215
216 %package -n spawn-fcgi
217 Summary:        Spawn fcgi-process directly
218 Summary(pl):    Bezpo¶rednie uruchamianie procesów fcgi
219 Group:          Applications
220
221 %description -n spawn-fcgi
222 spawn-fcgi is used to spawn fcgi-process directly without the help of
223 a webserver or the programm itself.
224
225 %description -n spawn-fcgi -l pl
226 spawn-fcgi s³u¿y do uruchamiania procesów fcgi bezpo¶rednio, bez
227 pomocy serwera WWW ani samego programu.
228
229 %prep
230 %setup -q
231
232 %build
233 %{__libtoolize}
234 %{__aclocal}
235 %{__autoconf}
236 %{__automake}
237
238 %configure \
239         %{!?with_ipv6:--disable-ipv6} \
240         %{!?with_largefile:--disable-lfs} \
241         %{?with_valgrind:--with-valgrind} \
242         %{?with_xattr:--with-attr} \
243         %{?with_mysql:--with-mysql} \
244         %{?with_ldap:--with-ldap} \
245         %{?with_ssl:--with-openssl} \
246         %{?with_lua:--with-lua} \
247         %{?with_memcache:--with-memcache} \
248         %{?with_webdav_props:--with-webdav-props} \
249         %{?with_gamin:--with-gamin} \
250         %{?with_gdbm:--with-gdbm}
251
252 %{__make}
253
254 %install
255 rm -rf $RPM_BUILD_ROOT
256 install -d $RPM_BUILD_ROOT{%{_lighttpddir}/{cgi-bin,html},/etc/{logrotate.d,rc.d/init.d,sysconfig},%{_sysconfdir}} \
257         $RPM_BUILD_ROOT/var/log/{%{name},archiv/%{name}}
258
259 %{__make} install \
260         DESTDIR=$RPM_BUILD_ROOT
261
262 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
263 install %{SOURCE2} %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
264 install %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
265 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
266
267 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
268
269 # could use automake patch, but automake generation fails...
270 mv $RPM_BUILD_ROOT%{_bindir}/spawn-fcgi $RPM_BUILD_ROOT%{_sbindir}/spawn-fcgi
271
272 %if %{without mysql}
273 rm -f $RPM_BUILD_ROOT%{_libdir}/mod_mysql_vhost.so
274 %endif
275
276 %clean
277 rm -rf $RPM_BUILD_ROOT
278
279 %pre
280 %groupadd -g 109 lighttpd
281 %useradd -u 116 -d %{_lighttpddir} -c "HTTP User" -g lighttpd lighttpd
282
283 %post
284 /sbin/chkconfig --add %{name}
285 if [ -f /var/lock/subsys/%{name} ]; then
286         /etc/rc.d/init.d/%{name} restart 1>&2
287 else
288         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
289 fi
290
291 %preun
292 if [ "$1" = "0" ]; then
293         if [ -f /var/lock/subsys/%{name} ]; then
294                 /etc/rc.d/init.d/%{name} stop 1>&2
295         fi
296         /sbin/chkconfig --del %{name}
297 fi
298
299 %postun
300 if [ "$1" = "0" ]; then
301         %userremove lighttpd
302         %groupremove lighttpd
303 fi
304
305 %triggerpostun -- %{name} <= 1.3.6-2
306 # upgraded
307 if [ "$1" = "2" ]; then
308 %banner %{name} -e <<EOF
309 spawn-fcgi program is now available separately from spawn-fcgi package.
310
311 EOF
312 fi
313
314 %files
315 %defattr(644,root,root,755)
316 %doc NEWS README ChangeLog doc/lighttpd.conf doc/*.txt doc/rrdtool-graph.sh
317 %attr(755,root,root) %{_sbindir}/*
318 %dir %{_libdir}
319 %attr(755,root,root) %{_libdir}/mod_access.so
320 %attr(755,root,root) %{_libdir}/mod_accesslog.so
321 %attr(755,root,root) %{_libdir}/mod_alias.so
322 %attr(755,root,root) %{_libdir}/mod_auth.so
323 %attr(755,root,root) %{_libdir}/mod_cgi.so
324 %attr(755,root,root) %{_libdir}/mod_dirlisting.so
325 %attr(755,root,root) %{_libdir}/mod_evhost.so
326 %attr(755,root,root) %{_libdir}/mod_expire.so
327 %attr(755,root,root) %{_libdir}/mod_fastcgi.so
328 %attr(755,root,root) %{_libdir}/mod_indexfile.so
329 %attr(755,root,root) %{_libdir}/mod_proxy.so
330 %attr(755,root,root) %{_libdir}/mod_redirect.so
331 %attr(755,root,root) %{_libdir}/mod_rewrite.so
332 %attr(755,root,root) %{_libdir}/mod_rrdtool.so
333 %attr(755,root,root) %{_libdir}/mod_scgi.so
334 %attr(755,root,root) %{_libdir}/mod_secdownload.so
335 %attr(755,root,root) %{_libdir}/mod_setenv.so
336 %attr(755,root,root) %{_libdir}/mod_simple_vhost.so
337 %attr(755,root,root) %{_libdir}/mod_ssi.so
338 %attr(755,root,root) %{_libdir}/mod_staticfile.so
339 %attr(755,root,root) %{_libdir}/mod_status.so
340 %attr(755,root,root) %{_libdir}/mod_userdir.so
341 %attr(755,root,root) %{_libdir}/mod_usertrack.so
342 %attr(750,root,root) %dir /var/log/archiv/%{name}
343 %dir %attr(750,lighttpd,root) /var/log/%{name}
344 %attr(755,lighttpd,lighttpd) %{_lighttpddir}
345 %attr(754,root,root) /etc/rc.d/init.d/%{name}
346 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
347 %dir %attr(750,root,lighttpd) %{_sysconfdir}
348 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
349 %attr(640,root,lighttpd) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.user
350 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
351 %{_mandir}/man?/*
352
353 %files mod_compress
354 %defattr(644,root,root,755)
355 %attr(755,root,root) %{_libdir}/mod_compress.so
356
357 %files mod_cml
358 %defattr(644,root,root,755)
359 %attr(755,root,root) %{_libdir}/mod_cml.so
360
361 %if %{with mysql}
362 %files mod_mysql_vhost
363 %defattr(644,root,root,755)
364 %attr(755,root,root) %{_libdir}/mod_mysql_vhost.so
365 %endif
366
367 %files mod_trigger_b4_dl
368 %defattr(644,root,root,755)
369 %attr(755,root,root) %{_libdir}/mod_trigger_b4_dl.so
370
371 %files mod_webdav
372 %defattr(644,root,root,755)
373 %attr(755,root,root) %{_libdir}/mod_webdav.so
374
375 %files -n spawn-fcgi
376 %defattr(644,root,root,755)
377 %doc doc/spawn-php.sh
378 %attr(755,root,root) %{_sbindir}/spawn-fcgi
This page took 0.047659 seconds and 3 git commands to generate.