]> git.pld-linux.org Git - packages/lighttpd.git/blame - lighttpd.spec
- use %useradd/%groupadd macros
[packages/lighttpd.git] / lighttpd.spec
CommitLineData
8d734bed 1#
05f8c491 2# TODO
0ab57655 3# - test ldap and mysql (failed at this time)
ddfaf124 4# - documentroot specified in config doesn't exist
fcae54a7 5# - mysql issue: http://www.freebsd.org/cgi/query-pr.cgi?pr=76866
05f8c491 6#
4f968063 7# Conditional build for lighttpd:
ce8f06ab 8%bcond_without xattr # without support of extended attributes
1da5e2ed 9%bcond_without ipv6 # IPv4-only version (doesn't require IPv6 in kernel)
dae5a344
ER
10# use it if you have 2.4 kernel to get sendfile() support,
11# and don't need > 2GB file requests,
12# see http://article.gmane.org/gmane.comp.web.lighttpd:722
1da5e2ed 13%bcond_without largefile # without largefile support
1da5e2ed 14%bcond_without ssl # disable ssl support
ce8f06ab
KK
15%bcond_with mysql # with mysql
16%bcond_with ldap # with ldap
f0f1c74c 17%bcond_with valgrind # compile code with valgrind support.
dae5a344 18%bcond_with dirhide # with 'hide from dirlisting' hack
d20e182e 19#
2abd0792 20# Prerelease snapshot: DATE-TIME
c1b34484 21##define _snap 20050116-1743
2abd0792
ER
22
23%if 0%{?_snap}
24%define _source http://www.lighttpd.net/download/%{name}-%{version}-%{_snap}.tar.gz
25%else
26%define _source http://www.lighttpd.net/download/%{name}-%{version}.tar.gz
27%endif
28
f0f1c74c 29%define _rel 3.5
2abd0792 30
027853cc 31Summary: Fast and light HTTP server
32Summary(pl): Szybki i lekki serwer HTTP
bee4f74e 33Name: lighttpd
14979de5 34Version: 1.3.13
2abd0792 35Release: %{_rel}%{?_snap:.%(echo %{_snap}|tr - _)}
bee4f74e 36Group: Networking/Daemons
4241e769 37License: BSD
2abd0792 38Source0: %{_source}
14979de5 39# Source0-md5: 2f017b936be376ad6f6c2ee26db93467
bee4f74e 40Source1: %{name}.init
2f7162ab
AM
41Source2: %{name}.conf
42Source3: %{name}.user
607835c0 43Source4: %{name}.logrotate
c54ca3d2 44Source5: %{name}.sysconfig
e22eff1c 45Patch0: http://minghetti.ch/blob/dirlist-hide.patch
dae5a344
ER
46Patch1: %{name}-fcgi-verbose.patch
47Patch2: %{name}-proxy-error-handler.patch
48Patch3: %{name}-fcgi-retry-timeout.patch
f0f1c74c 49Patch4: http://glen.alkohol.ee/pld/lighttpd-request_header-print.patch
70373b58 50URL: http://www.lighttpd.net/
1a75d3e1
JB
51BuildRequires: autoconf
52BuildRequires: automake
53BuildRequires: bzip2-devel
54BuildRequires: libtool
49163762 55%{?with_ssl:BuildRequires: openssl-devel}
1a75d3e1 56BuildRequires: pcre-devel
e68efba2 57BuildRequires: rpmbuild(macros) >= 1.159
1a75d3e1 58BuildRequires: zlib-devel
d20e182e 59%if %{with xattr}
60BuildRequires: attr-devel
61%endif
05f8c491
ER
62%{?with_ldap:BuildRequires: openldap-devel}
63%{?with_mysql:BuildRequires: mysql-devel}
dae5a344 64%{?debug:BuildRequires: valgrind}
417e0665 65BuildRequires: rpmbuild(macros) >= 1.202
bee4f74e
AM
66PreReq: rc-scripts
67Requires(pre): sh-utils
68Requires(pre): /bin/id
69Requires(pre): /usr/bin/getgid
70Requires(pre): /usr/sbin/groupadd
71Requires(pre): /usr/sbin/useradd
72Requires(post,preun): /sbin/chkconfig
bee4f74e 73Requires(postun): /usr/sbin/groupdel
e68efba2 74Requires(postun): /usr/sbin/userdel
75Provides: group(lighttpd)
1a75d3e1 76Provides: httpd
e68efba2 77Provides: user(lighttpd)
1a75d3e1 78Provides: webserver
bee4f74e
AM
79BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81%define _libdir %{_prefix}/%{_lib}/%{name}
8d734bed 82%define _lighttpddir /home/services/%{name}
bee4f74e
AM
83%define _sysconfdir /etc/%{name}
84
85%description
f655b1fd 86lighttpd is a secure, fast, compliant and very flexible web-server
ebd2f6ff
ER
87which has been optimized for high-performance environments. It has a
88very low memory footprint compared to other webservers and takes care
89of cpu-load. Its advanced feature-set (FastCGI, CGI, Auth,
bee4f74e
AM
90Output-Compression, URL-Rewriting and many more) make lighttpd the
91perfect webserver-software for every server that is suffering load
92problems.
93
f655b1fd
MC
94%description -l pl
95lighttpd jest bezpiecznym, szybkim, przyjaznym i bardzo elastycznym
1a75d3e1 96