]> git.pld-linux.org Git - packages/liferea.git/commitdiff
- updated for xulrunner 1.9
authorMarcin Banasiak <marcin.banasiak@gmail.com>
Mon, 7 Jul 2008 18:33:25 +0000 (18:33 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    liferea-xulrunner.patch -> 1.3

liferea-xulrunner.patch

index 923ba1075f1a2922358b650384434861c320c3fa..a0da4c051e94c9e696b690fde44c2a35ad5b84fb 100644 (file)
@@ -1,15 +1,17 @@
-diff -urN liferea-1.2.7/src/mozilla/Makefile.am liferea-1.2.7.new/src/mozilla/Makefile.am
---- liferea-1.2.7/src/mozilla/Makefile.am      2006-08-16 01:08:28.000000000 +0200
-+++ liferea-1.2.7.new/src/mozilla/Makefile.am  2007-02-24 21:51:01.000000000 +0100
-@@ -37,14 +37,20 @@
+diff -urN liferea-1.4.16b/src/mozilla/Makefile.am liferea-1.4.16b.new/src/mozilla/Makefile.am
+--- liferea-1.4.16b/src/mozilla/Makefile.am    2007-07-23 19:56:53.000000000 +0200
++++ liferea-1.4.16b.new/src/mozilla/Makefile.am        2008-07-07 18:58:58.000000000 +0200
+@@ -37,14 +37,22 @@
  
  ## the XulRunner support module
  
 +XULRUNNER_EXTRA_CFLAGS = \
++      -I/usr/include/xulrunner \
 +      -I/usr/include/xulrunner/dom \
++      -I/usr/include/xulrunner/gtkembedmoz \
 +      -I/usr/include/xulrunner/necko \
-+      -I/usr/include/xulrunner/pref \
-+      -I/usr/include/xulrunner/webbrwsr
++      -I/usr/include/xulrunner/webbrwsr \
++      -I/usr/include/xulrunner/xpcom
 +
  liblihtmlx_la_SOURCES = \
        mozembed.c mozembed.h \
@@ -19,16 +21,24 @@ diff -urN liferea-1.2.7/src/mozilla/Makefile.am liferea-1.2.7.new/src/mozilla/Ma
  liblihtmlx_la_LIBADD = $(PACKAGE_LIBS) $(XULRUNNER_LIBS) $(INTLLIBS)
 -liblihtmlx_la_CFLAGS = $(XULRUNNER_CFLAGS) $(PACKAGE_CFLAGS)  -DXULRUNNER_HOME=\""$(XULRUNNER_HOME)\""
 -liblihtmlx_la_CXXFLAGS = $(XULRUNNER_CFLAGS) $(PACKAGE_CFLAGS)
-+liblihtmlx_la_CFLAGS = $(XULRUNNER_CFLAGS) $(XULRUNNER_EXTRA_CFLAGS) $(PACKAGE_CFLAGS) -DXULRUNNER_HOME=\""$(XULRUNNER_HOME)\""
++liblihtmlx_la_CFLAGS = $(XULRUNNER_CFLAGS) $(XULRUNNER_EXTRA_CFLAGS) $(PACKAGE_CFLAGS)  -DXULRUNNER_HOME=\""$(XULRUNNER_HOME)\""
 +liblihtmlx_la_CXXFLAGS = $(XULRUNNER_CFLAGS) $(XULRUNNER_EXTRA_CFLAGS) $(PACKAGE_CFLAGS)
  
  if PLATFORM_WIN32
  
-@@ -53,6 +59,6 @@
- else
--liblihtmlx_la_LDFLAGS = -module -avoid-version
-+liblihtmlx_la_LDFLAGS = -R$(XULRUNNER_HOME) -module -avoid-version
- endif
+diff -urN liferea-1.4.16b/src/mozilla/xulrunner.c liferea-1.4.16b.new/src/mozilla/xulrunner.c
+--- liferea-1.4.16b/src/mozilla/xulrunner.c    2007-07-23 19:56:53.000000000 +0200
++++ liferea-1.4.16b.new/src/mozilla/xulrunner.c        2008-07-07 18:54:44.000000000 +0200
+@@ -30,10 +30,12 @@
+ static void xulrunner_init(void) {
+       
++#ifndef XPCOM_GLUE
+       /* gtk_moz_embed_set_comp_path() must not be called
+          without a component path for XulRunner. Passing
+          NULL will crash Liferea. */
+       gtk_moz_embed_set_comp_path(XULRUNNER_HOME);
++#endif
+       mozembed_init();        
+ }
This page took 0.033616 seconds and 4 git commands to generate.