]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
- release 2
[packages/liferea.git] / liferea.spec
1 # TODO:
2 # - create subpackage -lua (?)
3 #
4 # Conditional build:
5 %bcond_without  dbus            # without DBUS support
6 %bcond_without  gtkhtml         # without GtkHTML
7 %bcond_without  xulrunner       # without XULRunner backend
8 %bcond_without  lua             # without LUA scripting support
9 %bcond_with     nm              # with NetworkManager support
10 %bcond_without  webkit          # without WebKit backend
11 #
12 %ifarch %{x8664}
13 %undefine       with_gtkhtml    # GtkHTML backend disabled on x86_64
14 %endif
15 Summary:        A RSS feed reader
16 Summary(pl.UTF-8):      Program do pobierania informacji w formacie RSS
17 Name:           liferea
18 Version:        1.4.17
19 Release:        2
20 License:        GPL v2
21 Group:          X11/Applications/Networking
22 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
23 # Source0-md5:  5600626c3626a3da65423cd7caddaa55
24 Patch0:         %{name}-desktop.patch
25 Patch1:         %{name}-xulrunner.patch
26 Patch2:         %{name}-lua51.patch
27 URL:            http://liferea.sourceforge.net/
28 BuildRequires:  GConf2-devel >= 2.10.0
29 %{?with_nm:BuildRequires:       NetworkManager-devel}
30 BuildRequires:  autoconf >= 2.59
31 BuildRequires:  automake
32 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.33}
33 BuildRequires:  gettext-devel
34 BuildRequires:  gnutls-devel
35 BuildRequires:  gtk+2-devel >= 2:2.8.0
36 %{?with_webkit:BuildRequires:   gtk-webkit-devel}
37 BuildRequires:  intltool >= 0.35.5
38 BuildRequires:  libglade2-devel >= 2.0.0
39 %{?with_gtkhtml:BuildRequires:  libgtkhtml-devel >= 2.6.3}
40 BuildRequires:  libnotify-devel >= 0.3.2
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  libtool
43 BuildRequires:  libxml2-devel >= 1:2.6.27
44 BuildRequires:  libxslt-devel >= 1.1.19
45 %{?with_lua:BuildRequires:      lua51-devel}
46 BuildRequires:  pkgconfig
47 BuildRequires:  rpmbuild(macros) >= 1.311
48 BuildRequires:  sed >= 4.0
49 BuildRequires:  sqlite3-devel
50 %{?with_xulrunner:BuildRequires:        xulrunner-devel >= 1.9-5}
51 Requires(post,postun):  gtk+2
52 Requires(post,postun):  hicolor-icon-theme
53 Requires(post,preun):   GConf2
54 Requires:       %{name}-backend = %{version}-%{release}
55 %ifarch %{x8664}
56 Obsoletes:      liferea-gtkhtml
57 %endif
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
61 # we have strict deps for it
62 %define         _noautoreq      libxpcom.so
63
64 %description
65 Liferea is a GTK+ clone of FeedReader.
66
67 %description -l pl.UTF-8
68 Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
69 FeedReader.
70
71 %package gtkhtml
72 Summary:        GtkHTML module for Liferea
73 Summary(pl.UTF-8):      Moduł GtkHTML dla Liferea
74 Group:          X11/Applications/Networking
75 Requires:       %{name} = %{version}-%{release}
76 Provides:       %{name}-backend = %{version}-%{release}
77
78 %description gtkhtml
79 GtkHTML module for Liferea.
80
81 %description gtkhtml -l pl.UTF-8
82 Moduł GtkHTML dla Liferea.
83
84 %package mozilla
85 Summary:        Mozilla HTML browser module for Liferea
86 Summary(pl.UTF-8):      Moduł przeglądarki HTML dla Liferea oparty na Mozilli
87 Group:          X11/Applications/Networking
88 Requires:       %{name} = %{version}-%{release}
89 %requires_eq_to xulrunner xulrunner-devel
90 Provides:       %{name}-backend = %{version}-%{release}
91
92 %description mozilla
93 Mozilla HTML browser module for Liferea.
94
95 %description mozilla -l pl.UTF-8
96 Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
97
98 %package webkit
99 Summary:        WebKit module for Liferea
100 Summary(pl.UTF-8):      Moduł WebKit dla Liferea
101 Group:          X11/Applications/Networking
102 Requires:       %{name} = %{version}-%{release}
103 Provides:       %{name}-backend = %{version}-%{release}
104
105 %description webkit
106 WebKit module for Liferea.
107
108 %description webkit -l pl.UTF-8
109 Moduł WebKit dla Liferea.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114 %patch1 -p1
115 %patch2 -p1
116
117 %build
118 %{__glib_gettextize}
119 %{__intltoolize}
120 %{__aclocal}
121 %{__libtoolize}
122 %{__autoheader}
123 %{__automake}
124 %{__autoconf}
125 %configure \
126         --disable-schemas-install \
127         --disable-gecko \
128         %{!?with_dbus: --disable-dbus} \
129         %{!?with_gtkhtml: --disable-gtkhtml2} \
130         %{!?with_lua: --disable-lua} \
131         %{!?with_nm: --disable-nm} \
132         %{!?with_xulrunner: --disable-xulrunner} \
133         %{!?with_webkit: --disable-webkit}
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT \
141         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
142
143 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
144
145 %find_lang %{name}
146
147 %post
148 %gconf_schema_install liferea.schemas
149 %update_icon_cache hicolor
150
151 %preun
152 %gconf_schema_uninstall liferea.schemas
153
154 %postun
155 %update_icon_cache hicolor
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %files -f %{name}.lang
161 %defattr(644,root,root,755)
162 %doc AUTHORS ChangeLog NEWS README
163 %attr(755,root,root) %{_bindir}/liferea
164 %attr(755,root,root) %{_bindir}/liferea-add-feed
165 %attr(755,root,root) %{_bindir}/liferea-bin
166 %dir %{_libdir}/%{name}
167 %attr(755,root,root) %{_libdir}/%{name}/liblinotiflibnotify.so
168 %{_iconsdir}/hicolor/48x48/apps/liferea.png
169 %{_sysconfdir}/gconf/schemas/liferea.schemas
170 %{_datadir}/%{name}
171 %{_desktopdir}/*.desktop
172 %{_mandir}/man1/liferea.1*
173 %{_mandir}/pl/man1/liferea.1*
174 %if %{with lua}
175 %attr(755,root,root) %{_libdir}/%{name}/libliscrlua.so
176 %endif
177
178 %if %{with gtkhtml}
179 %files gtkhtml
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so
182 %endif
183
184 %if %{with xulrunner}
185 %files mozilla
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so
188 %endif
189
190 %if %{with webkit}
191 %files webkit
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlw.so
194 %endif
This page took 0.075503 seconds and 3 git commands to generate.