]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
- release 2
[packages/liferea.git] / liferea.spec
1 # TODO:
2 # - create subpackage -lua (?)
3 # - webkit support
4 #
5 # Conditional build:
6 %bcond_without  dbus            # without DBUS support
7 %bcond_without  gtkhtml         # without GtkHTML
8 %bcond_without  xulrunner       # without XULRunner backend
9 %bcond_without  lua             # without LUA scripting support
10 %bcond_with     nm              # with NetworkManager support
11 #
12 %ifarch %{x8664}
13 %undefine       with_gtkhtml    # GtkHTML backend disabled on x86_64
14 %endif
15 Summary:        A RSS feed reader
16 Summary(pl.UTF-8):      Program do pobierania informacji w formacie RSS
17 Name:           liferea
18 Version:        1.4.15
19 Release:        2
20 License:        GPL v2
21 Group:          X11/Applications/Networking
22 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
23 # Source0-md5:  e4ae96a0d41d94c31271ba791caec922
24 Patch0:         %{name}-desktop.patch
25 Patch1:         %{name}-xulrunner.patch
26 Patch2:         %{name}-lua51.patch
27 URL:            http://liferea.sourceforge.net/
28 BuildRequires:  GConf2-devel >= 2.10.0
29 %{?with_nm:BuildRequires:       NetworkManager-devel}
30 BuildRequires:  autoconf >= 2.59
31 BuildRequires:  automake
32 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.33}
33 BuildRequires:  gettext-devel
34 BuildRequires:  gnutls-devel
35 BuildRequires:  gtk+2-devel >= 2:2.8.0
36 BuildRequires:  intltool >= 0.35.5
37 BuildRequires:  libglade2-devel >= 2.0.0
38 %{?with_gtkhtml:BuildRequires:  libgtkhtml-devel >= 2.6.3}
39 BuildRequires:  libnotify-devel >= 0.3.2
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libtool
42 BuildRequires:  libxml2-devel >= 1:2.6.27
43 BuildRequires:  libxslt-devel >= 1.1.19
44 %{?with_lua:BuildRequires:      lua51-devel}
45 BuildRequires:  pkgconfig
46 BuildRequires:  rpmbuild(macros) >= 1.311
47 BuildRequires:  sqlite3-devel
48 %{?with_xulrunner:BuildRequires:        xulrunner-devel}
49 Requires(post,postun):  gtk+2
50 Requires(post,postun):  hicolor-icon-theme
51 Requires(post,preun):   GConf2
52 Requires:       %{name}-backend = %{version}-%{release}
53 %ifarch %{x8664}
54 Obsoletes:      liferea-gtkhtml
55 %endif
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
59 # we have strict deps for it
60 %define         _noautoreq      libxpcom.so
61
62 %description
63 Liferea is a GTK+ clone of FeedReader.
64
65 %description -l pl.UTF-8
66 Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
67 FeedReader.
68
69 %package gtkhtml
70 Summary:        GtkHTML module for Liferea
71 Summary(pl.UTF-8):      Moduł GtkHTML dla Liferea
72 Group:          X11/Applications/Networking
73 Requires:       %{name} = %{version}-%{release}
74 Provides:       %{name}-backend = %{version}-%{release}
75
76 %description gtkhtml
77 GtkHTML module for Liferea.
78
79 %description gtkhtml -l pl.UTF-8
80 Moduł GtkHTML dla Liferea.
81
82 %package mozilla
83 Summary:        Mozilla HTML browser module for Liferea
84 Summary(pl.UTF-8):      Moduł przeglądarki HTML dla Liferea oparty na Mozilli
85 Group:          X11/Applications/Networking
86 Requires:       %{name} = %{version}-%{release}
87 %requires_eq_to xulrunner xulrunner-devel
88 Provides:       %{name}-backend = %{version}-%{release}
89
90 %description mozilla
91 Mozilla HTML browser module for Liferea.
92
93 %description mozilla -l pl.UTF-8
94 Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 %patch1 -p1
100 %patch2 -p1
101
102 %build
103 %{__glib_gettextize}
104 %{__intltoolize}
105 %{__aclocal}
106 %{__libtoolize}
107 %{__autoheader}
108 %{__automake}
109 %{__autoconf}
110 %configure \
111         --disable-schemas-install \
112         %{!?with_dbus: --disable-dbus} \
113         %{!?with_gtkhtml: --disable-gtkhtml2} \
114         %{!?with_lua: --disable-lua} \
115         %{!?with_nm: --disable-nm} \
116         %{!?with_xulrunner: --disable-xulrunner}
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT \
124         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
125
126 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
127
128 %find_lang %{name}
129
130 %post
131 %gconf_schema_install liferea.schemas
132 %update_icon_cache hicolor
133
134 %preun
135 %gconf_schema_uninstall liferea.schemas
136
137 %postun
138 %update_icon_cache hicolor
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %files -f %{name}.lang
144 %defattr(644,root,root,755)
145 %doc AUTHORS ChangeLog NEWS README
146 %attr(755,root,root) %{_bindir}/liferea
147 %attr(755,root,root) %{_bindir}/liferea-add-feed
148 %attr(755,root,root) %{_bindir}/liferea-bin
149 %dir %{_libdir}/%{name}
150 %attr(755,root,root) %{_libdir}/%{name}/liblinotiflibnotify.so
151 %{_iconsdir}/hicolor/48x48/apps/liferea.png
152 %{_sysconfdir}/gconf/schemas/liferea.schemas
153 %{_datadir}/%{name}
154 %{_desktopdir}/*.desktop
155 %{_mandir}/man1/liferea.1*
156 %{_mandir}/pl/man1/liferea.1*
157 %if %{with lua}
158 %attr(755,root,root) %{_libdir}/%{name}/libliscrlua.so
159 %endif
160
161 %if %{with gtkhtml}
162 %files gtkhtml
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so
165 %endif
166
167 %if %{with xulrunner}
168 %files mozilla
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so
171 %endif
This page took 0.049898 seconds and 3 git commands to generate.