]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
- fixed in 1.4.6
[packages/liferea.git] / liferea.spec
1 # TODO: create subpackage -lua (?)
2 #
3 # Conditional build:
4 %bcond_without  dbus            # without DBUS support
5 %bcond_without  gtkhtml         # without GtkHTML
6 %bcond_without  xulrunner       # without XULRunner backend
7 %bcond_without  lua             # without LUA scripting support
8 %bcond_with     nm              # with NetworkManager support
9 #
10 %ifarch %{x8664}
11 %undefine       with_gtkhtml    # GtkHTML backend disabled on x86_64
12 %endif
13 Summary:        A RSS feed reader
14 Summary(pl.UTF-8):      Program do pobierania informacji w formacie RSS
15 Name:           liferea
16 Version:        1.4.6
17 Release:        1
18 License:        GPL v2
19 Group:          X11/Applications/Networking
20 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
21 # Source0-md5:  d38257cf130a43041e5f416e12ae94c5
22 Patch0:         %{name}-desktop.patch
23 Patch1:         %{name}-xulrunner.patch
24 Patch2:         %{name}-lua51.patch
25 URL:            http://liferea.sourceforge.net/
26 BuildRequires:  GConf2-devel >= 2.10.0
27 BuildRequires:  autoconf >= 2.59
28 BuildRequires:  automake
29 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.33}
30 BuildRequires:  gtk+2-devel >= 2:2.8.0
31 BuildRequires:  intltool >= 0.35.5
32 %{?with_gtkhtml:BuildRequires:  libgtkhtml-devel >= 2.6.3}
33 BuildRequires:  libnotify-devel >= 0.3.2
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  libtool
36 BuildRequires:  libxml2-devel >= 1:2.6.19
37 BuildRequires:  libxslt-devel >= 1.1.19
38 %{?with_lua:BuildRequires:      lua51-devel}
39 %{?with_nm:BuildRequires:       NetworkManager-devel}
40 BuildRequires:  pkgconfig
41 BuildRequires:  rpmbuild(macros) >= 1.311
42 %{?with_xulrunner:BuildRequires:        xulrunner-devel}
43 Requires(post,postun):  gtk+2
44 Requires(post,postun):  hicolor-icon-theme
45 Requires(post,preun):   GConf2
46 Requires:       %{name}-backend = %{version}-%{release}
47 %ifarch %{x8664}
48 Obsoletes:      liferea-gtkhtml
49 %endif
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
53 # we have strict deps for it
54 %define         _noautoreq      libxpcom.so
55
56 %description
57 Liferea is a GTK+ clone of FeedReader.
58
59 %description -l pl.UTF-8
60 Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
61 FeedReader.
62
63 %package gtkhtml
64 Summary:        GtkHTML module for Liferea
65 Summary(pl.UTF-8):      Moduł GtkHTML dla Liferea
66 Group:          X11/Applications/Networking
67 Requires:       %{name} = %{version}-%{release}
68 Provides:       %{name}-backend = %{version}-%{release}
69
70 %description gtkhtml
71 GtkHTML module for Liferea.
72
73 %description gtkhtml -l pl.UTF-8
74 Moduł GtkHTML dla Liferea.
75
76 %package mozilla
77 Summary:        Mozilla HTML browser module for Liferea
78 Summary(pl.UTF-8):      Moduł przeglądarki HTML dla Liferea oparty na Mozilli
79 Group:          X11/Applications/Networking
80 Requires:       %{name} = %{version}-%{release}
81 %requires_eq_to xulrunner xulrunner-devel
82 Provides:       %{name}-backend = %{version}-%{release}
83
84 %description mozilla
85 Mozilla HTML browser module for Liferea.
86
87 %description mozilla -l pl.UTF-8
88 Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
89
90 %prep
91 %setup -q
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95
96 %build
97 %{__glib_gettextize}
98 %{__intltoolize}
99 %{__aclocal}
100 %{__libtoolize}
101 %{__autoheader}
102 %{__automake}
103 %{__autoconf}
104 %configure \
105         --disable-schemas-install \
106         %{!?with_dbus: --disable-dbus} \
107         %{!?with_gtkhtml: --disable-gtkhtml2} \
108         %{!?with_lua: --disable-lua} \
109         %{!?with_nm: --disable-nm} \
110         %{!?with_xulrunner: --disable-xulrunner}
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT \
118         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
119
120 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
121
122 %find_lang %{name}
123
124 %post
125 %gconf_schema_install liferea.schemas
126 %update_icon_cache hicolor
127
128 %preun
129 %gconf_schema_uninstall liferea.schemas
130
131 %postun
132 %update_icon_cache hicolor
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %files -f %{name}.lang
138 %defattr(644,root,root,755)
139 %doc AUTHORS ChangeLog NEWS README
140 %attr(755,root,root) %{_bindir}/*
141 %dir %{_libdir}/%{name}
142 %attr(755,root,root) %{_libdir}/%{name}/*.so.*.*.*
143 %{_iconsdir}/hicolor/48x48/apps/liferea.png
144 %{_mandir}/pl/man1/liferea.1*
145 %{_sysconfdir}/gconf/schemas/liferea.schemas
146 %{_datadir}/%{name}
147 %{_desktopdir}/*.desktop
148 %{_mandir}/man1/liferea.1*
149 %if %{with lua}
150 %attr(755,root,root) %{_libdir}/%{name}/libliscrlua.so
151 %endif
152
153 %if %{with gtkhtml}
154 %files gtkhtml
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so*
157 %endif
158
159 %if %{with xulrunner}
160 %files mozilla
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so*
163 %endif
This page took 0.03327 seconds and 3 git commands to generate.