]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
- add missing AC_PROG_CXX
[packages/liferea.git] / liferea.spec
1 # TODO:
2 # - create subpackage -lua (?)
3 #
4 # Conditional build:
5 %bcond_without  dbus            # without DBUS support
6 %bcond_without  gtkhtml         # without GtkHTML
7 %bcond_without  xulrunner       # without XULRunner backend
8 %bcond_without  lua             # without LUA scripting support
9 %bcond_with     nm              # with NetworkManager support
10 %bcond_without  webkit          # without WebKit backend
11 #
12 %ifarch %{x8664}
13 %undefine       with_gtkhtml    # GtkHTML backend disabled on x86_64
14 %endif
15 Summary:        A RSS feed reader
16 Summary(pl.UTF-8):      Program do pobierania informacji w formacie RSS
17 Name:           liferea
18 Version:        1.4.22d
19 Release:        1
20 License:        GPL v2
21 Group:          X11/Applications/Networking
22 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
23 # Source0-md5:  0a942170ee16a61330982a1cbc7f936f
24 Patch0:         %{name}-desktop.patch
25 Patch1:         %{name}-xulrunner.patch
26 Patch2:         %{name}-lua51.patch
27 Patch3:         %{name}-ac.patch
28 URL:            http://liferea.sourceforge.net/
29 BuildRequires:  GConf2-devel >= 2.10.0
30 %{?with_nm:BuildRequires:       NetworkManager-devel}
31 BuildRequires:  autoconf >= 2.59
32 BuildRequires:  automake
33 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.33}
34 BuildRequires:  gettext-devel
35 BuildRequires:  gnutls-devel
36 BuildRequires:  gtk+2-devel >= 2:2.8.0
37 %{?with_webkit:BuildRequires:   gtk-webkit-devel}
38 BuildRequires:  intltool >= 0.35.5
39 BuildRequires:  libglade2-devel >= 2.0.0
40 %{?with_gtkhtml:BuildRequires:  libgtkhtml-devel >= 2.6.3}
41 BuildRequires:  libnotify-devel >= 0.3.2
42 BuildRequires:  libstdc++-devel
43 BuildRequires:  libtool
44 BuildRequires:  libxml2-devel >= 1:2.6.27
45 BuildRequires:  libxslt-devel >= 1.1.19
46 %{?with_lua:BuildRequires:      lua51-devel}
47 BuildRequires:  pkgconfig
48 BuildRequires:  rpmbuild(macros) >= 1.311
49 BuildRequires:  sed >= 4.0
50 BuildRequires:  sqlite3-devel
51 %{?with_xulrunner:BuildRequires:        xulrunner-devel >= 1.9-5}
52 Requires(post,postun):  gtk+2
53 Requires(post,postun):  hicolor-icon-theme
54 Requires(post,preun):   GConf2
55 Requires:       %{name}-backend = %{version}-%{release}
56 %ifarch %{x8664}
57 Obsoletes:      liferea-gtkhtml
58 %endif
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
62 # we have strict deps for it
63 %define         _noautoreq      libxpcom.so
64
65 %description
66 Liferea is a GTK+ clone of FeedReader.
67
68 %description -l pl.UTF-8
69 Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
70 FeedReader.
71
72 %package gtkhtml
73 Summary:        GtkHTML module for Liferea
74 Summary(pl.UTF-8):      Moduł GtkHTML dla Liferea
75 Group:          X11/Applications/Networking
76 Requires:       %{name} = %{version}-%{release}
77 Provides:       %{name}-backend = %{version}-%{release}
78
79 %description gtkhtml
80 GtkHTML module for Liferea.
81
82 %description gtkhtml -l pl.UTF-8
83 Moduł GtkHTML dla Liferea.
84
85 %package mozilla
86 Summary:        Mozilla HTML browser module for Liferea
87 Summary(pl.UTF-8):      Moduł przeglądarki HTML dla Liferea oparty na Mozilli
88 Group:          X11/Applications/Networking
89 Requires:       %{name} = %{version}-%{release}
90 %requires_eq_to xulrunner xulrunner-devel
91 Provides:       %{name}-backend = %{version}-%{release}
92
93 %description mozilla
94 Mozilla HTML browser module for Liferea.
95
96 %description mozilla -l pl.UTF-8
97 Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
98
99 %package webkit
100 Summary:        WebKit module for Liferea
101 Summary(pl.UTF-8):      Moduł WebKit dla Liferea
102 Group:          X11/Applications/Networking
103 Requires:       %{name} = %{version}-%{release}
104 Provides:       %{name}-backend = %{version}-%{release}
105
106 %description webkit
107 WebKit module for Liferea.
108
109 %description webkit -l pl.UTF-8
110 Moduł WebKit dla Liferea.
111
112 %prep
113 %setup -q
114 %patch0 -p1
115 %patch1 -p1
116 %patch2 -p1
117 %patch3 -p1
118
119 %build
120 %{__glib_gettextize}
121 %{__intltoolize}
122 %{__aclocal} -I m4
123 %{__libtoolize}
124 %{__autoheader}
125 %{__automake}
126 %{__autoconf}
127 %configure \
128         --disable-schemas-install \
129         %{!?with_dbus: --disable-dbus} \
130         %{!?with_gtkhtml: --disable-gtkhtml2} \
131         %{!?with_lua: --disable-lua} \
132         %{!?with_nm: --disable-nm} \
133         %{!?with_xulrunner: --disable-gecko} \
134         %{!?with_webkit: --disable-webkit}
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT \
142         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
143
144 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
145
146 %find_lang %{name}
147
148 %post
149 %gconf_schema_install liferea.schemas
150 %update_icon_cache hicolor
151
152 %preun
153 %gconf_schema_uninstall liferea.schemas
154
155 %postun
156 %update_icon_cache hicolor
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %files -f %{name}.lang
162 %defattr(644,root,root,755)
163 %doc AUTHORS ChangeLog NEWS README
164 %attr(755,root,root) %{_bindir}/liferea
165 %attr(755,root,root) %{_bindir}/liferea-add-feed
166 %attr(755,root,root) %{_bindir}/liferea-bin
167 %dir %{_libdir}/%{name}
168 %attr(755,root,root) %{_libdir}/%{name}/liblinotiflibnotify.so
169 %{_iconsdir}/hicolor/48x48/apps/liferea.png
170 %{_sysconfdir}/gconf/schemas/liferea.schemas
171 %{_datadir}/%{name}
172 %{_desktopdir}/*.desktop
173 %{_mandir}/man1/liferea.1*
174 %{_mandir}/pl/man1/liferea.1*
175 %if %{with lua}
176 %attr(755,root,root) %{_libdir}/%{name}/libliscrlua.so
177 %endif
178
179 %if %{with gtkhtml}
180 %files gtkhtml
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so
183 %endif
184
185 %if %{with xulrunner}
186 %files mozilla
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so
189 %endif
190
191 %if %{with webkit}
192 %files webkit
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlw.so
195 %endif
This page took 0.104429 seconds and 3 git commands to generate.