]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
1cd4c7e05dc9dbf1a6e9634521ab2a8fa4743143
[packages/liferea.git] / liferea.spec
1 # TODO:
2 # - create subpackage -lua (?)
3 # - webkit support
4 #
5 # Conditional build:
6 %bcond_without  dbus            # without DBUS support
7 %bcond_without  gtkhtml         # without GtkHTML
8 %bcond_without  xulrunner       # without XULRunner backend
9 %bcond_without  lua             # without LUA scripting support
10 %bcond_with     nm              # with NetworkManager support
11 #
12 %ifarch %{x8664}
13 %undefine       with_gtkhtml    # GtkHTML backend disabled on x86_64
14 %endif
15 Summary:        A RSS feed reader
16 Summary(pl.UTF-8):      Program do pobierania informacji w formacie RSS
17 Name:           liferea
18 Version:        1.4.11
19 Release:        2
20 License:        GPL v2
21 Group:          X11/Applications/Networking
22 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
23 # Source0-md5:  b96a479a4b72560cbdd8df8b7efd24b3
24 Patch0:         %{name}-desktop.patch
25 Patch1:         %{name}-xulrunner.patch
26 Patch2:         %{name}-lua51.patch
27 Patch3:         %{name}-no_versioned_soname.patch
28 URL:            http://liferea.sourceforge.net/
29 BuildRequires:  GConf2-devel >= 2.10.0
30 %{?with_nm:BuildRequires:       NetworkManager-devel}
31 BuildRequires:  autoconf >= 2.59
32 BuildRequires:  automake
33 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.33}
34 BuildRequires:  gettext-devel
35 BuildRequires:  gnutls-devel
36 BuildRequires:  gtk+2-devel >= 2:2.8.0
37 BuildRequires:  intltool >= 0.35.5
38 BuildRequires:  libglade2-devel >= 2.0.0
39 %{?with_gtkhtml:BuildRequires:  libgtkhtml-devel >= 2.6.3}
40 BuildRequires:  libnotify-devel >= 0.3.2
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  libtool
43 BuildRequires:  libxml2-devel >= 1:2.6.27
44 BuildRequires:  libxslt-devel >= 1.1.19
45 %{?with_lua:BuildRequires:      lua51-devel}
46 BuildRequires:  pkgconfig
47 BuildRequires:  rpmbuild(macros) >= 1.311
48 BuildRequires:  sqlite3-devel
49 %{?with_xulrunner:BuildRequires:        xulrunner-devel}
50 Requires(post,postun):  gtk+2
51 Requires(post,postun):  hicolor-icon-theme
52 Requires(post,preun):   GConf2
53 Requires:       %{name}-backend = %{version}-%{release}
54 %ifarch %{x8664}
55 Obsoletes:      liferea-gtkhtml
56 %endif
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
60 # we have strict deps for it
61 %define         _noautoreq      libxpcom.so
62
63 %description
64 Liferea is a GTK+ clone of FeedReader.
65
66 %description -l pl.UTF-8
67 Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
68 FeedReader.
69
70 %package gtkhtml
71 Summary:        GtkHTML module for Liferea
72 Summary(pl.UTF-8):      Moduł GtkHTML dla Liferea
73 Group:          X11/Applications/Networking
74 Requires:       %{name} = %{version}-%{release}
75 Provides:       %{name}-backend = %{version}-%{release}
76
77 %description gtkhtml
78 GtkHTML module for Liferea.
79
80 %description gtkhtml -l pl.UTF-8
81 Moduł GtkHTML dla Liferea.
82
83 %package mozilla
84 Summary:        Mozilla HTML browser module for Liferea
85 Summary(pl.UTF-8):      Moduł przeglądarki HTML dla Liferea oparty na Mozilli
86 Group:          X11/Applications/Networking
87 Requires:       %{name} = %{version}-%{release}
88 %requires_eq_to xulrunner xulrunner-devel
89 Provides:       %{name}-backend = %{version}-%{release}
90
91 %description mozilla
92 Mozilla HTML browser module for Liferea.
93
94 %description mozilla -l pl.UTF-8
95 Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101 %patch2 -p1
102 %patch3 -p1
103
104 %build
105 %{__glib_gettextize}
106 %{__intltoolize}
107 %{__aclocal}
108 %{__libtoolize}
109 %{__autoheader}
110 %{__automake}
111 %{__autoconf}
112 %configure \
113         --disable-schemas-install \
114         %{!?with_dbus: --disable-dbus} \
115         %{!?with_gtkhtml: --disable-gtkhtml2} \
116         %{!?with_lua: --disable-lua} \
117         %{!?with_nm: --disable-nm} \
118         %{!?with_xulrunner: --disable-xulrunner}
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT \
126         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
127
128 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
129
130 %find_lang %{name}
131
132 %post
133 %gconf_schema_install liferea.schemas
134 %update_icon_cache hicolor
135
136 %preun
137 %gconf_schema_uninstall liferea.schemas
138
139 %postun
140 %update_icon_cache hicolor
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %files -f %{name}.lang
146 %defattr(644,root,root,755)
147 %doc AUTHORS ChangeLog NEWS README
148 %attr(755,root,root) %{_bindir}/liferea
149 %attr(755,root,root) %{_bindir}/liferea-add-feed
150 %attr(755,root,root) %{_bindir}/liferea-bin
151 %dir %{_libdir}/%{name}
152 %attr(755,root,root) %{_libdir}/%{name}/liblinotiflibnotify.so
153 %{_iconsdir}/hicolor/48x48/apps/liferea.png
154 %{_sysconfdir}/gconf/schemas/liferea.schemas
155 %{_datadir}/%{name}
156 %{_desktopdir}/*.desktop
157 %{_mandir}/man1/liferea.1*
158 %{_mandir}/pl/man1/liferea.1*
159 %if %{with lua}
160 %attr(755,root,root) %{_libdir}/%{name}/libliscrlua.so
161 %endif
162
163 %if %{with gtkhtml}
164 %files gtkhtml
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so
167 %endif
168
169 %if %{with xulrunner}
170 %files mozilla
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so
173 %endif
This page took 0.087945 seconds and 2 git commands to generate.