]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
- up to 1.0.0 RC4
[packages/liferea.git] / liferea.spec
1 # Conditional build:
2 %bcond_without  dbus            # without DBUS support
3 %bcond_without  mozilla         # without mozilla
4 %bcond_without  gtkhtml         # without GtkHTML
5 %bcond_with     mozilla_firefox # build with mozilla-firefox-devel
6 #
7 Summary:        A RSS feed reader
8 Summary(pl):    Program do pobierania informacji w formacie RSS
9 Name:           liferea
10 Version:        1.0
11 %define         _rc RC4
12 Release:        1.%{_rc}.1
13 License:        GPL
14 Group:          X11/Applications/Networking
15 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}-%{_rc}.tar.gz
16 # Source0-md5:  593df5a7743b3ec8925a68605bef22da
17 Patch0:         %{name}-desktop.patch
18 URL:            http://liferea.sourceforge.net/
19 BuildRequires:  GConf2-devel >= 2.10.0
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.33}
23 BuildRequires:  gtk+2-devel >= 2:2.6.4
24 BuildRequires:  libxml2-devel >= 1:2.6.19
25 %{?with_gtkhtml:BuildRequires:  libgtkhtml-devel >= 2.6.3}
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool
28 %if %{with mozilla}
29 %if %{with mozilla_firefox}
30 BuildRequires:  mozilla-firefox-devel
31 %else
32 BuildRequires:  mozilla-devel
33 %endif
34 %endif
35 BuildRequires:  pkgconfig
36 BuildRequires:  rpmbuild(macros) >= 1.197
37 Requires(post,preun):   GConf2
38 Requires:       %{name}-backend = %{version}-%{release}
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
42
43 %description
44 Liferea is a GTK+ clone of FeedReader.
45
46 %description -l pl
47 Liferea jest klonem, napisanym za pomoc± biblioteki GTK+, programu
48 FeedReader.
49
50 %package gtkhtml
51 Summary:        GtkHTML module for Liferea
52 Summary(pl):    Modu³ GtkHTML dla Liferea
53 Group:          X11/Applications/Networking
54 Requires:       %{name} = %{version}-%{release}
55 Provides:       %{name}-backend = %{version}-%{release}
56
57 %description gtkhtml
58 GtkHTML module for Liferea.
59
60 %description gtkhtml -l pl
61 Modu³ GtkHTML dla Liferea.
62
63 %package mozilla
64 Summary:        Mozilla HTML browser module for Liferea
65 Summary(pl):    Modu³ przegl±darki HTML dla Liferea oparty na Mozilli
66 Group:          X11/Applications/Networking
67 Requires:       %{name} = %{version}-%{release}
68 %if %{with mozilla_firefox}
69 %requires_eq    mozilla-firefox
70 %else
71 Requires:       mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
72 %endif
73 Provides:       %{name}-backend = %{version}-%{release}
74
75 %description mozilla
76 Mozilla HTML browser module for Liferea.
77
78 %description mozilla -l pl
79 Modu³ przegl±darki HTML dla Liferea oparty na Mozilli.
80
81 %prep
82 %setup -q -n %{name}-%{version}-%{_rc}
83 %patch0 -p1
84
85 %build
86 %{__glib_gettextize}
87 %{__aclocal}
88 %{__libtoolize}
89 %{__autoheader}
90 %{__automake}
91 %{__autoconf}
92 %configure \
93         --disable-schemas-install \
94         %{!?with_dbus: --disable-dbus} \
95         %{!?with_gtkhtml: --disable-gtkhtml2} \
96         %{!?with_mozilla: --disable-gecko}
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT \
104         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
105
106 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
107
108 %find_lang %{name}
109
110 %post
111 %gconf_schema_install liferea.schemas
112
113 %preun
114 %gconf_schema_uninstall liferea.schemas
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %files -f %{name}.lang
120 %defattr(644,root,root,755)
121 %doc AUTHORS ChangeLog NEWS README
122 %attr(755,root,root) %{_bindir}/*
123 %dir %{_libdir}/%{name}
124 %{_sysconfdir}/gconf/schemas/*.schemas
125 %{_datadir}/%{name}
126 %{_desktopdir}/*
127 %{_pixmapsdir}/*
128 %{_mandir}/man1/liferea.1*
129
130 %if %{with gtkhtml}
131 %files gtkhtml
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so*
134 %endif
135
136 %if %{with mozilla}
137 %files mozilla
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlm.so*
140 %endif
This page took 0.071864 seconds and 3 git commands to generate.