]> git.pld-linux.org Git - packages/libxcrypt.git/commitdiff
- release 2, x32 buildfix auto/th/libxcrypt-4.4.0-2
authorAdam Gołębiowski <adamg@pld-linux.org>
Mon, 28 Jan 2019 06:41:34 +0000 (07:41 +0100)
committerAdam Gołębiowski <adamg@pld-linux.org>
Mon, 28 Jan 2019 06:41:34 +0000 (07:41 +0100)
0001-Add-x32-specific-inline-asm.patch [new file with mode: 0644]
libxcrypt.spec

diff --git a/0001-Add-x32-specific-inline-asm.patch b/0001-Add-x32-specific-inline-asm.patch
new file mode 100644 (file)
index 0000000..9e31b03
--- /dev/null
@@ -0,0 +1,42 @@
+From 7d01f2acf6fde6341a68a91f9b343841cc424af7 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 17 Dec 2018 11:33:35 -0800
+Subject: [PATCH] Add x32 specific inline asm
+
+Upstream-Status: Pending [https://github.com/besser82/libxcrypt/issues/74#issuecomment-447966455]
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ alg-yescrypt-opt.c | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/alg-yescrypt-opt.c b/alg-yescrypt-opt.c
+index 5dbd822..060caf4 100644
+--- a/alg-yescrypt-opt.c
++++ b/alg-yescrypt-opt.c
+@@ -528,6 +528,11 @@ static volatile uint64_t Smask2var = Smask2;
+ #undef MAYBE_MEMORY_BARRIER
+ #define MAYBE_MEMORY_BARRIER \
+       __asm__("" : : : "memory");
++#ifdef __ILP32__ /* x32 */
++#define REGISTER_PREFIX "e"
++#else
++#define REGISTER_PREFIX "r"
++#endif
+ #define PWXFORM_SIMD(X) { \
+       __m128i H; \
+       __asm__( \
+@@ -537,8 +542,8 @@ static volatile uint64_t Smask2var = Smask2;
+           "pmuludq %1, %0\n\t" \
+           "movl %%eax, %%ecx\n\t" \
+           "shrq $0x20, %%rax\n\t" \
+-          "paddq (%3,%%rcx), %0\n\t" \
+-          "pxor (%4,%%rax), %0\n\t" \
++          "paddq (%3,%%" REGISTER_PREFIX "cx), %0\n\t" \
++          "pxor (%4,%%" REGISTER_PREFIX "ax), %0\n\t" \
+           : "+x" (X), "=x" (H) \
+           : "d" (Smask2), "S" (S0), "D" (S1) \
+           : "cc", "ax", "cx"); \
+-- 
+2.20.1
+
index 54f5378bdd3ff0c7ff1a2a829f160c9d04c85a73..5d5636ac4a9b89b5fad0cdc42d27e359da09946b 100644 (file)
@@ -2,13 +2,14 @@ Summary:      Crypt Library for DES, MD5, and Blowfish
 Summary(pl.UTF-8):     Biblioteka szyfrująca hasła obsługująca DES, MD5 i Blowfish
 Name:          libxcrypt
 Version:       4.4.0
-Release:       1
+Release:       2
 License:       LGPL v2.1+
 Group:         Libraries
 #Source0Download: https://github.com/besser82/libxcrypt/releases
 Source0:       https://github.com/besser82/libxcrypt/archive/v%{version}/%{name}-%{version}.tar.gz
 # Source0-md5: 13e9f41b9881956c529a028b636ff22b
 Patch0:                %{name}-xcrypt.patch
+Patch1:                0001-Add-x32-specific-inline-asm.patch
 URL:           https://github.com/besser82/libxcrypt
 BuildRequires: autoconf >= 2.62
 BuildRequires: automake >= 1:1.14
@@ -60,6 +61,7 @@ Ten pakiet zawiera statyczną wersję biblioteki libxcrypt.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
This page took 0.166076 seconds and 4 git commands to generate.