]> git.pld-linux.org Git - packages/libxcrypt.git/blob - libxcrypt.spec
580b09f4a284893b74d0dd63a9d56d453449a51d
[packages/libxcrypt.git] / libxcrypt.spec
1 #
2 # Conditional build:
3 %bcond_without  default_crypt   # build as default libcrypt provider
4
5 Summary:        Crypt Library for DES, MD5, and Blowfish
6 Summary(pl.UTF-8):      Biblioteka szyfrująca hasła obsługująca DES, MD5 i Blowfish
7 Name:           libxcrypt
8 Version:        4.4.27
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 #Source0Download: https://github.com/besser82/libxcrypt/releases
13 Source0:        https://github.com/besser82/libxcrypt/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  c9d5dd34bc9e6a0b53b1b206e02ecf9d
15 Patch0:         %{name}-xcrypt.patch
16 URL:            https://github.com/besser82/libxcrypt
17 BuildRequires:  autoconf >= 2.62
18 BuildRequires:  automake >= 1:1.14
19 BuildRequires:  gcc >= 5:3.2
20 BuildRequires:  libltdl-devel
21 BuildRequires:  libtool >= 2:2
22 BuildRequires:  pkgconfig >= 1:0.27
23 %if %{with default_crypt}
24 Provides:       crypt(blowfish)
25 Obsoletes:      glibc-libcrypt
26 %endif
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %undefine       __cxx
30
31 %if %{with default_crypt}
32 %define         libname         libcrypt
33 %define         libver          1
34 %else
35 %define         libname         libxcrypt
36 %define         libver          2
37 %endif
38
39 %description
40 libxcrypt is a replacement for libcrypt, which comes with the GNU C
41 Library. It supports DES crypt, MD5, and passwords with Blowfish
42 encryption.
43
44 %description -l pl.UTF-8
45 libxcrypt to zamiennik biblioteki libcrypt dostarczanej wraz z
46 biblioteką GNU C (libc). Obsługuje szyfrowanie haseł DES, MD5 oraz
47 Blowfish.
48
49 %package devel
50 Summary:        Header file for libxcrypt
51 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki libxcrypt
52 License:        LGPL v2.1+
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 %{?with_default_crypt:Conflicts:        glibc-devel-doc < 6:2.34-7}
56
57 %description devel
58 This package contains the header file to develop software using
59 libxcrypt.
60
61 %description devel -l pl.UTF-8
62 Ten pakiet zawiera plik nagłówkowy pozwalający na tworzenie programów
63 korzystających z libxcrypt.
64
65 %package static
66 Summary:        Static libxcrypt library
67 Summary(pl.UTF-8):      Statyczna biblioteka libxcrypt
68 License:        LGPL v2.1+
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 This package contains the static libxcrypt library used for
74 development.
75
76 %description static -l pl.UTF-8
77 Ten pakiet zawiera statyczną wersję biblioteki libxcrypt.
78
79 %prep
80 %setup -q
81 %{!?with_default_crypt:%patch0 -p1}
82
83 %build
84 %{__libtoolize}
85 %{__aclocal}
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90 %if %{with default_crypt}
91         --enable-obsolete-api=glibc \
92         --enable-obsolete-api-enosys=yes \
93 %else
94         --includedir=%{_includedir}/xcrypt \
95         --disable-xcrypt-compat-files \
96 %endif
97         --disable-werror
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT/%{_lib}
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 %{__mv} $RPM_BUILD_ROOT%{_libdir}/%{libname}.so.* $RPM_BUILD_ROOT/%{_lib}
108 ln -snf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/%{libname}.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/%{libname}.so
109
110 # obsoleted by pkg-config
111 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{libname}.la
112
113 %if %{without default_crypt}
114 # PLD doesn't need Owl compatibility
115 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libowcrypt.*
116 # packaged with glibc-devel
117 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/crypt{,_r,_ra,_rn}.3*
118 %endif
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %posttrans
127 if [ ! -L /%{_lib}/%{libname}.so.%{libver} ]; then
128         %{__rm} -f /%{_lib}/%{libname}.so.%{libver}
129         /sbin/ldconfig
130 fi
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS ChangeLog LICENSING NEWS README.md THANKS TODO.md
135 %attr(755,root,root) /%{_lib}/%{libname}.so.*.*.*
136 %attr(755,root,root) %ghost /%{_lib}/%{libname}.so.%{libver}
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/%{libname}.so
141 %if %{with default_crypt}
142 %{_includedir}/crypt.h
143 %{_includedir}/xcrypt.h
144 %attr(755,root,root) %{_libdir}/libxcrypt.so
145 %else
146 %{_includedir}/xcrypt
147 %endif
148 %{_pkgconfigdir}/libcrypt.pc
149 %{_pkgconfigdir}/libxcrypt.pc
150 %{_mandir}/man3/crypt_checksalt.3*
151 %{_mandir}/man3/crypt_gensalt*.3*
152 %{_mandir}/man3/crypt_preferred_method.3*
153 %if %{with default_crypt}
154 %{_mandir}/man3/crypt.3*
155 %{_mandir}/man3/crypt_r.3*
156 %{_mandir}/man3/crypt_ra.3*
157 %{_mandir}/man3/crypt_rn.3*
158 %endif
159 %{_mandir}/man5/crypt.5*
160
161 %files static
162 %defattr(644,root,root,755)
163 %{_libdir}/%{libname}.a
164 %if %{with default_crypt}
165 %{_libdir}/libxcrypt.a
166 %endif
This page took 0.09326 seconds and 2 git commands to generate.