]> git.pld-linux.org Git - packages/libxcrypt.git/blob - libxcrypt.spec
- explicit /usr/include/*.h files (in default_crypt case)
[packages/libxcrypt.git] / libxcrypt.spec
1 #
2 # Conditional build:
3 %bcond_with     default_crypt   # build as default libcrypt provider
4
5 Summary:        Crypt Library for DES, MD5, and Blowfish
6 Summary(pl.UTF-8):      Biblioteka szyfrująca hasła obsługująca DES, MD5 i Blowfish
7 Name:           libxcrypt
8 Version:        4.4.17
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 #Source0Download: https://github.com/besser82/libxcrypt/releases
13 Source0:        https://github.com/besser82/libxcrypt/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  12118d098ead971f9a8377cacfdd0da7
15 Patch0:         %{name}-xcrypt.patch
16 URL:            https://github.com/besser82/libxcrypt
17 BuildRequires:  autoconf >= 2.62
18 BuildRequires:  automake >= 1:1.14
19 BuildRequires:  gcc >= 5:3.2
20 BuildRequires:  libtool >= 2:2
21 BuildRequires:  pkgconfig >= 1:0.27
22 %if %{with default_crypt}
23 Provides:       crypt(blowfish)
24 Obsoletes:      glibc-libcrypt
25 %endif
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %undefine       __cxx
29
30 %if %{with default_crypt}
31 %define         libname         libcrypt
32 %define         libver          1
33 %else
34 %define         libname         libxcrypt
35 %define         libver          2
36 %endif
37
38
39 %description
40 libxcrypt is a replacement for libcrypt, which comes with the GNU C
41 Library. It supports DES crypt, MD5, and passwords with Blowfish
42 encryption.
43
44 %description -l pl.UTF-8
45 libxcrypt to zamiennik biblioteki libcrypt dostarczanej wraz z
46 biblioteką GNU C (libc). Obsługuje szyfrowanie haseł DES, MD5 oraz
47 Blowfish.
48
49 %package devel
50 Summary:        Header file for libxcrypt
51 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki libxcrypt
52 License:        LGPL v2.1+
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55
56 %description devel
57 This package contains the header file to develop software using
58 libxcrypt.
59
60 %description devel -l pl.UTF-8
61 Ten pakiet zawiera plik nagłówkowy pozwalający na tworzenie programów
62 korzystających z libxcrypt.
63
64 %package static
65 Summary:        Static libxcrypt library
66 Summary(pl.UTF-8):      Statyczna biblioteka libxcrypt
67 License:        LGPL v2.1+
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 This package contains the static libxcrypt library used for
73 development.
74
75 %description static -l pl.UTF-8
76 Ten pakiet zawiera statyczną wersję biblioteki libxcrypt.
77
78 %prep
79 %setup -q
80 %{!?with_default_crypt:%patch0 -p1}
81
82 %build
83 %{__libtoolize}
84 %{__aclocal} -I m4
85 %{__autoconf}
86 %{__autoheader}
87 %{__automake}
88 %configure \
89         %{!?with_default_crypt:--includedir=%{_includedir}/xcrypt} \
90         --disable-werror \
91         --disable-xcrypt-compat-files
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT/%{_lib}
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 %{__mv} $RPM_BUILD_ROOT%{_libdir}/%{libname}.so.* $RPM_BUILD_ROOT/%{_lib}
102 ln -snf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/%{libname}.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/%{libname}.so
103
104 # obsoleted by pkg-config
105 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{libname}.la
106 # PLD doesn't need Owl compatibility
107 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libowcrypt.*
108 # packaged with glibc-devel
109 %{!?with_default_crypt:%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/crypt{,_r,_ra,_rn}.3*}
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS ChangeLog LICENSING NEWS README.md THANKS TODO.md
120 %attr(755,root,root) /%{_lib}/%{libname}.so.*.*.*
121 %attr(755,root,root) %ghost /%{_lib}/%{libname}.so.%{libver}
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/%{libname}.so
126 %if %{with default_crypt}
127 %{_includedir}/crypt.h
128 %else
129 %{_includedir}/xcrypt
130 %endif
131 %{_pkgconfigdir}/libcrypt.pc
132 %{_pkgconfigdir}/libxcrypt.pc
133 %{_mandir}/man3/crypt_checksalt.3*
134 %{_mandir}/man3/crypt_gensalt*.3*
135 %{_mandir}/man3/crypt_preferred_method.3*
136 %if %{with default_crypt}
137 %{_mandir}/man3/crypt.3*
138 %{_mandir}/man3/crypt_r.3*
139 %{_mandir}/man3/crypt_ra.3*
140 %{_mandir}/man3/crypt_rn.3*
141 %endif
142 %{_mandir}/man5/crypt.5*
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/%{libname}.a
This page took 0.090772 seconds and 3 git commands to generate.