]> git.pld-linux.org Git - packages/libx264.git/commitdiff
up to 20190110 snap (new soname) auto/th/libx264-0.1.3-1.20190110_2245.1
authorJan Palus <atler@pld-linux.org>
Fri, 11 Jan 2019 20:04:39 +0000 (21:04 +0100)
committerJan Palus <atler@pld-linux.org>
Fri, 11 Jan 2019 20:05:45 +0000 (21:05 +0100)
ffmpeg3.patch [deleted file]
libx264.spec
x32.patch

diff --git a/ffmpeg3.patch b/ffmpeg3.patch
deleted file mode 100644 (file)
index 34d4fcd..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-diff -ur x264-snapshot-20140824-2245.orig/input/lavf.c x264-snapshot-20140824-2245/input/lavf.c
---- x264-snapshot-20140824-2245.orig/input/lavf.c      2014-08-25 05:45:04.000000000 +0900
-+++ x264-snapshot-20140824-2245/input/lavf.c   2016-03-31 22:59:10.138953287 +0900
-@@ -83,7 +83,7 @@
-     AVCodecContext *c = h->lavf->streams[h->stream_id]->codec;
-     AVPacket *pkt = p_pic->opaque;
--    avcodec_get_frame_defaults( h->frame );
-+    av_frame_unref( h->frame );
-     while( i_frame >= h->next_frame )
-     {
-@@ -153,7 +153,7 @@
-     if( !strcmp( psz_filename, "-" ) )
-         psz_filename = "pipe:";
--    h->frame = avcodec_alloc_frame();
-+    h->frame = av_frame_alloc();
-     if( !h->frame )
-         return -1;
-@@ -253,7 +253,7 @@
-     avcodec_close( h->lavf->streams[h->stream_id]->codec );
-     avformat_close_input( &h->lavf );
- #if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(54, 28, 0)
--    avcodec_free_frame( &h->frame );
-+    av_frame_free( &h->frame );
- #else
-     av_freep( &h->frame );
- #endif
-diff -ur x264-snapshot-20140824-2245.orig/x264.c x264-snapshot-20140824-2245/x264.c
---- x264-snapshot-20140824-2245.orig/x264.c    2014-08-25 05:45:04.000000000 +0900
-+++ x264-snapshot-20140824-2245/x264.c 2016-03-31 22:58:07.680765885 +0900
-@@ -434,7 +434,7 @@
-     printf( "                              - valid csps for `lavf' demuxer:\n" );
-     printf( INDENT );
-     size_t line_len = strlen( INDENT );
--    for( enum PixelFormat i = AV_PIX_FMT_NONE+1; i < AV_PIX_FMT_NB; i++ )
-+    for( enum AVPixelFormat i = AV_PIX_FMT_NONE+1; i < AV_PIX_FMT_NB; i++ )
-     {
-         const char *pfname = av_get_pix_fmt_name( i );
-         if( pfname )
index ba56695dbbff18a90e1bb9fcd6b6f1aa20957079..2ced7bb70de687a9a84ec018ed4e16d6b0add9ea 100644 (file)
@@ -7,8 +7,8 @@
 %undefine      with_asm
 %endif
 
-%define                rel     8
-%define                snap    20140824
+%define                rel     1
+%define                snap    20190110
 %define                snaph   2245
 Summary:       H264 encoder library
 Summary(pl.UTF-8):     Biblioteka kodująca H264
@@ -19,15 +19,14 @@ License:    GPL v2+
 Group:         Libraries
 # still no releases, use snapshots
 Source0:       ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{snap}-%{snaph}.tar.bz2
-# Source0-md5: d2a779a864254ca426dfb1f3115987a0
+# Source0-md5: ef5f7a7eec118f4641e743a894de90c4
 Patch0:                %{name}-alpha.patch
 Patch1:                altivec-no-vand.patch
 Patch2:                %{name}-gpac.patch
 Patch3:                x32.patch
-Patch4:                ffmpeg3.patch
 URL:           http://www.videolan.org/developers/x264.html
+%{?with_asm:BuildRequires:     nasm >= 2.13}
 BuildRequires: pkgconfig
-%{?with_asm:BuildRequires:     yasm >= 1.2.0}
 %if %{without bootstrap}
 # which version exactly???
 # for full x264 CLI utility functionality it wants:
@@ -96,7 +95,6 @@ Dekoder x264 działający z linii poleceń.
 %endif
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
 
 %build
 CC="%{__cc}" \
@@ -130,7 +128,7 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS
-%attr(755,root,root) %{_libdir}/libx264.so.142
+%attr(755,root,root) %{_libdir}/libx264.so.157
 
 %files devel
 %defattr(644,root,root,755)
index 7e83423826e8976486e982a2789da31d66328932..2633dfde2ceb4a7418b229f1657171f496e80cb5 100644 (file)
--- a/x32.patch
+++ b/x32.patch
@@ -2,36 +2,36 @@
 +++ x264-snapshot-20140824-2245/configure      2015-03-05 18:47:39.881867944 +0000
 @@ -594,8 +594,8 @@
              if [[ "$asm" == auto && "$CFLAGS" != *-mfpmath* ]]; then
-                 CFLAGS="$CFLAGS -mfpmath=sse -msse"
+                 CFLAGS="$CFLAGS -mfpmath=sse -msse -msse2"
              fi
 -            CFLAGS="-m32 $CFLAGS"
 -            LDFLAGS="-m32 $LDFLAGS"
 +            CFLAGS="$CFLAGS"
 +            LDFLAGS="$LDFLAGS"
-         elif [ $compiler = ICC ]; then
-             # icc on linux has various degrees of mod16 stack support
-             if [ $SYS = LINUX ]; then
+         fi
+         if [ "$SYS" = MACOSX ]; then
+             ASFLAGS="$ASFLAGS -f macho32 -DPREFIX"
 @@ -627,7 +627,7 @@
-         ARCH="X86_64"
-         AS="yasm"
+         AS_EXT=".asm"
          ASFLAGS="$ASFLAGS -DARCH_X86_64=1 -I\$(SRCPATH)/common/x86/"
+         stack_alignment=16
 -        [ $compiler = GNU ] && CFLAGS="-m64 $CFLAGS" && LDFLAGS="-m64 $LDFLAGS"
 +        [ $compiler = GNU ] && CFLAGS="$CFLAGS" && LDFLAGS="$LDFLAGS"
          if [ "$SYS" = MACOSX ]; then
-             ASFLAGS="$ASFLAGS -f macho64 -m amd64 -DPIC -DPREFIX"
+             ASFLAGS="$ASFLAGS -f macho64 -DPIC -DPREFIX"
              if cc_check '' "-arch x86_64"; then
 @@ -641,7 +641,14 @@
-             [ $compiler = GNU ] && LDFLAGS="$LDFLAGS -Wl,--nxcompat -Wl,--dynamicbase"
-             [ $compiler = GNU ] && RCFLAGS="--target=pe-x86-64 $RCFLAGS"
+                 RCFLAGS="--target=pe-x86-64 $RCFLAGS"
+             fi
          else
 +        case "$host_os" in
 +              *gnux32)
-+                      ASFLAGS="$ASFLAGS -f elfx32 -m amd64"
++                      ASFLAGS="$ASFLAGS -f elfx32"
 +              ;;
 +              *)
-             ASFLAGS="$ASFLAGS -f elf -m amd64"
+             ASFLAGS="$ASFLAGS -f elf64"
 +          ;;
 +        esac
          fi
          ;;
-     powerpc|powerpc64)
+     powerpc*)
This page took 0.147981 seconds and 4 git commands to generate.