]> git.pld-linux.org Git - packages/libx264.git/blob - libx264.spec
- up to 20091118_2245
[packages/libx264.git] / libx264.spec
1 %define         snap    20091118
2 %define         snaph   2245
3 %define         rel     1
4 Summary:        H264 encoder library
5 Summary(pl.UTF-8):      Biblioteka kodująca H264
6 Name:           libx264
7 Version:        0.1.2
8 Release:        1.%{snap}_%{snaph}.%{rel}
9 License:        GPL v2+
10 Group:          Libraries
11 # unofficial, debianized/libtoolized packaging:
12 #Source0:       http://www.acarlab.com/misc-dnlds/%{name}-%{version}.tar.gz
13 # but it's too old, so use snapshots...
14 Source0:        ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{snap}-%{snaph}.tar.bz2
15 # Source0-md5:  2aba19167fa145785a76e1525fad5627
16 Patch0:         %{name}-alpha.patch
17 Patch1:         %{name}-syms.patch
18 URL:            http://www.videolan.org/developers/x264.html
19 BuildRequires:  gettext-devel
20 BuildRequires:  pkgconfig
21 %ifarch %{ix86} %{x8664}
22 BuildRequires:  yasm >= 0.6.0
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 # encoder/macroblock.c breaks strict-aliasing rules
27 %define         specflags       -fno-strict-aliasing
28
29 %description
30 libx264 library for encoding H264 video format.
31
32 %description -l pl.UTF-8
33 Biblioteka libx264 do kodowania w formacie obrazu H264.
34
35 %package devel
36 Summary:        Header files for x264 library
37 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki x264
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Header files for x264 library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki x264.
46
47 %package static
48 Summary:        Static x264 library
49 Summary(pl.UTF-8):      Statyczna biblioteka x264
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static x264 library.
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka x264.
58
59 %prep
60 %setup -q -n x264-snapshot-%{snap}-%{snaph}
61 %patch0 -p1
62 %patch1 -p1
63 sed -i 's:-O4::g' configure
64
65 %build
66 CC="%{__cc}" \
67 ./configure \
68         --prefix=%{_prefix} \
69         --exec-prefix=%{_prefix} \
70         --bindir=%{_bindir} \
71         --includedir=%{_includedir} \
72         --libdir=%{_libdir} \
73         --extra-cflags="%{rpmcflags}" \
74         --enable-pic \
75         --enable-shared
76
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post   -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %files
92 %defattr(644,root,root,755)
93 %doc AUTHORS
94 %attr(755,root,root) %{_bindir}/x264
95 %attr(755,root,root) %{_libdir}/libx264.so.[0-9][0-9]
96
97 %files devel
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_libdir}/libx264.so
100 %{_includedir}/x264.h
101 %{_pkgconfigdir}/x264.pc
102
103 %files static
104 %defattr(644,root,root,755)
105 %{_libdir}/libx264.a
This page took 0.149436 seconds and 3 git commands to generate.