]> git.pld-linux.org Git - packages/libwpe.git/blob - libwpe.spec
776ec0ce1bed272b593f155fc72464ebc0a97bc6
[packages/libwpe.git] / libwpe.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4
5 Summary:        General-purpose library for the WPE-flavored port of WebKit
6 Summary(pl.UTF-8):      Ogólna biblioteka do portu WPE biblioteki WebKit
7 Name:           libwpe
8 Version:        1.16.0
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://github.com/WebPlatformForEmbedded/libwpe/releases
13 Source0:        https://github.com/WebPlatformForEmbedded/libwpe/releases/download/%{version}/%{name}-%{version}.tar.xz
14 # Source0-md5:  9779115aaa7e67abe642777394e7bfa2
15 Patch0:         %{name}-libdir.patch
16 URL:            https://wpewebkit.org/
17 BuildRequires:  EGL-devel
18 BuildRequires:  cmake >= 3.0
19 %{?with_apidocs:BuildRequires:  hotdoc}
20 BuildRequires:  libstdc++-devel >= 6:4.7
21 BuildRequires:  rpm-build >= 4.6
22 BuildRequires:  rpmbuild(macros) >= 1.605
23 BuildRequires:  xorg-lib-libxkbcommon-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 General-purpose library developed for the WPE-flavored port of WebKit.
28
29 %description -l pl.UTF-8
30 Ogólna biblioteka do portu WPE biblioteki WebKit.
31
32 %package devel
33 Summary:        Header files for WPE library
34 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki WPE
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       EGL-devel
38 Requires:       xorg-lib-libxkbcommon-devel
39
40 %description devel
41 Header files for WPE library.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki WPE.
45
46 %package apidocs
47 Summary:        API documentation for WPE library
48 Summary(pl.UTF-8):      Dokumentacja API biblioteki WPE
49 Group:          Documentation
50 BuildArch:      noarch
51
52 %description apidocs
53 API documentation for WPE library.
54
55 %description apidocs -l pl.UTF-8
56 Dokumentacja API biblioteki WPE.
57
58 %prep
59 %setup -q
60 %patch0 -p1
61
62 %build
63 install -d build
64 cd build
65 %cmake .. \
66         %{?with_apidocs:-DBUILD_DOCS=ON}
67
68 %{__make}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} -C build install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(644,root,root,755)
84 %doc COPYING NEWS
85 %attr(755,root,root) %{_libdir}/libwpe-1.0.so.*.*.*
86 %attr(755,root,root) %ghost %{_libdir}/libwpe-1.0.so.1
87
88 %files devel
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_libdir}/libwpe-1.0.so
91 %{_includedir}/wpe-1.0
92 %{_pkgconfigdir}/wpe-1.0.pc
93
94 %if %{with apidocs}
95 %files apidocs
96 %defattr(644,root,root,755)
97 %doc build/Documentation/html/*
98 %endif
This page took 0.124612 seconds and 3 git commands to generate.