]> git.pld-linux.org Git - packages/libvirt.git/commitdiff
up to 4.1.0 auto/th/libvirt-4.1.0-1
authorJan Palus <atler@pld-linux.org>
Mon, 5 Mar 2018 23:49:25 +0000 (00:49 +0100)
committerJan Palus <atler@pld-linux.org>
Mon, 5 Mar 2018 23:49:25 +0000 (00:49 +0100)
- upstream patch to prevent linking against system libvirt

libvirt-link.patch [new file with mode: 0644]
libvirt-sasl.patch
libvirt.spec

diff --git a/libvirt-link.patch b/libvirt-link.patch
new file mode 100644 (file)
index 0000000..265b713
--- /dev/null
@@ -0,0 +1,175 @@
+From 43523d7421a3cb0a729ce8a44a5843fbd0a96dcf Mon Sep 17 00:00:00 2001
+From: Jan Palus <atler@pld-linux.org>
+Date: Mon, 5 Mar 2018 16:39:48 +0100
+Subject: [PATCH] make sure libvirt is linked first
+
+so it's not affected by flags that might be passed in $(*_LIBS) like
+-L/usr/lib which might result in linking against system library and
+requiring incorrect version of private symbols
+
+Signed-off-by: Jan Palus <atler@pld-linux.org>
+---
+ src/Makefile.am         |   29 +++++++++++++++--------------
+ src/lxc/Makefile.inc.am |    2 +-
+ tools/Makefile.am       |    2 +-
+ 3 files changed, 17 insertions(+), 16 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 3bf2da5..7f3144b 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1153,6 +1153,9 @@ libvirtd_LDFLAGS = \
+       $(NULL)
+ libvirtd_LDADD = \
++      libvirt-lxc.la \
++      libvirt-qemu.la \
++      libvirt.la \
+       $(LIBXML_LIBS) \
+       $(GNUTLS_LIBS) \
+       $(SASL_LIBS) \
+@@ -1166,9 +1169,6 @@ endif WITH_DTRACE_PROBES
+ libvirtd_LDADD += \
+       libvirt_driver_admin.la \
+-      libvirt-lxc.la \
+-      libvirt-qemu.la \
+-      libvirt.la \
+       ../gnulib/lib/libgnu.la $(LIBSOCKET) \
+       $(NULL)
+@@ -1222,7 +1222,7 @@ libvirt_driver_interface_la_CFLAGS = \
+               -I$(srcdir)/conf \
+               $(AM_CFLAGS) $(LIBNL_CFLAGS)
+ libvirt_driver_interface_la_LDFLAGS = $(AM_LDFLAGS_MOD_NOUNDEF)
+-libvirt_driver_interface_la_LIBADD =
++libvirt_driver_interface_la_LIBADD = libvirt.la
+ if WITH_NETCF
+ libvirt_driver_interface_la_CFLAGS += $(NETCF_CFLAGS)
+ libvirt_driver_interface_la_LIBADD += $(NETCF_LIBS)
+@@ -1231,7 +1231,7 @@ if WITH_UDEV
+ libvirt_driver_interface_la_CFLAGS += $(UDEV_CFLAGS)
+ libvirt_driver_interface_la_LIBADD += $(UDEV_LIBS)
+ endif WITH_UDEV
+-libvirt_driver_interface_la_LIBADD += libvirt.la ../gnulib/lib/libgnu.la
++libvirt_driver_interface_la_LIBADD += ../gnulib/lib/libgnu.la
+ libvirt_driver_interface_la_SOURCES = $(INTERFACE_DRIVER_SOURCES)
+ endif WITH_INTERFACE
+@@ -1323,7 +1323,7 @@ endif WITH_STORAGE_SCSI
+ if WITH_STORAGE_MPATH
+ libvirt_storage_backend_mpath_la_SOURCES = \
+       $(STORAGE_DRIVER_MPATH_SOURCES)
+-libvirt_storage_backend_mpath_la_LIBADD = $(DEVMAPPER_LIBS)
++libvirt_storage_backend_mpath_la_LIBADD = libvirt.la $(DEVMAPPER_LIBS)
+ libvirt_storage_backend_mpath_la_CFLAGS = \
+       -I$(srcdir)/conf \
+       $(DEVMAPPER_CFLAGS) \
+@@ -1331,7 +1331,7 @@ libvirt_storage_backend_mpath_la_CFLAGS = \
+ storagebackend_LTLIBRARIES += libvirt_storage_backend_mpath.la
+ libvirt_storage_backend_mpath_la_LDFLAGS = $(AM_LDFLAGS_MOD)
+-libvirt_storage_backend_mpath_la_LIBADD += libvirt.la ../gnulib/lib/libgnu.la
++libvirt_storage_backend_mpath_la_LIBADD += ../gnulib/lib/libgnu.la
+ endif WITH_STORAGE_MPATH
+ if WITH_STORAGE_DISK
+@@ -1347,7 +1347,7 @@ endif WITH_STORAGE_DISK
+ if WITH_STORAGE_RBD
+ libvirt_storage_backend_rbd_la_SOURCES = $(STORAGE_DRIVER_RBD_SOURCES)
+-libvirt_storage_backend_rbd_la_LIBADD = $(LIBRBD_LIBS)
++libvirt_storage_backend_rbd_la_LIBADD = libvirt.la $(LIBRBD_LIBS)
+ libvirt_storage_backend_rbd_la_CFLAGS = \
+       -I$(srcdir)/conf \
+       -I$(srcdir)/secret \
+@@ -1355,7 +1355,7 @@ libvirt_storage_backend_rbd_la_CFLAGS = \
+ storagebackend_LTLIBRARIES += libvirt_storage_backend_rbd.la
+ libvirt_storage_backend_rbd_la_LDFLAGS = $(AM_LDFLAGS_MOD)
+-libvirt_storage_backend_rbd_la_LIBADD += libvirt.la ../gnulib/lib/libgnu.la
++libvirt_storage_backend_rbd_la_LIBADD += ../gnulib/lib/libgnu.la
+ endif WITH_STORAGE_RBD
+ if WITH_STORAGE_SHEEPDOG
+@@ -1380,7 +1380,7 @@ endif WITH_STORAGE_SHEEPDOG
+ if WITH_STORAGE_GLUSTER
+ libvirt_storage_backend_gluster_la_SOURCES = \
+       $(STORAGE_DRIVER_GLUSTER_SOURCES)
+-libvirt_storage_backend_gluster_la_LIBADD = $(GLUSTERFS_LIBS)
++libvirt_storage_backend_gluster_la_LIBADD = libvirt.la $(GLUSTERFS_LIBS)
+ libvirt_storage_backend_gluster_la_CFLAGS = \
+       -I$(srcdir)/conf \
+       $(GLUSTERFS_CFLAGS) \
+@@ -1388,7 +1388,7 @@ libvirt_storage_backend_gluster_la_CFLAGS = \
+ storagebackend_LTLIBRARIES += libvirt_storage_backend_gluster.la
+ libvirt_storage_backend_gluster_la_LDFLAGS = $(AM_LDFLAGS_MOD)
+-libvirt_storage_backend_gluster_la_LIBADD += libvirt.la ../gnulib/lib/libgnu.la
++libvirt_storage_backend_gluster_la_LIBADD += ../gnulib/lib/libgnu.la
+ endif WITH_STORAGE_GLUSTER
+ if WITH_STORAGE_ZFS
+@@ -1424,7 +1424,7 @@ libvirt_driver_nodedev_la_CFLAGS = \
+               -I$(srcdir)/conf \
+               $(AM_CFLAGS) $(LIBNL_CFLAGS)
+ libvirt_driver_nodedev_la_LDFLAGS = $(AM_LDFLAGS_MOD_NOUNDEF)
+-libvirt_driver_nodedev_la_LIBADD =
++libvirt_driver_nodedev_la_LIBADD = libvirt.la
+ if WITH_HAL
+ libvirt_driver_nodedev_la_SOURCES += $(NODE_DEVICE_DRIVER_HAL_SOURCES)
+@@ -1437,7 +1437,7 @@ libvirt_driver_nodedev_la_CFLAGS += $(UDEV_CFLAGS) $(PCIACCESS_CFLAGS)
+ libvirt_driver_nodedev_la_LIBADD += $(UDEV_LIBS) $(PCIACCESS_LIBS)
+ endif WITH_UDEV
+-libvirt_driver_nodedev_la_LIBADD += libvirt.la ../gnulib/lib/libgnu.la
++libvirt_driver_nodedev_la_LIBADD += ../gnulib/lib/libgnu.la
+ endif WITH_NODE_DEVICES
+@@ -1456,10 +1456,11 @@ libvirt_driver_nwfilter_impl_la_CFLAGS = \
+               $(AM_CFLAGS)
+ libvirt_driver_nwfilter_impl_la_LDFLAGS = $(AM_LDFLAGS)
+ libvirt_driver_nwfilter_impl_la_LIBADD = \
++              libvirt.la \
+               $(LIBPCAP_LIBS) \
+               $(LIBNL_LIBS) \
+               $(DBUS_LIBS)
+-libvirt_driver_nwfilter_impl_la_LIBADD += libvirt.la ../gnulib/lib/libgnu.la
++libvirt_driver_nwfilter_impl_la_LIBADD += ../gnulib/lib/libgnu.la
+ libvirt_driver_nwfilter_impl_la_SOURCES = $(NWFILTER_DRIVER_SOURCES)
+ endif WITH_NWFILTER
+diff --git a/src/lxc/Makefile.inc.am b/src/lxc/Makefile.inc.am
+index 8a3d4c4..8dd2e9e 100644
+--- a/src/lxc/Makefile.inc.am
++++ b/src/lxc/Makefile.inc.am
+@@ -121,8 +121,8 @@ libvirt_lxc_LDFLAGS = \
+       $(LIBXML_LIBS) \
+       $(NULL)
+ libvirt_lxc_LDADD = \
+-      $(FUSE_LIBS) \
+       libvirt.la \
++      $(FUSE_LIBS) \
+       ../gnulib/lib/libgnu.la \
+       $(NULL)
+ if WITH_DTRACE_PROBES
+diff --git a/tools/Makefile.am b/tools/Makefile.am
+index 85e640b..1452d98 100644
+--- a/tools/Makefile.am
++++ b/tools/Makefile.am
+@@ -139,9 +139,9 @@ libvirt_shell_la_LDFLAGS = \
+               $(COVERAGE_LDFLAGS) \
+               $(NULL)
+ libvirt_shell_la_LIBADD = \
++              ../src/libvirt.la \
+               $(LIBXML_LIBS) \
+               $(READLINE_LIBS) \
+-              ../src/libvirt.la \
+               ../gnulib/lib/libgnu.la \
+               $(NULL)
+ libvirt_shell_la_SOURCES = vsh.c vsh.h
+-- 
+1.7.1
+
index 46782b5218293724a9f86b1cea518e9454d46060..ec5a98a12b6c948668ff31ce144c9fd669f3e631 100644 (file)
@@ -1,6 +1,6 @@
 diff -dur -x '*~' -x '*.orig' -x '*.rej' libvirt-2.5.0.orig/daemon/libvirtd.conf libvirt-2.5.0/daemon/libvirtd.conf
---- libvirt-2.5.0.orig/daemon/libvirtd.conf    2016-06-27 16:12:20.000000000 +0200
-+++ libvirt-2.5.0/daemon/libvirtd.conf 2016-12-20 12:56:04.000000000 +0100
+--- libvirt-2.5.0.orig/src/remote/libvirtd.conf        2016-06-27 16:12:20.000000000 +0200
++++ libvirt-2.5.0/src/remote/libvirtd.conf     2016-12-20 12:56:04.000000000 +0100
 @@ -123,7 +123,7 @@
  #          the network providing auth (eg, TLS/x509 certificates)
  #
@@ -20,19 +20,19 @@ diff -dur -x '*~' -x '*.orig' -x '*.rej' libvirt-2.5.0.orig/daemon/libvirtd.conf
  
  # Change the authentication scheme for TLS sockets.
 diff -dur -x '*~' -x '*.orig' -x '*.rej' libvirt-2.5.0.orig/daemon/Makefile.am libvirt-2.5.0/daemon/Makefile.am
---- libvirt-2.5.0.orig/daemon/Makefile.am      2016-11-30 13:57:30.000000000 +0100
-+++ libvirt-2.5.0/daemon/Makefile.am   2016-12-20 12:56:04.000000000 +0100
+--- libvirt-2.5.0.orig/src/Makefile.am 2016-11-30 13:57:30.000000000 +0100
++++ libvirt-2.5.0/src/Makefile.am      2016-12-20 12:56:04.000000000 +0100
 @@ -532,13 +532,13 @@
  # the WITH_LIBVIRTD conditional
  if WITH_SASL
- install-data-sasl:
+ install-sasl:
 -      $(MKDIR_P) $(DESTDIR)$(sysconfdir)/sasl2/
 +      $(MKDIR_P) $(DESTDIR)$(sysconfdir)/sasl/
-       $(INSTALL_DATA) $(srcdir)/libvirtd.sasl \
+       $(INSTALL_DATA) $(srcdir)/remote/libvirtd.sasl \
 -              $(DESTDIR)$(sysconfdir)/sasl2/libvirt.conf
 +              $(DESTDIR)$(sysconfdir)/sasl/libvirt.conf
  
- uninstall-data-sasl:
+ uninstall-sasl:
 -      rm -f $(DESTDIR)$(sysconfdir)/sasl2/libvirt.conf
 -      rmdir $(DESTDIR)$(sysconfdir)/sasl2/ || :
 +      rm -f $(DESTDIR)$(sysconfdir)/sasl/libvirt.conf
index 54ecdef95936390dfb66624fd4c472f573c195ce..87adcf48104231240ed6cf9c2137aa92405ebb20 100644 (file)
 Summary:       Toolkit to interact with virtualization capabilities
 Summary(pl.UTF-8):     Narzędzia współpracujące z funkcjami wirtualizacji
 Name:          libvirt
-Version:       4.0.0
-Release:       2
+Version:       4.1.0
+Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       http://libvirt.org/sources/libvirt-%{version}.tar.xz
-# Source0-md5: ff0dbdd8ec4ac1277588dfe3b245d0e9
+# Source0-md5: 30b95c458da4f8c3d073a82755815997
 Source1:       %{name}.init
 Source2:       %{name}.tmpfiles
 Patch0:                %{name}-sasl.patch
@@ -61,6 +61,7 @@ Patch4:               %{name}-udevadm-settle.patch
 Patch5:                vserver.patch
 Patch6:                bashisms.patch
 Patch7:                %{name}-guests.init.patch
+Patch8:                %{name}-link.patch
 URL:           http://www.libvirt.org/
 BuildRequires: acl-devel
 BuildRequires: attr-devel
@@ -483,6 +484,7 @@ Moduł sekcji Wiresharka do pakietów libvirt.
 %{?with_vserver:%patch5 -p1}
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
 
 %build
 %{__libtoolize}
@@ -675,6 +677,8 @@ fi
 
 %files -n bash-completion-%{name}
 %defattr(644,root,root,755)
+/etc/bash_completion.d/virsh
+/etc/bash_completion.d/virt-admin
 /etc/bash_completion.d/vsh
 
 %files devel
@@ -737,8 +741,10 @@ fi
 %{systemdunitdir}/virt-guest-shutdown.target
 %{systemdunitdir}/virtlockd.service
 %{systemdunitdir}/virtlockd.socket
+%{systemdunitdir}/virtlockd-admin.socket
 %{systemdunitdir}/virtlogd.service
 %{systemdunitdir}/virtlogd.socket
+%{systemdunitdir}/virtlogd-admin.socket
 %config(noreplace) %verify(not md5 mtime size) /usr/lib/sysctl.d/60-libvirtd.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd
 %attr(755,root,root) %{_libexecdir}/libvirt_iohelper
This page took 0.139547 seconds and 4 git commands to generate.