]> git.pld-linux.org Git - packages/libvirt.git/blob - libvirt.spec
add missing rc-scripts service scriptlets
[packages/libvirt.git] / libvirt.spec
1 #
2 # TODO:
3 # - kill CFLAGS from libvirt.pc:Libs
4 # - seems that lxc patch is not needed anymore, verify that before removing
5 # - pldize virtlockd.init
6 #
7 # Conditional build:
8 %bcond_without  ceph            # RADOS BD (Ceph) storage support
9 %bcond_without  esx             # VMware ESX support
10 %bcond_without  glusterfs       # GlusterFS storage support
11 %bcond_without  hyperv          # Hyper-V support
12 %bcond_without  libxl           # libxenlight support
13 %bcond_without  lxc             # LXC support
14 %bcond_without  netcf           # host interfaces support
15 %bcond_without  openvz          # OpenVZ support
16 %bcond_without  phyp            # PHYP support
17 %bcond_without  polkit          # PolicyKit support
18 %bcond_without  qemu            # Qemu support
19 %bcond_without  sanlock         # sanlock storage lock manager
20 %bcond_without  systemtap       # systemtap/dtrace probes
21 %bcond_without  uml             # UML support
22 %bcond_without  vbox            # VirtualBox support
23 %bcond_without  vmware          # VMware Workstation/Player support
24 %bcond_with     vserver         # Support for Linux-VServer guests
25 %bcond_without  xenapi          # Xen API (Citrix XenServer) support
26 %bcond_without  xen             # Xen support
27 %bcond_without  static_libs     # static libraries build
28
29 # qemu available only on x86 and ppc
30 %ifnarch %{ix86} %{x8664} ppc
31 %undefine       with_qemu
32 %endif
33 # Xen is available only on x86 and ia64
34 %ifnarch %{ix86} %{x8664} ia64
35 %undefine       with_xen
36 %endif
37 Summary:        Toolkit to interact with virtualization capabilities
38 Summary(pl.UTF-8):      Narzędzia współpracujące z funkcjami wirtualizacji
39 Name:           libvirt
40 Version:        1.2.1
41 Release:        2
42 License:        LGPL v2.1+
43 Group:          Libraries
44 Source0:        ftp://ftp.libvirt.org/libvirt/%{name}-%{version}.tar.gz
45 # Source0-md5:  cce374220f67895afb6331bd2ddedbfd
46 Source1:        %{name}.init
47 Source2:        %{name}.tmpfiles
48 Patch0:         %{name}-sasl.patch
49 Patch1:         %{name}-lxc.patch
50 Patch2:         %{name}-qemu-acl.patch
51 Patch3:         %{name}-xend.patch
52 Patch4:         virtlockd.init.patch
53 Patch5:         %{name}-udevadm-settle.patch
54 Patch6:         vserver.patch
55 URL:            http://www.libvirt.org/
56 BuildRequires:  audit-libs-devel
57 BuildRequires:  augeas-devel
58 BuildRequires:  autoconf >= 2.50
59 BuildRequires:  automake
60 BuildRequires:  avahi-devel >= 0.6.0
61 %{?with_ceph:BuildRequires:     ceph-devel}
62 BuildRequires:  curl-devel >= 7.18.0
63 BuildRequires:  cyrus-sasl-devel
64 BuildRequires:  dbus-devel >= 1.0.0
65 BuildRequires:  device-mapper-devel >= 1.0.0
66 BuildRequires:  gawk
67 BuildRequires:  gettext-devel >= 0.17
68 %{?with_glusterfs:BuildRequires:        glusterfs-devel >= 3.4.1}
69 BuildRequires:  gnutls-devel >= 1.0.25
70 BuildRequires:  libapparmor-devel
71 BuildRequires:  libblkid-devel >= 2.17
72 BuildRequires:  libcap-ng-devel >= 0.4.0
73 BuildRequires:  libfuse-devel >= 2.8.6
74 BuildRequires:  libgcrypt-devel
75 BuildRequires:  libnl-devel >= 3.2
76 BuildRequires:  libpcap-devel >= 1.0.0
77 BuildRequires:  libselinux-devel >= 2.0.82
78 BuildRequires:  libssh2-devel >= 1.3
79 BuildRequires:  libstdc++-devel
80 BuildRequires:  libtool
81 %{?with_xenapi:BuildRequires:   libxenserver-devel}
82 BuildRequires:  libxml2-devel >= 1:2.6.0
83 BuildRequires:  libxslt-devel
84 BuildRequires:  ncurses-devel
85 %{?with_netcf:BuildRequires:    netcf-devel >= 0.2.0}
86 BuildRequires:  numactl-devel
87 BuildRequires:  openldap-devel
88 BuildRequires:  openwsman-devel >= 2.2.3
89 BuildRequires:  parted-devel >= 1.8.0
90 BuildRequires:  perl-tools-pod
91 BuildRequires:  pkgconfig
92 %{?with_polkit:BuildRequires:   polkit-devel >= 0.90}
93 BuildRequires:  readline-devel
94 BuildRequires:  rpmbuild(macros) >= 1.627
95 %{?with_sanlock:BuildRequires:  sanlock-devel >= 0.8}
96 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
97 BuildRequires:  udev-devel >= 1:145
98 %{?with_xen:BuildRequires:      xen-devel >= 4.2}
99 # For disk driver
100 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10.0
101 BuildRequires:  yajl-devel
102 Requires:       curl-libs >= 7.18.0
103 Requires:       device-mapper >= 1.0.0
104 Requires:       libcap-ng >= 0.4.0
105 Requires:       libnl >= 3.2
106 Requires:       libpcap >= 1.0.0
107 Requires:       libselinux >= 2.0.82
108 Requires:       libssh2 >= 1.3
109 Requires:       libxml2 >= 1:2.6.0
110 Requires:       openwsman-libs >= 2.2.3
111 Obsoletes:      libvirt-daemon-esx
112 Obsoletes:      libvirt-daemon-hyperv
113 Obsoletes:      libvirt-daemon-openvz
114 Obsoletes:      libvirt-daemon-phyp
115 Obsoletes:      libvirt-daemon-vbox
116 Obsoletes:      libvirt-daemon-vmware
117 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
118
119 %description
120 Libvirt is a C toolkit to interact with the virtualization
121 capabilities of recent versions of Linux.
122
123 Virtualization of the Linux Operating System means the ability to run
124 multiple instances of Operating Systems concurently on a single
125 hardware system where the basic resources are driven by a Linux
126 instance. The library aim at providing long term stable C API
127 initially for the Xen paravirtualization but should be able to
128 integrate other virtualization mechanisms if needed.
129
130 This package contains the base libraries and configuration file.
131
132 %description -l pl.UTF-8
133 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
134 obecnych wersji Linuksa.
135
136 Wirtualizacja w systemie operacyjnym Linux oznacza możliwość
137 jednoczesnego uruchamiania wielu instancji systemu operacyjnego na
138 pojedynczym systemie sprzętowym, którego podstawowe zasoby są
139 zarządzane przez instancję Linuksa. Celem biblioteki jest zapewnienie
140 długotrwale stabilnego API C, początkowo do parawirtualizacji Xen, ale
141 dającej się zintegrować w razie potrzeby z innymi mechanizmami
142 wirtualizacji.
143
144 Ten pakiet zawiera podstawowe biblioteki oraz plik konfiguracyjny.
145
146 %package devel
147 Summary:        Development files for programs using libvirt
148 Summary(pl.UTF-8):      Pliki programistyczne do programów wykorzystujących libvirt
149 Group:          Development/Libraries
150 Requires:       %{name} = %{version}-%{release}
151 Requires:       audit-libs-devel
152 Requires:       curl-devel >= 7.18.0
153 Requires:       dbus-devel >= 1.0.0
154 Requires:       device-mapper-devel >= 1.0.0
155 Requires:       gnutls-devel >= 1.0.25
156 Requires:       libapparmor-devel
157 Requires:       libcap-ng-devel >= 0.4.0
158 Requires:       libgcrypt-devel
159 Requires:       libnl-devel >= 3.2
160 Requires:       libpcap-devel >= 1.0.0
161 Requires:       libselinux-devel >= 2.0.82
162 Requires:       libxml2-devel >= 1:2.6.0
163 Requires:       numactl-devel
164 Requires:       openwsman-devel >= 2.2.3
165 %{?with_xen:Requires:   xen-devel >= 4.2}
166 Requires:       yajl-devel
167
168 %description devel
169 Libvirt is a C toolkit to interact with the virtualization
170 capabilities of recent versions of Linux.
171
172 This package contains the header files needed for developing programs
173 using the libvirt library.
174
175 %description devel -l pl.UTF-8
176 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
177 obecnych wersji Linuksa.
178
179 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
180 wykorzystujących bibliotekę libvirt.
181
182 %package static
183 Summary:        Development static libraries for programs using libvirt
184 Summary(pl.UTF-8):      Statyczne biblioteki programistyczne do programów wykorzystujących libvirt
185 Group:          Development/Libraries
186 Requires:       %{name}-devel = %{version}-%{release}
187
188 %description static
189 Libvirt is a C toolkit to interact with the virtualization
190 capabilities of recent versions of Linux.
191
192 This package contains the static libraries for developing programs
193 using the libvirt library.
194
195 %description static -l pl.UTF-8
196 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
197 obecnych wersji Linuksa.
198
199 Ten pakiet zawiera biblioteki statyczne do tworzenia programów
200 wykorzystujących bibliotekę libvirt.
201
202 %package lock-sanlock
203 Summary:        Sanlock lock manager plugin for libvirt
204 Summary(pl.UTF-8):      Zarządca blokad sanlock dla biblioteki libvirt
205 Group:          Libraries
206 Requires:       %{name}-daemon = %{version}-%{release}
207
208 %description lock-sanlock
209 Sanlock lock manager plugin for libvirt.
210
211 %description lock-sanlock -l pl.UTF-8
212 Zarządca blokad sanlock dla biblioteki libvirt.
213
214 %package daemon
215 Summary:        Server side daemon and supporting files for libvirt library
216 Summary(pl.UTF-8):      Demon działający po stronie serwera oraz pliki wspierające dla biblioteki libvirt
217 Group:          Applications/System
218 Requires:       %{name} = %{version}-%{release}
219 Requires:       avahi-libs >= 0.6.0
220 Requires:       iproute2
221 Requires:       libblkid >= 2.17
222 %{?with_netcf:Requires: netcf >= 0.2.0}
223 Requires:       parted-libs >= 1.8.0
224 Requires:       rc-scripts
225 # Needed for probing the power management features of the host.
226 Requires:       pm-utils
227 Requires:       systemd-units >= 37-0.10
228 Requires:       udev-libs >= 1:145
229 Requires:       util-linux
230 Requires:       virtual(module-tools)
231 Requires:       xorg-lib-libpciaccess >= 0.10.0
232 Requires(post): systemd-units
233 Requires(post,preun):   /sbin/chkconfig
234 Requires(postun):       systemd-units
235 Requires(preun):        systemd-units
236 Suggests:       bridge-utils
237 Suggests:       cyrus-sasl
238 Suggests:       cyrus-sasl-digest-md5
239 Suggests:       dmidecode
240 Suggests:       dnsmasq >= 2.41
241 Suggests:       ebtables
242 Suggests:       gawk
243 Suggests:       glusterfs-client >= 2.0.1
244 Suggests:       iptables
245 Suggests:       iptables
246 Suggests:       libcgroup
247 Suggests:       lvm2
248 Suggests:       numad
249 Suggests:       open-iscsi
250 Suggests:       parted >= 1.8.0
251 Suggests:       polkit >= 0.93
252 #Suggests:      radvd
253 Suggests:       scrub
254 #Suggests:      sheepdog
255 Provides:       libvirt(hypervisor)
256
257 %description daemon
258 Server side daemon required to manage the virtualization capabilities
259 of recent versions of Linux. Requires a hypervisor specific sub-RPM
260 for specific drivers.
261
262 %description daemon -l pl.UTF-8
263 Demon działający po stronie serwera wymagany do zarządzania funkcjami
264 wirtualizacji nowych wersji Linuksa. Wymaga podpakietu specyficznego
265 dla hipernadzorcy.
266
267 %package daemon-libxl
268 Summary:        Server side driver required to run XEN guests (xenlight)
269 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości XEN (xenlight)
270 Group:          Libraries
271 Requires:       %{name}-daemon = %{version}-%{release}
272 Requires:       /usr/sbin/qcow-create
273 Requires:       xen
274 Provides:       libvirt(hypervisor)
275
276 %description daemon-libxl
277 Server side driver required to manage the virtualization capabilities
278 of XEN via xenlight interface.
279
280 %description daemon-libxl -l pl.UTF-8
281 Sterownik wymagany po stronie serwera do zarządzania funkcjami
282 wirtualizacji XEN poprzez interfejs xenlight.
283
284 %package daemon-lxc
285 Summary:        Server side driver required to run LXC guests
286 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości LXC
287 Group:          Libraries
288 Requires:       %{name}-daemon = %{version}-%{release}
289 Requires:       libfuse >= 2.8.6
290 Provides:       libvirt(hypervisor)
291
292 %description daemon-lxc
293 Server side driver required to manage the virtualization capabilities
294 of LXC.
295
296 %description daemon-lxc -l pl.UTF-8
297 Sterownik wymagany po stronie serwera do zarządzania funkcjami
298 wirtualizacji LXC.
299
300 %package daemon-qemu
301 Summary:        Server side driver required to run QEMU guests
302 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości QEMU
303 Group:          Libraries
304 Requires:       %{name}-daemon = %{version}-%{release}
305 Requires:       /usr/bin/qemu-img
306 Requires:       bzip2
307 Requires:       gzip
308 Requires:       lzop
309 Requires:       qemu
310 Requires:       xz
311 Provides:       libvirt(hypervisor)
312
313 %description daemon-qemu
314 Server side driver required to manage the virtualization capabilities
315 of the QEMU emulators.
316
317 %description daemon-qemu -l pl.UTF-8
318 Sterownik wymagany po stronie serwera do zarządzania funkcjami
319 wirtualizacji emulatora QEMU.
320
321 %package daemon-uml
322 Summary:        Server side driver required to run UML guests
323 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości UML
324 Group:          Libraries
325 Requires:       %{name}-daemon = %{version}-%{release}
326 Provides:       libvirt(hypervisor)
327
328 %description daemon-uml
329 Server side driver required to manage the virtualization capabilities
330 of UML.
331
332 %description daemon-uml -l pl.UTF-8
333 Sterownik wymagany po stronie serwera do zarządzania funkcjami
334 wirtualizacji UML.
335
336 %package daemon-xen
337 Summary:        Server side driver required to run XEN guests
338 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości XEN
339 Group:          Libraries
340 Requires:       %{name}-daemon = %{version}-%{release}
341 Requires:       /usr/sbin/qcow-create
342 Requires:       xen
343 Requires:       xen-xend
344 Provides:       libvirt(hypervisor)
345
346 %description daemon-xen
347 Server side driver required to manage the virtualization capabilities
348 of XEN.
349
350 %description daemon-xen -l pl.UTF-8
351 Sterownik wymagany po stronie serwera do zarządzania funkcjami
352 wirtualizacji XEN.
353
354 %package client
355 Summary:        Client side utilities of the libvirt library
356 Summary(pl.UTF-8):      Narzędzia klienckie do biblioteki libvirt
357 Group:          Applications/System
358 Requires:       %{name} = %{version}-%{release}
359 Requires:       gettext >= 0.18.1.1-6
360 Requires:       gnutls >= 1.0.25
361 Requires:       netcat-openbsd
362 Requires:       rc-scripts
363 Requires(post): systemd-units
364 Requires(post,preun):   /sbin/chkconfig
365 Requires(postun):       systemd-units
366 Requires(preun):        systemd-units
367
368 %description client
369 Client binaries needed to access to the virtualization capabilities of
370 recent versions of Linux (and other OSes).
371
372 %description client -l pl.UTF-8
373 Programy klienckie potrzebne do funkcji wirtualizacji nowych wersji
374 Linuksa (oraz innych systemów operacyjnych).
375
376 %package utils
377 Summary:        Tools to interact with virtualization capabilities (metapackage)
378 Summary(pl.UTF-8):      Narzędzia do współpracy z funkcjami wirtualizacyjnymi (metapakiet)
379 Group:          Applications/System
380 Requires:       %{name}-client = %{version}-%{release}
381 Requires:       %{name}-daemon = %{version}-%{release}
382 %{?with_libxl:Requires: %{name}-daemon-libxl = %{version}-%{release}}
383 Requires:       %{name}-daemon-lxc = %{version}-%{release}
384 Requires:       %{name}-daemon-qemu = %{version}-%{release}
385 Requires:       %{name}-daemon-uml = %{version}-%{release}
386 Requires:       %{name}-daemon-xen = %{version}-%{release}
387
388 %description utils
389 Libvirt is a C toolkit to interact with the virtualization
390 capabilities of recent versions of Linux.
391
392 This is metapackage gathering all tools for the libvirt library.
393
394 %description utils -l pl.UTF-8
395 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
396 obecnych wersji Linuksa.
397
398 To jest metapakiet zbierający wszystkie narzędzia przeznaczone dla
399 biblioteki libvirt.
400
401 %package -n systemtap-libvirt
402 Summary:        systemtap/dtrace probes for libvirt
403 Summary(pl.UTF-8):      Sondy systemtap/dtrace dla libvirt
404 Group:          Development/Tools
405 Requires:       %{name} = %{version}-%{release}
406 Requires:       systemtap-client
407
408 %description -n systemtap-libvirt
409 systemtap/dtrace probes for libvirt.
410
411 %description -n systemtap-libvirt -l pl.UTF-8
412 Sondy systemtap/dtrace dla libvirt.
413
414 %prep
415 %setup -q
416 %patch0 -p1
417 # TODO
418 #patch1 -p1
419 %patch2 -p1
420 %patch3 -p1
421 %patch4 -p1
422 %patch5 -p1
423 %{?with_vserver:%patch6 -p1}
424
425 %build
426 %{__libtoolize}
427 %{__aclocal} -I gnulib/m4 -I m4
428 %{__autoconf}
429 %{__autoheader}
430 %{__automake}
431
432 %configure \
433         PVCREATE=/sbin/pvcreate \
434         VGCREATE=/sbin/vgcreate \
435         LVCREATE=/sbin/lvcreate \
436         PVREMOVE=/sbin/pvremove \
437         VGREMOVE=/sbin/vgremove \
438         LVREMOVE=/sbin/lvremove \
439         VGCHANGE=/sbin/vgchange \
440         LVCHANGE=/sbin/lvchange \
441           VGSCAN=/sbin/vgscan   \
442              PVS=/sbin/pvs      \
443              VGS=/sbin/vgs      \
444              LVS=/sbin/lvs      \
445               TC=/sbin/tc \
446            BRCTL=/sbin/brctl    \
447         ISCSIADM=/sbin/iscsiadm \
448         SHOWMOUNT=/usr/sbin/showmount \
449         MOUNT=/bin/mount \
450         UMOUNT=/bin/umount \
451         MKFS=/sbin/mkfs \
452         SHOWMOUNT=/usr/sbin/showmount \
453         IPTABLES_PATH=/usr/sbin/iptables \
454         IP6TABLES_PATH=/usr/sbin/ip6tables \
455         EBTABLES_PATH=/usr/sbin/ebtables \
456         ISCSIADM=/sbin/iscsiadm \
457         DNSMASQ=/usr/sbin/dnsmasq \
458         RADVD=/usr/sbin/radvd \
459         UDEVADM=/sbin/udevadm \
460         MODPROBE=/sbin/modprobe \
461         SCRUB=/usr/bin/scrub \
462         OVSVSCTL=/usr/bin/ovs-vsctl \
463         NUMAD=/usr/bin/numad \
464         COLLIE=/usr/sbin/collie \
465         --disable-silent-rules \
466         %{?with_static_libs:--enable-static} \
467         --with-html-dir=%{_gtkdocdir} \
468         --with-html-subdir=%{name} \
469         --with-init-script=systemd+redhat \
470         --with-packager="PLD-Linux" \
471         --with-packager-version="%{name}-%{version}-%{release}.%{_target_cpu}" \
472         --with-qemu-user=qemu \
473         --with-qemu-group=qemu \
474         --with-storage-disk \
475         --with-storage-fs \
476         --with-storage-gluster%{!?with_glusterfs:=no} \
477         --with-storage-iscsi \
478         --with-storage-lvm \
479         --with-storage-mpath \
480         --with-storage-rbd%{!?with_ceph:=no} \
481         --with-storage-scsi \
482         --with-storage-sheepdog \
483         --with-apparmor \
484         --with-audit \
485         --with-avahi \
486         %{__with_without systemtap dtrace} \
487         %{__with_without esx} \
488         --with-driver-modules \
489         --without-hal \
490         %{__with_without hyperv} \
491         --with-blkid \
492         --with-ssh2 \
493         %{__with_without libxl} \
494         %{__with_without lxc} \
495         --with-macvtap \
496         %{__with_without netcf} \
497         --with-numactl \
498         --with-numad \
499         %{__with_without openvz} \
500         %{__with_without phyp} \
501         %{__with_without polkit} \
502         %{__with_without qemu} \
503         %{__with_without sanlock} \
504         --with-sasl \
505         --with-selinux \
506         --with-udev \
507         %{__with_without uml} \
508         %{__with_without vbox vbox %{_libdir}/VirtualBox} \
509         --with-virtualport \
510         %{__with_without vmware} \
511         %{__with_without xen} \
512         %{__with_without xenapi} \
513         --with-yajl \
514         --x-libraries=%{_libdir}
515
516 %{__make} \
517         AWK=gawk
518
519 %install
520 rm -rf $RPM_BUILD_ROOT
521 install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d} \
522         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
523
524 %{__make} install \
525         DEVHELP_DIR=%{_gtkdocdir}/%{name}/devhelp \
526         DESTDIR=$RPM_BUILD_ROOT
527
528 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/libvirtd
529 install %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
530
531 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
532 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvirt/connection-driver/*.la \
533         %{?with_static_libs:$RPM_BUILD_ROOT%{_libdir}/libvirt/connection-driver/*.a}
534
535 %if %{with sanlock}
536 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvirt/lock-driver/*.la \
537         %{?with_static_libs:$RPM_BUILD_ROOT%{_libdir}/libvirt/lock-driver/*.a}
538 %endif
539
540 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{eu_ES,eu}
541 # duplicate of vi, just one less message translated
542 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/vi_VN
543
544 %find_lang %{name}
545
546 %clean
547 rm -rf $RPM_BUILD_ROOT
548
549 %post   -p /sbin/ldconfig
550 %postun -p /sbin/ldconfig
551
552 %post daemon
553 /sbin/chkconfig --add libvirtd
554 %service libvirtd restart
555 %systemd_post libvirtd.service
556
557 %preun daemon
558 if [ "$1" = "0" ]; then
559         %service -q libvirtd stop
560         /sbin/chkconfig --del libvirtd
561 fi
562 %systemd_preun libvirtd.service
563
564 %postun daemon
565 %systemd_reload
566
567 %post client
568 /sbin/chkconfig --add libvirt-guests
569 %service -n libvirt-guests restart
570 NORESTART=1
571 %systemd_post libvirt-guests.service
572
573 %preun client
574 %systemd_preun libvirt-guests.service
575 if [ "$1" = "0" ]; then
576         %service -q libvirt-guests stop
577         /sbin/chkconfig --del libvirt-guests
578 fi
579
580 %postun client
581 %systemd_reload
582
583 %files -f %{name}.lang
584 %defattr(644,root,root,755)
585 %doc ChangeLog README TODO NEWS
586 %dir %{_sysconfdir}/libvirt
587 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libvirt.conf
588 %attr(755,root,root) %{_libdir}/libvirt.so.*.*.*
589 %attr(755,root,root) %ghost %{_libdir}/libvirt.so.0
590 %if %{with lxc}
591 %attr(755,root,root) %{_libdir}/libvirt-lxc.so.*.*.*
592 %attr(755,root,root) %ghost %{_libdir}/libvirt-lxc.so.0
593 %endif
594 %if %{with qemu}
595 %attr(755,root,root) %{_libdir}/libvirt-qemu.so.*.*.*
596 %attr(755,root,root) %ghost %{_libdir}/libvirt-qemu.so.0
597 %endif
598
599 %dir %{_libdir}/libvirt
600 %dir %{_datadir}/libvirt
601 %{_datadir}/libvirt/libvirtLogo.png
602
603 %files devel
604 %defattr(644,root,root,755)
605 %attr(755,root,root) %{_libdir}/libvirt.so
606 %{?with_lxc:%attr(755,root,root) %{_libdir}/libvirt-lxc.so}
607 %{?with_qemu:%attr(755,root,root) %{_libdir}/libvirt-qemu.so}
608 %{_datadir}/%{name}/api
609 %{_gtkdocdir}/%{name}
610 %{_includedir}/%{name}
611 %{_pkgconfigdir}/%{name}.pc
612
613 %files static
614 %defattr(644,root,root,755)
615 %{_libdir}/libvirt.a
616 %{?with_lxc:%{_libdir}/libvirt-lxc.a}
617 %{?with_qemu:%{_libdir}/libvirt-qemu.a}
618
619 %if %{with sanlock}
620 %files lock-sanlock
621 %defattr(644,root,root,755)
622 %attr(755,root,root) %{_sbindir}/virt-sanlock-cleanup
623 %attr(755,root,root) %{_libdir}/libvirt_sanlock_helper
624 %attr(755,root,root) %{_libdir}/libvirt/lock-driver/sanlock.so
625 %{_datadir}/augeas/lenses/libvirt_sanlock.aug
626 %{_datadir}/augeas/lenses/tests/test_libvirt_sanlock.aug
627 %dir /var/lib/libvirt/sanlock
628 %{_mandir}/man8/virt-sanlock-cleanup.8*
629 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu-sanlock.conf
630 %endif
631
632 %files daemon
633 %defattr(644,root,root,755)
634 %doc docs/*.xml
635 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/nwfilter
636 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu
637 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu/networks
638 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu/networks/autostart
639 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libvirtd.conf
640 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu-lockd.conf
641 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/virtlockd.conf
642 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu/networks/default.xml
643 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu/networks/autostart/default.xml
644 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/nwfilter/*.xml
645 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/libvirt.conf
646 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirtd
647 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtlockd
648 %attr(754,root,root) /etc/rc.d/init.d/libvirtd
649 %attr(754,root,root) /etc/rc.d/init.d/virtlockd
650 %{systemdunitdir}/libvirtd.service
651 %{systemdunitdir}/virtlockd.service
652 %{systemdunitdir}/virtlockd.socket
653 %config(noreplace) %verify(not md5 mtime size) /usr/lib/sysctl.d/libvirtd.conf
654 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd
655 %attr(755,root,root) %{_libdir}/libvirt_iohelper
656 %attr(755,root,root) %{_libdir}/libvirt_parthelper
657 %attr(755,root,root) %{_libdir}/virt-aa-helper
658 %attr(755,root,root) %{_sbindir}/libvirtd
659 %attr(755,root,root) %{_sbindir}/virtlockd
660 %{_datadir}/augeas/lenses/libvirtd.aug
661 %{_datadir}/augeas/lenses/libvirt_lockd.aug
662 %{_datadir}/augeas/lenses/virtlockd.aug
663 %{_datadir}/augeas/lenses/tests/test_libvirtd.aug
664 %{_datadir}/augeas/lenses/tests/test_libvirt_lockd.aug
665 %{_datadir}/augeas/lenses/tests/test_virtlockd.aug
666 %if %{with polkit}
667 %{_datadir}/polkit-1/actions/org.libvirt.api.policy
668 %{_datadir}/polkit-1/actions/org.libvirt.unix.policy
669 %endif
670 %{_mandir}/man8/libvirtd.8*
671 %{_mandir}/man8/virtlockd.8*
672 %dir /var/lib/libvirt
673 %dir /var/lib/libvirt/dnsmasq
674 %attr(711,root,root) %dir /var/lib/libvirt/boot
675 %attr(700,root,root) %dir /var/lib/libvirt/network
676 %attr(711,root,root) %dir /var/lib/libvirt/images
677 %attr(711,root,root) %dir /var/lib/libvirt/filesystems
678 %attr(700,root,root) %dir /var/log/libvirt
679 %attr(711,root,root) %dir /var/cache/libvirt
680 %dir /var/run/libvirt
681 %dir /var/run/libvirt/network
682 %{systemdtmpfilesdir}/%{name}.conf
683 %dir %{_libdir}/libvirt/connection-driver
684 %{_datadir}/libvirt/cpu_map.xml
685 %{?with_netcf:%attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_interface.so}
686 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_network.so
687 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_nodedev.so
688 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_nwfilter.so
689 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_secret.so
690 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_storage.so
691 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_vbox.so
692 %dir %{_libdir}/libvirt/lock-driver
693 %attr(755,root,root) %{_libdir}/libvirt/lock-driver/lockd.so
694
695 %if %{with libxl}
696 %files daemon-libxl
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_libxl.so
699 %attr(700,root,root) %dir /var/lib/libvirt/libxl
700 %attr(700,root,root) %dir /var/run/libvirt/libxl
701 %attr(700,root,root) %dir /var/log/libvirt/libxl
702 %endif
703
704 %if %{with lxc}
705 %files daemon-lxc
706 %defattr(644,root,root,755)
707 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/lxc.conf
708 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.lxc
709 %attr(700,root,root) %dir /var/lib/libvirt/lxc
710 %attr(700,root,root) %dir /var/run/libvirt/lxc
711 %attr(700,root,root) %dir /var/log/libvirt/lxc
712 %{_datadir}/augeas/lenses/libvirtd_lxc.aug
713 %{_datadir}/augeas/lenses/tests/test_libvirtd_lxc.aug
714 %attr(755,root,root) %{_libdir}/libvirt_lxc
715 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_lxc.so
716 %endif
717
718 %if %{with qemu}
719 %files daemon-qemu
720 %defattr(644,root,root,755)
721 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu.conf
722 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.qemu
723 %attr(750,qemu,qemu) %dir /var/cache/libvirt/qemu
724 %attr(750,qemu,qemu) %dir /var/lib/libvirt/qemu
725 %attr(700,root,root) %dir /var/log/libvirt/qemu
726 %attr(700,root,root) %dir /var/run/libvirt/qemu
727 %{_datadir}/augeas/lenses/libvirtd_qemu.aug
728 %{_datadir}/augeas/lenses/tests/test_libvirtd_qemu.aug
729 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_qemu.so
730 %endif
731
732 %if %{with uml}
733 %files daemon-uml
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_uml.so
736 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.uml
737 %attr(700,root,root) %dir /var/lib/libvirt/uml
738 %attr(700,root,root) %dir /var/run/libvirt/uml
739 %attr(700,root,root) %dir /var/log/libvirt/uml
740 %endif
741
742 %if %{with xen}
743 %files daemon-xen
744 %defattr(644,root,root,755)
745 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_xen.so
746 %endif
747
748 %files client
749 %defattr(644,root,root,755)
750 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirt-guests
751 %attr(754,root,root) /etc/rc.d/init.d/libvirt-guests
752 %{systemdunitdir}/libvirt-guests.service
753 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/virt-login-shell.conf
754 %attr(755,root,root) %{_bindir}/virsh
755 %attr(755,root,root) %{_bindir}/virt-host-validate
756 %attr(4755,root,root) %{_bindir}/virt-login-shell
757 %attr(755,root,root) %{_bindir}/virt-xml-validate
758 %attr(755,root,root) %{_bindir}/virt-pki-validate
759 %attr(754,root,root) %{_libexecdir}/libvirt-guests.sh
760 %{_mandir}/man1/virsh.1*
761 %{_mandir}/man1/virt-host-validate.1*
762 %{_mandir}/man1/virt-login-shell.1*
763 %{_mandir}/man1/virt-xml-validate.1*
764 %{_mandir}/man1/virt-pki-validate.1*
765 %dir %{_datadir}/libvirt/schemas
766 %{_datadir}/libvirt/schemas/basictypes.rng
767 %{_datadir}/libvirt/schemas/capability.rng
768 %{_datadir}/libvirt/schemas/domain.rng
769 %{_datadir}/libvirt/schemas/domaincommon.rng
770 %{_datadir}/libvirt/schemas/domainsnapshot.rng
771 %{_datadir}/libvirt/schemas/interface.rng
772 %{_datadir}/libvirt/schemas/network.rng
773 %{_datadir}/libvirt/schemas/networkcommon.rng
774 %{_datadir}/libvirt/schemas/nodedev.rng
775 %{_datadir}/libvirt/schemas/nwfilter.rng
776 %{_datadir}/libvirt/schemas/secret.rng
777 %{_datadir}/libvirt/schemas/storageencryption.rng
778 %{_datadir}/libvirt/schemas/storagefilefeatures.rng
779 %{_datadir}/libvirt/schemas/storagepool.rng
780 %{_datadir}/libvirt/schemas/storagevol.rng
781
782 %files utils
783 %defattr(644,root,root,755)
784
785 %if %{with systemtap}
786 %files -n systemtap-libvirt
787 %defattr(644,root,root,755)
788 %{_datadir}/systemtap/tapset/libvirt_functions.stp
789 %{_datadir}/systemtap/tapset/libvirt_probes.stp
790 %{_datadir}/systemtap/tapset/libvirt_qemu_probes.stp
791 %endif
This page took 0.079556 seconds and 4 git commands to generate.