]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/blob - libtorrent-rasterbar.spec
8a511d7e6be67fae20a668d34793012c71b95f8d
[packages/libtorrent-rasterbar.git] / libtorrent-rasterbar.spec
1 # WARNING: qbittorrent 4.1.x uses 1.1.x/1.2.x, not 2.x
2 #
3 %define         tagver  %(echo %{version} | tr . _)
4 Summary:        A C++ BitTorrent library
5 Summary(hu.UTF-8):      C++ BitTorrent könyvtár
6 Summary(pl.UTF-8):      Biblioteka BitTorrenta napisana w C++
7 Name:           libtorrent-rasterbar
8 Version:        1.2.7
9 Release:        2
10 Epoch:          2
11 License:        BSD
12 Group:          Libraries
13 #Source0Download: https://github.com/arvidn/libtorrent/releases
14 Source0:        https://github.com/arvidn/libtorrent/releases/download/libtorrent_%{tagver}/%{name}-%{version}.tar.gz
15 # Source0-md5:  0c5e9d3c141704d1801f6da65c4554fe
16 URL:            http://www.rasterbar.com/products/libtorrent/
17 BuildRequires:  GeoIP-devel
18 BuildRequires:  autoconf >= 2.63
19 BuildRequires:  automake >= 1:1.11
20 BuildRequires:  boost-devel >= 1.58
21 BuildRequires:  boost-python-devel >= 1.58
22 BuildRequires:  libstdc++-devel >= 6:4.7
23 BuildRequires:  libtool >= 2:2.2.6
24 BuildRequires:  openssl-devel
25 BuildRequires:  pkgconfig >= 1:0.20
26 BuildRequires:  python-devel >= 1:2.4
27 BuildRequires:  python-modules >= 1:2.4
28 BuildRequires:  rpm-pythonprov
29 BuildRequires:  sed >= 4.0
30 BuildRequires:  util-linux
31 BuildRequires:  which
32 BuildRequires:  zlib-devel
33 Obsoletes:      rb_libtorrent
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 libtorrent-rasterbar is a C++ library that aims to be a good
38 alternative to all the other BitTorrent implementations around. It is
39 a library and not a full featured client, although it comes with a
40 working example client.
41
42 Its main goals are to be very efficient (in terms of CPU and memory
43 usage) as well as being very easy to use both as a user and developer.
44
45 %description -l hu.UTF-8
46 libtorrent-rasterbar egy C++ könyvtár, amely egy jó alternatívája
47 kíván lenni az összes többi BitTorrent implementációjának. Ez "csak"
48 egy könyvtár, és nem egy szolgáltatásgazdag kliens, habár ad egy
49 működő példa-klienst.
50
51 A fő céljai, hogy nagyon hatékony legyen (CPU és memória-használat) és
52 könnyű legyen használni mind a felhasználóknak, mind a fejlesztőknek.
53
54 %description -l pl.UTF-8
55 libtorrent-rasterbar jest napisaną w C++ biblioteką, która aspiruje do
56 bycia dobrą alternatywą dla wszystkich innych implementacji
57 BitTorrenta. Jest to biblioteka a nie pełnoprawny klient, aczkolwiek
58 pakiet zawiera działającego przykładowego klienta.
59
60 Główne cele biblioteki to bycie bardzo efektywną (w rozumieniu
61 wykorzystania procesora i pamięci) jak również łatwą w użyciu zarówno
62 dla użytkownika, jak i programisty.
63
64 %package devel
65 Summary:        Header files for %{name} library
66 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
67 License:        BSD, zlib/libpng License, Boost Software License
68 Group:          Development/Libraries
69 Requires:       %{name} = %{epoch}:%{version}-%{release}
70 Requires:       boost-devel >= 1.58
71 Requires:       libstdc++-devel >= 6:4.7
72 Requires:       openssl-devel
73 Obsoletes:      rb_libtorrent-devel
74
75 %description    devel
76 The libtorrent-rasterbar-devel package contains libraries and header
77 files for developing applications that use libtorrent-rasterbar.
78
79 The various source and header files included in this package are
80 licensed under the revised BSD, zlib/libpng, and Boost Public
81 licenses.
82
83 %description devel -l hu.UTF-8
84 A libtorrent-rasterbar-devel csomag tartalmazza a könyvtári és
85 fejlesztői fájlokat, amellyel libtorrent-rasterbar-t használó
86 alkalmazásokat fejleszthetsz.
87
88 %description devel -l pl.UTF-8
89 Pakiet libtorrent-rasterbar-devel zawiera biblioteki i nagłówki do
90 rozwijania aplikacji używających libtorrent-rasterbar.
91
92 Różne pliki źródłowe i nagłówki dostarczone z tym pakietem są
93 licencjonowane pod zmienioną licencją BSD, zlib/libpng i Boost Public
94 License.
95
96 %package static
97 Summary:        Static %{name} library
98 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
99 Group:          Development/Libraries
100 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
101 Obsoletes:      rb_libtorrent-static
102
103 %description static
104 Static libtorrent-rasterbar library.
105
106 %description static -l hu.UTF-8
107 Statikus libtorrent-rasterbar könyvtár.
108
109 %description static -l pl.UTF-8
110 Statyczna biblioteka libtorrent-rasterbar.
111
112 %package -n python-libtorrent-rasterbar
113 Summary:        Python bindings for libtorrent-rasterbar
114 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libtorrent-rasterbar
115 Group:          Libraries/Python
116 Requires:       %{name} = %{epoch}:%{version}-%{release}
117
118 %description -n python-libtorrent-rasterbar
119 Python bindings for libtorrent-rasterbar.
120
121 %description -n python-libtorrent-rasterbar -l pl.UTF-8
122 Wiązania Pythona do biblioteki libtorrent-rasterbar.
123
124 %prep
125 %setup -q
126
127 ## Some of the sources and docs are executable, which makes rpmlint against
128 ## the resulting -debuginfo and -devel packages, respectively, quite angry. :]
129 find src docs -type f | xargs chmod a-x
130 find -type f -regex '.*\.[hc]pp' | xargs chmod a-x
131 ## The RST files are the sources used to create the final HTML files; and are
132 ## not needed.
133 %{__rm} docs/*.rst
134
135 %build
136 %{__libtoolize}
137 %{__aclocal} -I m4
138 %{__autoconf}
139 %{__automake}
140 %configure \
141         LIBS="-lpthread -lrt" \
142         --disable-silent-rules \
143         --enable-python-binding \
144         --with-asio=system \
145         --with-boost-libdir=%{_libdir} \
146         --with-boost-filesystem=boost_filesystem \
147         --with-boost-program-options=boost_program_options \
148         --with-boost-regex=boost_regex \
149         --with-boost-system=boost_system \
150         --with-boost-thread=boost_thread \
151         --with-libgeoip=system \
152         --with-ssl \
153         --with-zlib=system
154
155 %{__make}
156
157 %install
158 rm -rf $RPM_BUILD_ROOT
159
160 %{__make} install \
161         DESTDIR=$RPM_BUILD_ROOT
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
165
166 %post   -p /sbin/ldconfig
167 %postun -p /sbin/ldconfig
168
169 %files
170 %defattr(644,root,root,755)
171 %doc AUTHORS ChangeLog COPYING
172 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so.*.*.*
173 %attr(755,root,root) %ghost %{_libdir}/libtorrent-rasterbar.so.10
174
175 %files devel
176 %defattr(644,root,root,755)
177 %doc docs/
178 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so
179 %{_libdir}/libtorrent-rasterbar.la
180 %{_includedir}/libtorrent
181 %{_pkgconfigdir}/libtorrent-rasterbar.pc
182 %{_datadir}/cmake/Modules/FindLibtorrentRasterbar.cmake
183
184 %files static
185 %defattr(644,root,root,755)
186 %{_libdir}/libtorrent-rasterbar.a
187
188 %files -n python-libtorrent-rasterbar
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{py_sitedir}/libtorrent.so
191 %{py_sitedir}/python_libtorrent-*.egg-info
This page took 0.154664 seconds and 3 git commands to generate.