]> git.pld-linux.org Git - packages/libtirpc.git/blob - libtirpc.spec
- headers in place where it was in glibc
[packages/libtirpc.git] / libtirpc.spec
1 #
2 # Conditional build:
3 %bcond_with     gssglue         # build with MIT Kerberos instead of Heimdal
4 #
5 Summary:        Transport Independent RPC Library
6 Summary(pl.UTF-8):      Biblioteka RPC niezależnego od transportu
7 Name:           libtirpc
8 Version:        0.2.2
9 Release:        1.2
10 Epoch:          1
11 License:        BSD-like
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/libtirpc/%{name}-%{version}.tar.bz2
14 # Source0-md5:  74c41c15c2909f7d11d9c7bfa7db6273
15 Patch0:         %{name}-link.patch
16 Patch1:         %{name}-heimdal.patch
17 Patch2:         %{name}-XDR_GETPOS.patch
18 Patch3:         %{name}-rpc-des-prot.patch
19 Patch4:         %{name}-nis.patch
20 URL:            http://sourceforge.net/projects/libtirpc/
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  automake
23 %if %{with gssglue}
24 BuildRequires:  libgssglue-devel >= 0.1
25 %else
26 BuildRequires:  heimdal-devel
27 %endif
28 BuildRequires:  libtool
29 BuildRequires:  pkgconfig
30 %if %{with gssglue}
31 Requires:       libgssglue >= 0.1
32 %else
33 Requires:       heimdal-libs
34 %endif
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 # FIXME: this allows invalid (unresolved symbols) library to be installed.
38 # Left until upstream fixes this properly.
39 %define no_install_post_check_so        1
40
41 %description
42 This package contains SunLib's implementation of transport-independent
43 RPC (TI-RPC) documentation. This library forms a piece of the base of
44 Open Network Computing (ONC), and is derived directly from the Solaris
45 2.3 source.
46
47 TI-RPC is an enhanced version of TS-RPC that requires the UNIX System
48 V Transport Layer Interface (TLI) or an equivalent X/Open Transport
49 Interface (XTI). TI-RPC is on-the-wire compatible with the TS-RPC,
50 which is supported by almost 70 vendors on all major operating
51 systems. TS-RPC source code (RPCSRC 4.0) remains available from
52 several Internet sites.
53
54 %description -l pl.UTF-8
55 Ten pakiet zawiera implementację SunLib RPC niezależnego od transportu
56 (TI-RPC). Ta biblioteka tworzy element podstawy dla ONC (Open Network
57 Computing) i wywodzi się bezpośrednio ze źródeł Solarisa 2.3.
58
59 TI-RPC to rozszerzona wersja TS-RPC wymagająca TLI (UNIX System V
60 Transport Layer Interface). Jest kompatybilna w locie z TS-RPC,
61 obsługiwanym przez prawie 70 producentów dla wszystkich znaczących
62 systemów operacyjnych. Kod źródłowy TS-RPC (RPCSRC 4.0) pozostaje
63 dostępny z różnych stron internetowych.
64
65 %package devel
66 Summary:        Development files for the TI-RPC library
67 Summary(pl.UTF-8):      Pliki programistyczne biblioteki TI-RPC
68 Group:          Development/Libraries
69 Requires:       %{name} = %{epoch}:%{version}-%{release}
70 %if %{with gssglue}
71 Requires:       libgssglue-devel >= 0.1
72 %else
73 Requires:       heimdal-devel
74 %endif
75
76 %description devel
77 This package includes header files necessary for developing programs
78 which use the TI-RPC library.
79
80 %description devel -l pl.UTF-8
81 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
82 wykorzystujących bibliotekę TI-RPC.
83
84 %package static
85 Summary:        Static TI-RPC library
86 Summary(pl.UTF-8):      Statyczna biblioteka TI-RPC
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
89
90 %description static
91 This package includes static TI-RPC library.
92
93 %description static -l pl.UTF-8
94 Ten pakiet zawiera statyczną bibliotekę TI-RPC.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 %patch1 -p1
100 %patch2 -p1
101 %patch3 -p1
102 %patch4 -p1
103
104 %build
105 %{__libtoolize}
106 %{__aclocal}
107 %{__autoconf}
108 %{__autoheader}
109 %{__automake}
110 %configure \
111         --enable-gss=%{?with_gssglue:libgssglue}%{!?with_gssglue:heimdal-gssapi}
112
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/%{_lib},%{_mandir}/man{3,5}}
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 %{__make} -C doc install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 mv -f $RPM_BUILD_ROOT%{_libdir}/libtirpc.so.* $RPM_BUILD_ROOT/%{_lib}
126 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libtirpc.so
127 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo lib*.so.*.*) \
128         $RPM_BUILD_ROOT%{_libdir}/libtirpc.so
129
130 # rpc headers for glibc 2.14+
131 install -d $RPM_BUILD_ROOT%{_includedir}/rpc
132 ln -s tirpc/netconfig.h $RPM_BUILD_ROOT%{_includedir}/netconfig.h
133 for i in $RPM_BUILD_ROOT%{_includedir}/tirpc/rpc/*.h; do
134         i="$(basename $i)"
135         ln -s ../tirpc/rpc/$i $RPM_BUILD_ROOT%{_includedir}/rpc/$i
136 done
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post   -p /sbin/ldconfig
142 %postun -p /sbin/ldconfig
143
144 %files
145 %defattr(644,root,root,755)
146 %doc AUTHORS ChangeLog NEWS README
147 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/netconfig
148 %attr(755,root,root) /%{_lib}/libtirpc.so.*.*
149 %attr(755,root,root) %ghost /%{_lib}/libtirpc.so.1
150 %{_mandir}/man5/netconfig.5*
151
152 %files devel
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/libtirpc.so
155 %{_includedir}/netconfig.h
156 %{_includedir}/rpc/*.h
157 %{_includedir}/tirpc
158 %{_pkgconfigdir}/libtirpc.pc
159 %{_mandir}/man3/bindresvport.3t*
160 %{_mandir}/man3/des_crypt.3t*
161 %{_mandir}/man3/getnet*.3t*
162 %{_mandir}/man3/getrpc*.3t*
163 %{_mandir}/man3/rpc*.3t*
164 %{_mandir}/man3/rtime.3t*
165
166 %files static
167 %defattr(644,root,root,755)
168 %{_libdir}/libtirpc.a
This page took 0.184945 seconds and 4 git commands to generate.