]> git.pld-linux.org Git - packages/libtirpc.git/blob - libtirpc.spec
- useful comment
[packages/libtirpc.git] / libtirpc.spec
1 #
2 # Conditional build:
3 %bcond_with     gssglue         # build with MIT Kerberos instead of Heimdal
4 #
5 Summary:        Transport Independent RPC Library
6 Summary(pl.UTF-8):      Biblioteka RPC niezależnego od transportu
7 Name:           libtirpc
8 Version:        0.2.2
9 Release:        3
10 Epoch:          1
11 License:        BSD-like
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/libtirpc/%{name}-%{version}.tar.bz2
14 # Source0-md5:  74c41c15c2909f7d11d9c7bfa7db6273
15 Patch0:         %{name}-link.patch
16 Patch1:         %{name}-heimdal.patch
17 # fixed in git
18 Patch2:         %{name}-XDR_GETPOS.patch
19 Patch3:         %{name}-rpc-des-prot.patch
20 Patch4:         %{name}-des-in-libc.patch
21 #Patch4:                %{name}-nis.patch
22 #Patch5:                %{name}-glibc-2.14.patch
23 URL:            http://sourceforge.net/projects/libtirpc/
24 BuildRequires:  autoconf >= 2.50
25 BuildRequires:  automake
26 BuildRequires:  glibc >= 6:2.14-9.1
27 %if %{with gssglue}
28 BuildRequires:  libgssglue-devel >= 0.1
29 %else
30 BuildRequires:  heimdal-devel
31 %endif
32 BuildRequires:  libtool
33 BuildRequires:  pkgconfig
34 %if %{with gssglue}
35 Requires:       libgssglue >= 0.1
36 %else
37 Requires:       heimdal-libs
38 %endif
39 Requires:       glibc >= 6:2.14-9.1
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 # FIXME: this allows invalid (unresolved symbols) library to be installed.
43 # Left until upstream fixes this properly.
44 %define no_install_post_check_so        1
45
46 %description
47 This package contains SunLib's implementation of transport-independent
48 RPC (TI-RPC) documentation. This library forms a piece of the base of
49 Open Network Computing (ONC), and is derived directly from the Solaris
50 2.3 source.
51
52 TI-RPC is an enhanced version of TS-RPC that requires the UNIX System
53 V Transport Layer Interface (TLI) or an equivalent X/Open Transport
54 Interface (XTI). TI-RPC is on-the-wire compatible with the TS-RPC,
55 which is supported by almost 70 vendors on all major operating
56 systems. TS-RPC source code (RPCSRC 4.0) remains available from
57 several Internet sites.
58
59 %description -l pl.UTF-8
60 Ten pakiet zawiera implementację SunLib RPC niezależnego od transportu
61 (TI-RPC). Ta biblioteka tworzy element podstawy dla ONC (Open Network
62 Computing) i wywodzi się bezpośrednio ze źródeł Solarisa 2.3.
63
64 TI-RPC to rozszerzona wersja TS-RPC wymagająca TLI (UNIX System V
65 Transport Layer Interface). Jest kompatybilna w locie z TS-RPC,
66 obsługiwanym przez prawie 70 producentów dla wszystkich znaczących
67 systemów operacyjnych. Kod źródłowy TS-RPC (RPCSRC 4.0) pozostaje
68 dostępny z różnych stron internetowych.
69
70 %package devel
71 Summary:        Development files for the TI-RPC library
72 Summary(pl.UTF-8):      Pliki programistyczne biblioteki TI-RPC
73 Group:          Development/Libraries
74 Requires:       %{name} = %{epoch}:%{version}-%{release}
75 Requires:       glibc-devel >= 6:2.14-9.1
76 %if %{with gssglue}
77 Requires:       libgssglue-devel >= 0.1
78 %else
79 Requires:       heimdal-devel
80 %endif
81
82 %description devel
83 This package includes header files necessary for developing programs
84 which use the TI-RPC library.
85
86 %description devel -l pl.UTF-8
87 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
88 wykorzystujących bibliotekę TI-RPC.
89
90 %package static
91 Summary:        Static TI-RPC library
92 Summary(pl.UTF-8):      Statyczna biblioteka TI-RPC
93 Group:          Development/Libraries
94 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
95
96 %description static
97 This package includes static TI-RPC library.
98
99 %description static -l pl.UTF-8
100 Ten pakiet zawiera statyczną bibliotekę TI-RPC.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 %patch1 -p1
106 %patch2 -p1
107 %patch3 -p1
108 %patch4 -p1
109
110 %build
111 %{__libtoolize}
112 %{__aclocal}
113 %{__autoconf}
114 %{__autoheader}
115 %{__automake}
116 %configure \
117         --enable-gss=%{?with_gssglue:libgssglue}%{!?with_gssglue:heimdal-gssapi}
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/%{_lib},%{_mandir}/man{3,5}}
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 %{__make} -C doc install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 mv -f $RPM_BUILD_ROOT%{_libdir}/libtirpc.so.* $RPM_BUILD_ROOT/%{_lib}
132 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libtirpc.so
133 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo lib*.so.*.*) \
134         $RPM_BUILD_ROOT%{_libdir}/libtirpc.so
135
136 # obsoleted by pkgconfig
137 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libtirpc.la
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post   -p /sbin/ldconfig
143 %postun -p /sbin/ldconfig
144
145 %files
146 %defattr(644,root,root,755)
147 %doc AUTHORS ChangeLog NEWS README
148 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/netconfig
149 %attr(755,root,root) /%{_lib}/libtirpc.so.*.*
150 %attr(755,root,root) %ghost /%{_lib}/libtirpc.so.1
151 %{_mandir}/man5/netconfig.5*
152
153 %files devel
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/libtirpc.so
156 %{_includedir}/tirpc
157 %{_pkgconfigdir}/libtirpc.pc
158 %{_mandir}/man3/bindresvport.3t*
159 %{_mandir}/man3/des_crypt.3t*
160 %{_mandir}/man3/getnet*.3t*
161 %{_mandir}/man3/getrpc*.3t*
162 %{_mandir}/man3/rpc*.3t*
163 %{_mandir}/man3/rtime.3t*
164
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/libtirpc.a
This page took 0.03803 seconds and 4 git commands to generate.