]> git.pld-linux.org Git - packages/libteam.git/blob - libteam.spec
Let's have a very nasty hack to fix system halt
[packages/libteam.git] / libteam.spec
1 Summary:        Library for controlling team network device
2 Summary(pl.UTF-8):      Biblioteka do sterowania grupowymi urządzeniami sieciowymi
3 Name:           libteam
4 Version:        1.25
5 Release:        2
6 License:        LGPL v2.1+
7 Group:          Libraries
8 #Source0Download: http://libteam.org/
9 Source0:        http://libteam.org/files/%{name}-%{version}.tar.gz
10 # Source0-md5:  9e51c42b08ff8e80561e0b1cd5af266f
11 Source1:    teamd.sysconfig
12 Source2:    teamd-lvl1-service-generator
13 Source3:    teamd-lvl2-service-generator
14 Source4:    teamd@.service
15 Source5:    teamd-lvl1.target
16 Source6:    teamd-lvl2.target
17 # You might not be able to shut down your system without this:
18 # https://lists.fedorahosted.org/archives/list/libteam@lists.fedorahosted.org/thread/QYCLFVANHB47URKOST5HFT5EVWPRHGVQ/
19 Source7:    teamd-shutdown-workaround.service
20 Patch0:         %{name}-link.patch
21 URL:            http://libteam.org/
22 BuildRequires:  autoconf >= 2.50
23 BuildRequires:  automake
24 BuildRequires:  dbus-devel
25 BuildRequires:  jansson-devel
26 # if non-root --with-group or --with-user
27 #BuildRequires: libcap-devel
28 BuildRequires:  libdaemon-devel
29 BuildRequires:  libnl-devel >= 3.2
30 BuildRequires:  libtool >= 2:2
31 BuildRequires:  pkgconfig
32 BuildRequires:  zeromq-devel >= 3.2.0
33 Requires:       libnl >= 3.2
34 Requires:       zeromq >= 3.2.0
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 The purpose of the Team driver is to provide a mechanism to team
39 multiple NICs (ports) into one logical one (teamdev) at L2 layer. The
40 process is called "channel bonding", "Ethernet bonding", "channel
41 teaming", "link aggregation", etc. This is already implemented in the
42 Linux kernel by the bonding driver.
43
44 One thing to note is that Team driver project does try to provide the
45 similar functionality as the bonding driver, however architecturally
46 it is quite different from bonding driver. Team driver is modular,
47 userspace driven, very lean and efficient, and it does have some
48 distinct advantages over bonding. The way Team is configured differs
49 dramatically from the way bonding is.
50
51 %description -l pl.UTF-8
52 Celem sterownika Team jest dostarczenie mechanizmu do grupowania
53 (team) wielu interfejsów (portów) sieciowych (czyli NIC) w jeden
54 logiczny (teamdev) w warstwie L2. Proces ten jest nazywany
55 "channel bonding", "Ethernet bonding", "channel teaming", "link
56 aggregation" itp. Jest to już zaimplementowane w jądrze Linuksa
57 poprzez sterownik bonding.
58
59 Należy zauważyć, że projekt sterownika Team próbuje zapewnić
60 podobną funkcjonalność co sterownik bonding, ale architektonicznie
61 różni się od niego. Jest modularny, działa w przestrzeni użytkownika,
62 jest bardzo lekki i wydajny, ma też kilka zalet, których nie ma
63 bonding. Sposób konfiguracji sterownika Team znacząco różni się od
64 konfiguracji sterownika bonding.
65
66 %package devel
67 Summary:        Header files for libteam library
68 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libteam
69 Group:          Development/Libraries
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       libnl-devel >= 3.2
72
73 %description devel
74 Header files for libteam library.
75
76 %description devel -l pl.UTF-8
77 Pliki nagłówkowe biblioteki libteam.
78
79 %package static
80 Summary:        Static libteam library
81 Summary(pl.UTF-8):      Statyczna biblioteka libteam
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 Static libteam library.
87
88 %description static -l pl.UTF-8
89 Statyczna biblioteka libteam.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94
95 %build
96 %{__libtoolize}
97 %{__aclocal} -I m4
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         --disable-silent-rules
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT/etc/dbus-1/system.d \
109            $RPM_BUILD_ROOT/etc/sysconfig \
110            $RPM_BUILD_ROOT/lib/systemd/{system-generators,system}
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 install teamd/dbus/teamd.conf $RPM_BUILD_ROOT/etc/dbus-1/system.d
116 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/teamd
117 install %{SOURCE2} $RPM_BUILD_ROOT/lib/systemd/system-generators
118 install %{SOURCE3} $RPM_BUILD_ROOT/lib/systemd/system-generators
119 install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}
120 install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}
121 install %{SOURCE6} $RPM_BUILD_ROOT%{systemdunitdir}
122 install %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}
123
124 # obsoleted by pkg-config
125 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post
131 /sbin/ldconfig
132 %systemd_post teamd-lvl1.target teamd-lvl2.target teamd-shutdown-workaround.service
133
134 %preun
135 %systemd_preun teamd-lvl1.target teamd-lvl2.target teamd-shutdown-workaround.service
136
137 %postun
138 /sbin/ldconfig
139 %systemd_reload
140
141 %files
142 %defattr(644,root,root,755)
143 %doc README teamd/example_configs
144 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/teamd
145 /etc/dbus-1/system.d/teamd.conf
146 %{systemdunitdir}/teamd@.service
147 %{systemdunitdir}/teamd-lvl?.target
148 %{systemdunitdir}/teamd-shutdown-workaround.service
149 %attr(755,root,root) %{_bindir}/bond2team
150 %attr(755,root,root) %{_bindir}/teamd
151 %attr(755,root,root) %{_bindir}/teamdctl
152 %attr(755,root,root) %{_bindir}/teamnl
153 %attr(755,root,root) %{_libdir}/libteam.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libteam.so.5
155 %attr(755,root,root) %{_libdir}/libteamdctl.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libteamdctl.so.0
157 %attr(755,root,root) /lib/systemd/system-generators/teamd-lvl?-service-generator
158 %{_mandir}/man1/bond2team.1*
159 %{_mandir}/man5/teamd.conf.5*
160 %{_mandir}/man8/teamd.8*
161 %{_mandir}/man8/teamdctl.8*
162 %{_mandir}/man8/teamnl.8*
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libteam.so
167 %attr(755,root,root) %{_libdir}/libteamdctl.so
168 %{_includedir}/team.h
169 %{_includedir}/teamdctl.h
170 %{_pkgconfigdir}/libteam.pc
171 %{_pkgconfigdir}/libteamdctl.pc
172
173 %files static
174 %defattr(644,root,root,755)
175 %{_libdir}/libteam.a
176 %{_libdir}/libteamdctl.a
This page took 0.283907 seconds and 3 git commands to generate.