]> git.pld-linux.org Git - packages/libsvgtiny.git/blob - libsvgtiny.spec
- pl
[packages/libsvgtiny.git] / libsvgtiny.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Implementation of SVG Tiny
6 Summary(pl.UTF-8):      Implementacja SVG Tiny
7 Name:           libsvgtiny
8 Version:        0.1.1
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
13 # Source0-md5:  6e3da8ecfde7749852a66195ebea0de1
14 URL:            http://www.netsurf-browser.org/projects/libsvgtiny/
15 BuildRequires:  gperf
16 BuildRequires:  libdom-devel >= 0.1.0
17 BuildRequires:  libwapcaplet-devel >= 0.2.1
18 BuildRequires:  netsurf-buildsystem >= 1.1
19 BuildRequires:  pkgconfig
20 Requires:       libdom >= 0.1.0
21 Requires:       libwapcaplet >= 0.2.1
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Libsvgtiny is an implementation of SVG Tiny, written in C. It is
26 currently in development for use with NetSurf and is intended to be
27 suitable for use in other projects too.
28
29 The overall idea of the library is to take some SVG as input, and
30 return a list of paths and texts which can be rendered easily. The
31 library does not do the actual rendering.
32
33 %description -l pl.UTF-8
34 Libsvgtiny to implementacja SVG Tiny napisana w C. Jest obecnie
35 rozwijana do wykorzystania w ramach projektu NetSurf, ale także z
36 myślą o możliwości użycia w innych projektach.
37
38 Ogólna idea biblioteki polega na przyjęciu SVG na wejściu i zwróceniu
39 listy ścieżek oraz tekstów, które można łatwo wyrenderować. Biblioteka
40 nie wykonuje samego renderowania.
41
42 %package devel
43 Summary:        libsvgtiny library headers
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsvgtiny
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       libdom-devel >= 0.1.0
48
49 %description devel
50 This package contains the include files and other resources you can
51 use to incorporate libsvgtiny into applications.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe pozwalające na używanie biblioteki libsvgtiny w
55 swoich programach.
56
57 %package static
58 Summary:        libsvgtiny static library
59 Summary(pl.UTF-8):      Statyczna biblioteka libsvgtiny
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 This is package with static libsvgtiny library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka libsvgtiny.
68
69 %prep
70 %setup -q
71
72 %build
73 export CC="%{__cc}"
74 export CFLAGS="%{rpmcflags}"
75 export LDFLAGS="%{rpmldflags}"
76
77 %{__make} \
78         Q= \
79         PREFIX=%{_prefix} \
80         LIBDIR=%{_lib} \
81         COMPONENT_TYPE=lib-shared
82
83 %if %{with static_libs}
84 %{__make} \
85         Q= \
86         PREFIX=%{_prefix} \
87         LIBDIR=%{_lib} \
88         COMPONENT_TYPE=lib-static
89 %endif
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 %{__make} install \
94         Q= \
95         PREFIX=%{_prefix} \
96         LIBDIR=%{_lib} \
97         COMPONENT_TYPE=lib-shared \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 %if %{with static_libs}
101 %{__make} install \
102         Q= \
103         PREFIX=%{_prefix} \
104         LIBDIR=%{_lib} \
105         COMPONENT_TYPE=lib-static \
106         DESTDIR=$RPM_BUILD_ROOT
107 %endif
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc README
118 %attr(755,root,root) %{_libdir}/libsvgtiny.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libsvgtiny.so.0
120
121 %files devel
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_libdir}/libsvgtiny.so
124 %{_includedir}/svgtiny.h
125 %{_pkgconfigdir}/libsvgtiny.pc
126
127 %if %{with static_libs}
128 %files static
129 %defattr(644,root,root,755)
130 %{_libdir}/libsvgtiny.a
131 %endif
This page took 0.093372 seconds and 4 git commands to generate.