]> git.pld-linux.org Git - packages/libsvgtiny.git/blob - libsvgtiny.spec
pass our CC, fix bad make commandline
[packages/libsvgtiny.git] / libsvgtiny.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Implementation of SVG Tiny
6 Name:           libsvgtiny
7 Version:        0.1.0
8 Release:        1
9 License:        MIT
10 Group:          Libraries
11 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
12 # Source0-md5:  b1da875a8cfa4e005bb74c6aac62baf1
13 URL:            http://www.netsurf-browser.org/projects/libsvgtiny/
14 BuildRequires:  libdom-devel >= 0.0.1
15 BuildRequires:  libwapcaplet-devel >= 0.2.0
16 BuildRequires:  netsurf-buildsystem
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Libsvgtiny is an implementation of SVG Tiny, written in C. It is
21 currently in development for use with NetSurf and is intended to be
22 suitable for use in other projects too.
23
24 The overall idea of the library is to take some SVG as input, and
25 return a list of paths and texts which can be rendered easily. The
26 library does not do the actual rendering.
27
28 %package devel
29 Summary:        libsvgtiny library headers
30 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsvgtiny
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33
34 %description devel
35 This is the libraries, include files and other resources you can use
36 to incorporate libsvgtiny into applications.
37
38 %description devel -l pl.UTF-8
39 Pliki nagłówkowe pozwalające na używanie biblioteki libsvgtiny w
40 swoich programach.
41
42 %package static
43 Summary:        libsvgtiny static libraries
44 Summary(pl.UTF-8):      Statyczne biblioteki libsvgtiny
45 Group:          Development/Libraries
46 Requires:       %{name}-devel = %{version}-%{release}
47
48 %description static
49 This is package with static libsvgtiny libraries.
50
51 %description static -l pl.UTF-8
52 Statyczna biblioteka libsvgtiny.
53
54 %prep
55 %setup -q
56
57 %build
58 export CC="%{__cc}"
59 export CFLAGS="%{rpmcflags}"
60 export LDFLAGS="%{rpmldflags}"
61
62 %{__make} Q= \
63         PREFIX=%{_prefix} \
64         COMPONENT_TYPE=lib-shared
65
66 %if %{with static_libs}
67 %{__make} Q= \
68         PREFIX=%{_prefix} \
69         COMPONENT_TYPE=lib-static
70 %endif
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 %{__make} install Q= \
75         PREFIX=%{_prefix} \
76         COMPONENT_TYPE=lib-shared \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %if %{with static_libs}
80 %{__make} install Q= \
81         PREFIX=%{_prefix} \
82         COMPONENT_TYPE=lib-static \
83         DESTDIR=$RPM_BUILD_ROOT
84 %endif
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post   -p /sbin/ldconfig
90 %postun -p /sbin/ldconfig
91
92 %files
93 %defattr(644,root,root,755)
94 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/lib*.so
99 %{_includedir}/*.h
100 %{_pkgconfigdir}/*pc
101
102 %if %{with static_libs}
103 %files static
104 %defattr(644,root,root,755)
105 %{_libdir}/lib*.a
106 %endif
This page took 0.069314 seconds and 4 git commands to generate.