]> git.pld-linux.org Git - packages/libsvgtiny.git/blob - libsvgtiny.spec
- updated to 0.1.2
[packages/libsvgtiny.git] / libsvgtiny.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Implementation of SVG Tiny
6 Summary(pl.UTF-8):      Implementacja SVG Tiny
7 Name:           libsvgtiny
8 Version:        0.1.2
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
13 # Source0-md5:  33471a498cfe206afdf57d747ed93f39
14 Patch0:         no-Werror.patch
15 URL:            http://www.netsurf-browser.org/projects/libsvgtiny/
16 BuildRequires:  gperf
17 BuildRequires:  libdom-devel >= 0.1.1
18 BuildRequires:  libwapcaplet-devel >= 0.2.1
19 BuildRequires:  netsurf-buildsystem >= 1.2
20 BuildRequires:  pkgconfig
21 Requires:       libdom >= 0.1.0
22 Requires:       libwapcaplet >= 0.2.1
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Libsvgtiny is an implementation of SVG Tiny, written in C. It is
27 currently in development for use with NetSurf and is intended to be
28 suitable for use in other projects too.
29
30 The overall idea of the library is to take some SVG as input, and
31 return a list of paths and texts which can be rendered easily. The
32 library does not do the actual rendering.
33
34 %description -l pl.UTF-8
35 Libsvgtiny to implementacja SVG Tiny napisana w C. Jest obecnie
36 rozwijana do wykorzystania w ramach projektu NetSurf, ale także z
37 myślą o możliwości użycia w innych projektach.
38
39 Ogólna idea biblioteki polega na przyjęciu SVG na wejściu i zwróceniu
40 listy ścieżek oraz tekstów, które można łatwo wyrenderować. Biblioteka
41 nie wykonuje samego renderowania.
42
43 %package devel
44 Summary:        libsvgtiny library headers
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsvgtiny
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       libdom-devel >= 0.1.0
49
50 %description devel
51 This package contains the include files and other resources you can
52 use to incorporate libsvgtiny into applications.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe pozwalające na używanie biblioteki libsvgtiny w
56 swoich programach.
57
58 %package static
59 Summary:        libsvgtiny static library
60 Summary(pl.UTF-8):      Statyczna biblioteka libsvgtiny
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 This is package with static libsvgtiny library.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka libsvgtiny.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73
74 %build
75 export CC="%{__cc}"
76 export CFLAGS="%{rpmcflags}"
77 export LDFLAGS="%{rpmldflags}"
78
79 %{__make} \
80         Q= \
81         PREFIX=%{_prefix} \
82         LIBDIR=%{_lib} \
83         COMPONENT_TYPE=lib-shared
84
85 %if %{with static_libs}
86 %{__make} \
87         Q= \
88         PREFIX=%{_prefix} \
89         LIBDIR=%{_lib} \
90         COMPONENT_TYPE=lib-static
91 %endif
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 %{__make} install \
96         Q= \
97         PREFIX=%{_prefix} \
98         LIBDIR=%{_lib} \
99         COMPONENT_TYPE=lib-shared \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %if %{with static_libs}
103 %{__make} install \
104         Q= \
105         PREFIX=%{_prefix} \
106         LIBDIR=%{_lib} \
107         COMPONENT_TYPE=lib-static \
108         DESTDIR=$RPM_BUILD_ROOT
109 %endif
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc README
120 %attr(755,root,root) %{_libdir}/libsvgtiny.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libsvgtiny.so.0
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/libsvgtiny.so
126 %{_includedir}/svgtiny.h
127 %{_pkgconfigdir}/libsvgtiny.pc
128
129 %if %{with static_libs}
130 %files static
131 %defattr(644,root,root,755)
132 %{_libdir}/libsvgtiny.a
133 %endif
This page took 0.074467 seconds and 4 git commands to generate.