]> git.pld-linux.org Git - packages/libsvgtiny.git/blob - libsvgtiny.spec
fix install in lib64 systems
[packages/libsvgtiny.git] / libsvgtiny.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Implementation of SVG Tiny
6 Name:           libsvgtiny
7 Version:        0.1.0
8 Release:        1
9 License:        MIT
10 Group:          Libraries
11 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
12 # Source0-md5:  b1da875a8cfa4e005bb74c6aac62baf1
13 Patch0:         lib.patch
14 URL:            http://www.netsurf-browser.org/projects/libsvgtiny/
15 BuildRequires:  libdom-devel >= 0.0.1
16 BuildRequires:  libwapcaplet-devel >= 0.2.0
17 BuildRequires:  netsurf-buildsystem
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Libsvgtiny is an implementation of SVG Tiny, written in C. It is
22 currently in development for use with NetSurf and is intended to be
23 suitable for use in other projects too.
24
25 The overall idea of the library is to take some SVG as input, and
26 return a list of paths and texts which can be rendered easily. The
27 library does not do the actual rendering.
28
29 %package devel
30 Summary:        libsvgtiny library headers
31 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsvgtiny
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34
35 %description devel
36 This is the libraries, include files and other resources you can use
37 to incorporate libsvgtiny into applications.
38
39 %description devel -l pl.UTF-8
40 Pliki nagłówkowe pozwalające na używanie biblioteki libsvgtiny w
41 swoich programach.
42
43 %package static
44 Summary:        libsvgtiny static libraries
45 Summary(pl.UTF-8):      Statyczne biblioteki libsvgtiny
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48
49 %description static
50 This is package with static libsvgtiny libraries.
51
52 %description static -l pl.UTF-8
53 Statyczna biblioteka libsvgtiny.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58
59 %build
60 export CC="%{__cc}"
61 export CFLAGS="%{rpmcflags}"
62 export LDFLAGS="%{rpmldflags}"
63
64 %{__make} Q= \
65         PREFIX=%{_prefix} \
66         COMPONENT_TYPE=lib-shared
67
68 %if %{with static_libs}
69 %{__make} Q= \
70         PREFIX=%{_prefix} \
71         COMPONENT_TYPE=lib-static
72 %endif
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 %{__make} install Q= \
77         lib=%{_lib} \
78         PREFIX=%{_prefix} \
79         COMPONENT_TYPE=lib-shared \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 %if %{with static_libs}
83 %{__make} install Q= \
84         lib=%{_lib} \
85         PREFIX=%{_prefix} \
86         COMPONENT_TYPE=lib-static \
87         DESTDIR=$RPM_BUILD_ROOT
88 %endif
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
99
100 %files devel
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_libdir}/lib*.so
103 %{_includedir}/*.h
104 %{_pkgconfigdir}/*pc
105
106 %if %{with static_libs}
107 %files static
108 %defattr(644,root,root,755)
109 %{_libdir}/lib*.a
110 %endif
This page took 0.045182 seconds and 4 git commands to generate.