]> git.pld-linux.org Git - packages/libsvgtiny.git/blob - libsvgtiny.spec
obsolete lib.patch deleted
[packages/libsvgtiny.git] / libsvgtiny.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Implementation of SVG Tiny
6 Name:           libsvgtiny
7 Version:        0.1.1
8 Release:        1
9 License:        MIT
10 Group:          Libraries
11 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
12 # Source0-md5:  6e3da8ecfde7749852a66195ebea0de1
13 URL:            http://www.netsurf-browser.org/projects/libsvgtiny/
14 BuildRequires:  gperf
15 BuildRequires:  libdom-devel >= 0.1.0
16 BuildRequires:  libwapcaplet-devel >= 0.2.1
17 BuildRequires:  netsurf-buildsystem >= 1.1
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Libsvgtiny is an implementation of SVG Tiny, written in C. It is
22 currently in development for use with NetSurf and is intended to be
23 suitable for use in other projects too.
24
25 The overall idea of the library is to take some SVG as input, and
26 return a list of paths and texts which can be rendered easily. The
27 library does not do the actual rendering.
28
29 %package devel
30 Summary:        libsvgtiny library headers
31 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsvgtiny
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34
35 %description devel
36 This is the libraries, include files and other resources you can use
37 to incorporate libsvgtiny into applications.
38
39 %description devel -l pl.UTF-8
40 Pliki nagłówkowe pozwalające na używanie biblioteki libsvgtiny w
41 swoich programach.
42
43 %package static
44 Summary:        libsvgtiny static libraries
45 Summary(pl.UTF-8):      Statyczne biblioteki libsvgtiny
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48
49 %description static
50 This is package with static libsvgtiny libraries.
51
52 %description static -l pl.UTF-8
53 Statyczna biblioteka libsvgtiny.
54
55 %prep
56 %setup -q
57
58 %build
59 export CC="%{__cc}"
60 export CFLAGS="%{rpmcflags}"
61 export LDFLAGS="%{rpmldflags}"
62
63 %{__make} Q= \
64         PREFIX=%{_prefix} \
65         COMPONENT_TYPE=lib-shared
66
67 %if %{with static_libs}
68 %{__make} Q= \
69         PREFIX=%{_prefix} \
70         COMPONENT_TYPE=lib-static
71 %endif
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 %{__make} install Q= \
76         lib=%{_lib} \
77         PREFIX=%{_prefix} \
78         COMPONENT_TYPE=lib-shared \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %if %{with static_libs}
82 %{__make} install Q= \
83         lib=%{_lib} \
84         PREFIX=%{_prefix} \
85         COMPONENT_TYPE=lib-static \
86         DESTDIR=$RPM_BUILD_ROOT
87 %endif
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %attr(755,root,root) %{_libdir}/libsvgtiny.so.*.*.*
98 %ghost %{_libdir}/libsvgtiny.so.0
99
100 %files devel
101 %defattr(644,root,root,755)
102 %{_libdir}/libsvgtiny.so
103 %{_includedir}/svgtiny.h
104 %{_pkgconfigdir}/libsvgtiny.pc
105
106 %if %{with static_libs}
107 %files static
108 %defattr(644,root,root,755)
109 %{_libdir}/libsvgtiny.a
110 %endif
This page took 0.083207 seconds and 4 git commands to generate.