]> git.pld-linux.org Git - packages/libsvgtiny.git/blob - libsvgtiny.spec
- new
[packages/libsvgtiny.git] / libsvgtiny.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Implementation of SVG Tiny
6 Name:           libsvgtiny
7 Version:        0.1.0
8 Release:        1
9 License:        MIT
10 Group:          Libraries
11 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
12 # Source0-md5:  b1da875a8cfa4e005bb74c6aac62baf1
13 URL:            http://www.netsurf-browser.org/projects/libsvgtiny/
14 BuildRequires:  libdom-devel >= 0.0.1
15 BuildRequires:  libwapcaplet-devel >= 0.2.0
16 BuildRequires:  netsurf-buildsystem
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Libsvgtiny is an implementation of SVG Tiny, written in C. It is
21 currently in development for use with NetSurf and is intended to be
22 suitable for use in other projects too.
23
24 The overall idea of the library is to take some SVG as input, and
25 return a list of paths and texts which can be rendered easily. The
26 library does not do the actual rendering.
27
28 %package devel
29 Summary:        libsvgtiny library headers
30 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsvgtiny
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33
34 %description devel
35 This is the libraries, include files and other resources you can use
36 to incorporate libsvgtiny into applications.
37
38 %description devel -l pl.UTF-8
39 Pliki nagłówkowe pozwalające na używanie biblioteki libsvgtiny w
40 swoich programach.
41
42 %package static
43 Summary:        libsvgtiny static libraries
44 Summary(pl.UTF-8):      Statyczne biblioteki libsvgtiny
45 Group:          Development/Libraries
46 Requires:       %{name}-devel = %{version}-%{release}
47
48 %description static
49 This is package with static libsvgtiny libraries.
50
51 %description static -l pl.UTF-8
52 Statyczna biblioteka libsvgtiny.
53
54 %prep
55 %setup -q
56
57 %build
58 CFLAGS="%{rpmcflags}"
59 LDFLAGS="%{rpmldflags}"
60 export CFLAGS
61 export LDFLAGS
62
63 %{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-shared Q='' \
64         -Iinclude -Isrc"
65 %if %{with static_libs}
66 %{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-static Q='' \
67         -Iinclude -Isrc"
68 %endif
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT \
75         PREFIX=%{_prefix} \
76         COMPONENT_TYPE=lib-shared \
77         Q=''
78
79 %if %{with static_libs}
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT \
82         PREFIX=%{_prefix} \
83         COMPONENT_TYPE=lib-static \
84         Q=''
85 %endif
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
96
97 %files devel
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_libdir}/lib*.so
100 %{_includedir}/*.h
101 %{_pkgconfigdir}/*pc
102
103 %if %{with static_libs}
104 %files static
105 %defattr(644,root,root,755)
106 %{_libdir}/lib*.a
107 %endif
This page took 0.103776 seconds and 4 git commands to generate.