]> git.pld-linux.org Git - packages/libsvgtiny.git/blob - libsvgtiny.spec
- up to 0.1.1
[packages/libsvgtiny.git] / libsvgtiny.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Implementation of SVG Tiny
6 Name:           libsvgtiny
7 Version:        0.1.1
8 Release:        1
9 License:        MIT
10 Group:          Libraries
11 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
12 # Source0-md5:  6e3da8ecfde7749852a66195ebea0de1
13 #Patch0:                lib.patch
14 URL:            http://www.netsurf-browser.org/projects/libsvgtiny/
15 BuildRequires:  gperf
16 BuildRequires:  libdom-devel >= 0.1.0
17 BuildRequires:  libwapcaplet-devel >= 0.2.1
18 BuildRequires:  netsurf-buildsystem >= 1.1
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Libsvgtiny is an implementation of SVG Tiny, written in C. It is
23 currently in development for use with NetSurf and is intended to be
24 suitable for use in other projects too.
25
26 The overall idea of the library is to take some SVG as input, and
27 return a list of paths and texts which can be rendered easily. The
28 library does not do the actual rendering.
29
30 %package devel
31 Summary:        libsvgtiny library headers
32 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsvgtiny
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35
36 %description devel
37 This is the libraries, include files and other resources you can use
38 to incorporate libsvgtiny into applications.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe pozwalające na używanie biblioteki libsvgtiny w
42 swoich programach.
43
44 %package static
45 Summary:        libsvgtiny static libraries
46 Summary(pl.UTF-8):      Statyczne biblioteki libsvgtiny
47 Group:          Development/Libraries
48 Requires:       %{name}-devel = %{version}-%{release}
49
50 %description static
51 This is package with static libsvgtiny libraries.
52
53 %description static -l pl.UTF-8
54 Statyczna biblioteka libsvgtiny.
55
56 %prep
57 %setup -q
58 #%%patch0 -p1
59
60 %build
61 export CC="%{__cc}"
62 export CFLAGS="%{rpmcflags}"
63 export LDFLAGS="%{rpmldflags}"
64
65 %{__make} Q= \
66         PREFIX=%{_prefix} \
67         COMPONENT_TYPE=lib-shared
68
69 %if %{with static_libs}
70 %{__make} Q= \
71         PREFIX=%{_prefix} \
72         COMPONENT_TYPE=lib-static
73 %endif
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 %{__make} install Q= \
78         lib=%{_lib} \
79         PREFIX=%{_prefix} \
80         COMPONENT_TYPE=lib-shared \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %if %{with static_libs}
84 %{__make} install Q= \
85         lib=%{_lib} \
86         PREFIX=%{_prefix} \
87         COMPONENT_TYPE=lib-static \
88         DESTDIR=$RPM_BUILD_ROOT
89 %endif
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_libdir}/libsvgtiny.so.*.*.*
100 %ghost %{_libdir}/libsvgtiny.so.0
101
102 %files devel
103 %defattr(644,root,root,755)
104 %{_libdir}/libsvgtiny.so
105 %{_includedir}/svgtiny.h
106 %{_pkgconfigdir}/libsvgtiny.pc
107
108 %if %{with static_libs}
109 %files static
110 %defattr(644,root,root,755)
111 %{_libdir}/libsvgtiny.a
112 %endif
This page took 0.084729 seconds and 4 git commands to generate.