]> git.pld-linux.org Git - packages/libsoup3.git/blob - libsoup.spec
e78727f2078777fba3b6f6e5bced2ecdc8f16b76
[packages/libsoup3.git] / libsoup.spec
1 Summary:        SOAP (Simple Object Access Protocol) implementation in C
2 Summary(pl.UTF-8):      Implementacja w C SOAP (Simple Object Access Protocol)
3 Name:           libsoup
4 Version:        2.32.2
5 Release:        2
6 License:        LGPL v2+
7 Group:          Libraries
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libsoup/2.32/%{name}-%{version}.tar.bz2
9 # Source0-md5:  03f37350a2a31046ebabb8470e75abcc
10 URL:            http://www.gnome.org/
11 BuildRequires:  GConf2-devel
12 BuildRequires:  autoconf >= 2.63
13 BuildRequires:  automake >= 1:1.9
14 BuildRequires:  docbook-dtd412-xml
15 BuildRequires:  glib2-devel >= 1:2.22.0
16 BuildRequires:  gnutls-devel >= 2.1.7
17 BuildRequires:  gobject-introspection-devel >= 0.9.5
18 BuildRequires:  gtk-doc >= 1.10
19 BuildRequires:  libgnome-keyring-devel
20 BuildRequires:  libproxy-devel
21 BuildRequires:  libtool
22 BuildRequires:  libxml2-devel >= 1:2.6.31
23 BuildRequires:  pkgconfig
24 BuildRequires:  sqlite3-devel
25 Requires:       glib2 >= 1:2.22.0
26 Requires:       gnutls >= 2.1.7
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 It provides an queued asynchronous callback-based mechanism for
31 sending and servicing SOAP requests, and a WSDL (Web Service
32 Definition Language) to C compiler which generates client stubs and
33 server skeletons for easily calling and implementing SOAP methods.
34
35 %description -l pl.UTF-8
36 Pakiet dostarcza interfejs kolejkowalnego, asynchronicznego mechanizmu
37 do wysyłania i serwowania żądań SOAP oraz WSDL (Web Service Definition
38 Language) dla kompilatora C, który generuje klienckie stub i szkielety
39 serwerów dla łatwego wywoływania i implementowania metod SOAP.
40
41 %package devel
42 Summary:        Include files etc to develop SOAP applications
43 Summary(pl.UTF-8):      Pliki nagłówkowe, dokumentacja dla SOAP
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       glib2-devel >= 1:2.22.0
47 Requires:       gnutls-devel >= 2.1.7
48 Requires:       libproxy-devel
49 Requires:       libxml2-devel >= 1:2.6.31
50
51 %description devel
52 Header files, etc you can use to develop SOAP applications.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe itp. Jednym słowem wszystko czego potrzebujesz aby
56 samemu tworzyć sobie aplikacje korzystające z SOAP.
57
58 %package static
59 Summary:        SOAP static libraries
60 Summary(pl.UTF-8):      Biblioteki statyczne SOAP
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 SOAP static libraries.
66
67 %description static -l pl.UTF-8
68 Biblioteki statyczne SOAP.
69
70 %package gnome
71 Summary:        GNOME specific extensions to libsoup library
72 Summary(pl.UTF-8):      Rozszerzenia GNOME do biblioteki libsoup
73 Group:          Libraries
74 Requires:       %{name} = %{version}-%{release}
75
76 %description gnome
77 GNOME specific extensions to libsoup library.
78
79 %description gnome -l pl.UTF-8
80 Rozszerzenia GNOME do biblioteki libsoup.
81
82 %package gnome-devel
83 Summary:        Header files for libsoup-gnome library
84 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsoup-gnome
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87 Requires:       %{name}-gnome = %{version}-%{release}
88
89 %description gnome-devel
90 Header files for libsoup-gnome library.
91
92 %description gnome-devel -l pl.UTF-8
93 Pliki nagłówkowe biblioteki libsoup-gnome.
94
95 %package gnome-static
96 Summary:        Static libsoup-gnome library
97 Summary(pl.UTF-8):      Statyczna biblioteka libsoup-gnome
98 Group:          Development/Libraries
99 Requires:       %{name}-gnome-devel = %{version}-%{release}
100
101 %description gnome-static
102 Static libsoup-gnome library.
103
104 %description gnome-static -l pl.UTF-8
105 Statyczna biblioteka libsoup-gnome.
106
107 %package apidocs
108 Summary:        libsoup API documentation
109 Summary(pl.UTF-8):      Dokumentacja API libsoup
110 Group:          Documentation
111 Requires:       gtk-doc-common
112
113 %description apidocs
114 libsoup API documentation.
115
116 %description apidocs -l pl.UTF-8
117 Dokumentacja API libsoup.
118
119 %prep
120 %setup -q
121
122 %build
123 %{__gtkdocize}
124 %{__glib_gettextize}
125 %{__libtoolize}
126 %{__aclocal}
127 %{__autoconf}
128 %{__autoheader}
129 %{__automake}
130 %configure \
131         --enable-ssl \
132         --enable-gtk-doc \
133         --with-html-dir=%{_gtkdocdir} \
134         --disable-silent-rules
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139
140 %{__make} install \
141         pkgconfigdir=%{_pkgconfigdir} \
142         m4datadir=%{_aclocaldir} \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post   -p /sbin/ldconfig
149 %postun -p /sbin/ldconfig
150
151 %post   gnome -p /sbin/ldconfig
152 %postun gnome -p /sbin/ldconfig
153
154 %files
155 %defattr(644,root,root,755)
156 %doc AUTHORS NEWS README
157 %attr(755,root,root) %{_libdir}/libsoup-2.4.so.*.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libsoup-2.4.so.1
159 %{_libdir}/girepository-1.0/Soup-2.4.typelib
160
161 %files devel
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/libsoup-2.4.so
164 %{_libdir}/libsoup-2.4.la
165 %{_includedir}/libsoup-2.4
166 %{_pkgconfigdir}/libsoup-2.4.pc
167 %{_datadir}/gir-1.0/Soup-2.4.gir
168
169 %files static
170 %defattr(644,root,root,755)
171 %{_libdir}/libsoup-2.4.a
172
173 %files gnome
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_libdir}/libsoup-gnome-2.4.so.*.*.*
176 %attr(755,root,root) %ghost %{_libdir}/libsoup-gnome-2.4.so.1
177 %{_libdir}/girepository-1.0/SoupGNOME-2.4.typelib
178
179 %files gnome-devel
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/libsoup-gnome-2.4.so
182 %{_libdir}/libsoup-gnome-2.4.la
183 %{_includedir}/libsoup-gnome-2.4
184 %{_pkgconfigdir}/libsoup-gnome-2.4.pc
185 %{_datadir}/gir-1.0/SoupGNOME-2.4.gir
186
187 %files gnome-static
188 %defattr(644,root,root,755)
189 %{_libdir}/libsoup-gnome-2.4.a
190
191 %files apidocs
192 %defattr(644,root,root,755)
193 %{_gtkdocdir}/libsoup-2.4
This page took 0.24578 seconds and 2 git commands to generate.