]> git.pld-linux.org Git - packages/libsoup.git/commitdiff
- updated to 2.68.0 auto/th/libsoup-2.68.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 11 Sep 2019 18:26:54 +0000 (20:26 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 11 Sep 2019 18:26:54 +0000 (20:26 +0200)
- added ugly path-override patch to allow specifying runtime path of ntlm_auth not existing at build time

libsoup-path-override.patch [new file with mode: 0644]
libsoup.spec

diff --git a/libsoup-path-override.patch b/libsoup-path-override.patch
new file mode 100644 (file)
index 0000000..a0a1923
--- /dev/null
@@ -0,0 +1,24 @@
+--- libsoup-2.68.0/meson.build.orig    2019-09-11 11:08:25.000000000 +0200
++++ libsoup-2.68.0/meson.build 2019-09-11 17:30:07.856616832 +0200
+@@ -311,11 +311,18 @@
+ ################
+ # NTLM not supported on Windows
+ if host_machine.system() != 'windows'
+-  ntlm_auth = find_program(get_option('ntlm_auth'), required: get_option('ntlm'))
++  ntlm_auth_path = get_option('ntlm_auth')
++  if ntlm_auth_path[0] == '/'
++    ntlm_auth_found = true
++  else
++    ntlm_auth = find_program(get_option('ntlm_auth'), required: get_option('ntlm'))
++    ntlm_auth_found = ntlm_auth.found()
++    ntlm_auth_path = ntlm_auth.path()
++  endif
+-  if ntlm_auth.found()
++  if ntlm_auth_found
+     add_project_arguments('-DUSE_NTLM_AUTH=1', language : 'c')
+-    add_project_arguments('-DNTLM_AUTH="' + ntlm_auth.path() + '"', language : 'c')
++    add_project_arguments('-DNTLM_AUTH="' + ntlm_auth_path + '"', language : 'c')
+   endif
+ endif
index 9168e8466f4244c425d8f101d4a5242c65d821f7..3086214d411442d50449c5e50be374531bf5d694 100644 (file)
@@ -1,12 +1,13 @@
 Summary:       SOAP (Simple Object Access Protocol) implementation in C
 Summary(pl.UTF-8):     Implementacja w C SOAP (Simple Object Access Protocol)
 Name:          libsoup
-Version:       2.66.2
+Version:       2.68.0
 Release:       1
 License:       LGPL v2+
 Group:         Libraries
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/libsoup/2.66/%{name}-%{version}.tar.xz
-# Source0-md5: 66c2ae89d6031b01337d78a2c57c75d5
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/libsoup/2.68/%{name}-%{version}.tar.xz
+# Source0-md5: be8181fc6c0e0f3a5f269eef7e40a351
+Patch0:                %{name}-path-override.patch
 URL:           https://wiki.gnome.org/Projects/libsoup
 BuildRequires: docbook-dtd412-xml
 BuildRequires: gettext-tools
@@ -14,9 +15,10 @@ BuildRequires:       glib2-devel >= 1:2.38.0
 BuildRequires: gobject-introspection-devel >= 0.10.0
 BuildRequires: gtk-doc >= 1.20
 BuildRequires: heimdal-devel
+BuildRequires: libbrotli-devel
 BuildRequires: libpsl-devel >= 0.20.0
 BuildRequires: libxml2-devel >= 1:2.6.31
-BuildRequires: meson >= 0.48
+BuildRequires: meson >= 0.50
 BuildRequires: ninja >= 1.5
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.736
@@ -24,6 +26,7 @@ BuildRequires:        sqlite3-devel
 BuildRequires: tar >= 1:1.22
 BuildRequires: vala
 BuildRequires: xz
+BuildRequires: zlib-devel
 Requires:      glib2 >= 1:2.38.0
 Requires:      libpsl >= 0.20.0
 # for TLS support
@@ -141,11 +144,13 @@ API libsoup dla jÄ™zyka Vala.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %meson build \
        -Ddoc=true \
-       -Dntlm=true \
+       -Dgtk_doc=true \
+       -Dntlm=enabled \
        -Dntlm_auth=/usr/bin/ntlm_auth \
        -Dtests=false \
        -Dtls_check=false
This page took 0.09388 seconds and 4 git commands to generate.