]> git.pld-linux.org Git - packages/libsoup.git/blob - libsoup.spec
- release 2
[packages/libsoup.git] / libsoup.spec
1 Summary:        SOAP (Simple Object Access Protocol) implementation in C
2 Summary(pl.UTF-8):      Implementacja w C SOAP (Simple Object Access Protocol)
3 Name:           libsoup
4 Version:        2.26.0
5 Release:        2
6 License:        LGPL v2+
7 Group:          Libraries
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libsoup/2.26/%{name}-%{version}.tar.bz2
9 # Source0-md5:  9df9d2b3304213641d3214a774d75ee1
10 URL:            http://www.gnome.org/
11 BuildRequires:  autoconf >= 2.53
12 BuildRequires:  automake
13 BuildRequires:  glib2-devel >= 1:2.20.0
14 BuildRequires:  gnutls-devel >= 1.2.5
15 BuildRequires:  gtk-doc >= 1.6
16 BuildRequires:  libproxy-devel
17 BuildRequires:  libtool
18 BuildRequires:  libxml2-devel >= 1:2.6.31
19 BuildRequires:  pkgconfig
20 BuildRequires:  sqlite3-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 It provides an queued asynchronous callback-based mechanism for
25 sending and servicing SOAP requests, and a WSDL (Web Service
26 Definition Language) to C compiler which generates client stubs and
27 server skeletons for easily calling and implementing SOAP methods.
28
29 %description -l pl.UTF-8
30 Pakiet dostarcza interfejs kolejkowalnego, asynchronicznego mechanizmu
31 do wysyłania i serwowania żądań SOAP oraz WSDL (Web Service Definition
32 Language) dla kompilatora C, który generuje klienckie stub i szkielety
33 serwerów dla łatwego wywoływania i implementowania metod SOAP.
34
35 %package devel
36 Summary:        Include files etc to develop SOAP applications
37 Summary(pl.UTF-8):      Pliki nagłówkowe, dokumentacja dla SOAP
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       glib2-devel >= 1:2.20.0
41 Requires:       gnutls-devel >= 1.2.5
42 Requires:       libxml2-devel >= 1:2.6.31
43
44 %description devel
45 Header files, etc you can use to develop SOAP applications.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe itp. Jednym słowem wszystko czego potrzebujesz aby
49 samemu tworzyć sobie aplikacje korzystające z SOAP.
50
51 %package static
52 Summary:        SOAP static libraries
53 Summary(pl.UTF-8):      Biblioteki statyczne SOAP
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 SOAP static libraries.
59
60 %description static -l pl.UTF-8
61 Biblioteki statyczne SOAP.
62
63 %package gnome
64 Summary:        GNOME specific extensions to libsoup library
65 Summary(pl.UTF-8):      Rozszerzenia GNOME do biblioteki libsoup
66 Group:          Libraries
67 Requires:       %{name} = %{version}-%{release}
68
69 %description gnome
70 GNOME specific extensions to libsoup library.
71
72 %description gnome -l pl.UTF-8
73 Rozszerzenia GNOME do biblioteki libsoup.
74
75 %package gnome-devel
76 Summary:        Header files for libsoup-gnome library
77 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsoup-gnome
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80 Requires:       %{name}-gnome = %{version}-%{release}
81
82 %description gnome-devel
83 Header files for libsoup-gnome library.
84
85 %description gnome-devel -l pl.UTF-8
86 Pliki nagłówkowe biblioteki libsoup-gnome.
87
88 %package gnome-static
89 Summary:        Static libsoup-gnome library
90 Summary(pl.UTF-8):      Statyczna biblioteka libsoup-gnome
91 Group:          Development/Libraries
92 Requires:       %{name}-gnome-devel = %{version}-%{release}
93
94 %description gnome-static
95 Static libsoup-gnome library.
96
97 %description gnome-static -l pl.UTF-8
98 Statyczna biblioteka libsoup-gnome.
99
100 %package apidocs
101 Summary:        libsoup API documentation
102 Summary(pl.UTF-8):      Dokumentacja API libsoup
103 Group:          Documentation
104 Requires:       gtk-doc-common
105
106 %description apidocs
107 libsoup API documentation.
108
109 %description apidocs -l pl.UTF-8
110 Dokumentacja API libsoup.
111
112 %prep
113 %setup -q
114
115 %build
116 %{__glib_gettextize}
117 %{__libtoolize}
118 %{__aclocal}
119 %{__autoconf}
120 %{__autoheader}
121 %{__automake}
122 %configure \
123         --enable-ssl \
124         --enable-gtk-doc \
125         --with-html-dir=%{_gtkdocdir}
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install \
132         pkgconfigdir=%{_pkgconfigdir} \
133         m4datadir=%{_aclocaldir} \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %post   gnome -p /sbin/ldconfig
143 %postun gnome -p /sbin/ldconfig
144
145 %files
146 %defattr(644,root,root,755)
147 %doc AUTHORS ChangeLog NEWS README
148 %attr(755,root,root) %{_libdir}/libsoup-2.4.so.*.*.*
149 %attr(755,root,root) %ghost %{_libdir}/libsoup-2.4.so.1
150
151 %files devel
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_libdir}/libsoup-2.4.so
154 %{_libdir}/libsoup-2.4.la
155 %{_includedir}/libsoup-2.4
156 %{_pkgconfigdir}/libsoup-2.4.pc
157
158 %files static
159 %defattr(644,root,root,755)
160 %{_libdir}/libsoup-2.4.a
161
162 %files gnome
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/libsoup-gnome-2.4.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libsoup-gnome-2.4.so.1
166
167 %files gnome-devel
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/libsoup-gnome-2.4.so
170 %{_libdir}/libsoup-gnome-2.4.la
171 %{_includedir}/libsoup-gnome-2.4
172 %{_pkgconfigdir}/libsoup-gnome-2.4.pc
173
174 %files gnome-static
175 %defattr(644,root,root,755)
176 %{_libdir}/libsoup-gnome-2.4.a
177
178 %files apidocs
179 %defattr(644,root,root,755)
180 %{_gtkdocdir}/libsoup-2.4
This page took 0.078745 seconds and 3 git commands to generate.