]> git.pld-linux.org Git - packages/libsndfile.git/blob - libsndfile.spec
- x32 rebuild
[packages/libsndfile.git] / libsndfile.spec
1 # TODO:
2 #       - who needs sndfile-regtest?
3 #
4 # Conditional build:
5 %bcond_with     regtest         # build sndfile-regtest program
6 %bcond_without  octave          # don't build octave binding
7 %bcond_without  static_libs     # don't build static library
8 %bcond_without  tests           # don't build tests
9 #
10 Summary:        C library for reading and writing files containing sampled sound
11 Summary(pl.UTF-8):      Biblioteka obsługi plików dźwiękowych
12 Name:           libsndfile
13 Version:        1.0.25
14 Release:        8
15 License:        LGPL v2.1+
16 Group:          Libraries
17 Source0:        http://www.mega-nerd.com/libsndfile/files/%{name}-%{version}.tar.gz
18 # Source0-md5:  e2b7bb637e01022c7d20f95f9c3990a2
19 Patch0:         octave32.patch
20 URL:            http://www.mega-nerd.com/libsndfile/
21 BuildRequires:  alsa-lib-devel
22 BuildRequires:  autoconf >= 2.57
23 BuildRequires:  automake
24 BuildRequires:  flac-devel >= 1.2.1
25 BuildRequires:  gcc-fortran
26 BuildRequires:  libogg-devel >= 2:1.1.3
27 %{?with_tests:BuildRequires:    libstdc++-devel}
28 BuildRequires:  libtool
29 BuildRequires:  libvorbis-devel >= 1:1.2.3
30 %{?with_octave:BuildRequires:   octave-devel}
31 BuildRequires:  pkgconfig
32 BuildRequires:  sed >= 4.0
33 %{?with_regtest:BuildRequires:  sqlite3-devel >= 3.2}
34 Requires:       flac >= 1.2.1
35 Requires:       libogg >= 2:1.1.3
36 Requires:       libvorbis >= 1:1.2.3
37 Obsoletes:      libsndfile1
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define no_install_post_check_so 1
41
42 %description
43 Libsndfile is a C library for reading and writing files containing
44 sampled sound (such as MS Windows WAV and the Apple/SGI AIFF format)
45 through one standard library interface.
46
47 %description -l pl.UTF-8
48 Libsndfile to biblioteką napisaną w C, służąca do czytania i
49 zapisywania plików zawierających zsamplowany dźwięk (np. w formacie MS
50 Windows WAV czy Apple/SGI AIFF) poprzez jednolity, standardowy
51 interfejs.
52
53 %package devel
54 Summary:        libsndfile header files and development documentation
55 Summary(pl.UTF-8):      Pliki nagłówkowe oraz dokumentacja do libsndfile
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       flac-devel >= 1.2.1
59 Requires:       libogg-devel >= 2:1.1.3
60 Requires:       libvorbis-devel >= 1:1.2.3
61 Obsoletes:      libsndfile1-devel
62
63 %description devel
64 Header files and development documentation for libsndfile.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe oraz dokumentacja do biblioteki libsndfile.
68
69 %package static
70 Summary:        libsndfile static libraries
71 Summary(pl.UTF-8):      Biblioteki statyczne libsndfile
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 libsndfile static libraries.
77
78 %description static -l pl.UTF-8
79 Biblioteki statyczne libsndfile.
80
81 %package progs
82 Summary:        libsndfile utility programs
83 Summary(pl.UTF-8):      Narzędzia korzystające z biblioteki libsndfile
84 Group:          Applications/Sound
85 Requires:       %{name} = %{version}-%{release}
86
87 %description progs
88 libsndfile utility programs:
89 - sndfile-convert - convert a sound files from one format to another
90 - sndfile-info - display information about a sound file
91 - sndfile-play - play a sound file
92
93 %description progs -l pl.UTF-8
94 Narzędzia z biblioteki libsndfile:
95 - sndfile-convert - kowertertuje pliki dźwiękowe
96 - sndfile-info - wyświetla informacje o pliku dźwiękowym
97 - sndfile-play - odtwarza pliki dźwiękowe
98
99 %package -n octave-sndfile
100 Summary:        sndfile module for Octave
101 Summary(pl.UTF-8):      Moduł sndfile dla Octave
102 Group:          Applications/Math
103 Requires:       %{name} = %{version}-%{release}
104 Requires:       octave
105 Obsoletes:      libsndfile-octave
106
107 %description -n octave-sndfile
108 A couple of script files for loading, saving, and playing sound files
109 from within Octave.
110
111 %description -n octave-sndfile -l pl.UTF-8
112 Kilka skryptów Octave do ładowania, zapisywania i odtwarzania plików
113 dźwiękowych.
114
115 %prep
116 %setup -q
117 %patch0 -p1
118
119 %if %{without tests}
120 %{__sed} -i 's, tests$,,' Makefile.am
121 %endif
122
123 %build
124 %{__libtoolize}
125 %{__aclocal} -I M4
126 %{__autoconf}
127 %{__automake}
128 %configure \
129         %{!?with_static_libs:--disable-static} \
130         %{!?with_regtest:--disable-sqlite}
131
132 %{__make} \
133         V=1
134 %{?with_tests: %{__make} test}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libsndfile1-dev
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %files
151 %defattr(644,root,root,755)
152 %doc AUTHORS ChangeLog NEWS README
153 %attr(755,root,root) %{_libdir}/libsndfile.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libsndfile.so.1
155
156 %files devel
157 %defattr(644,root,root,755)
158 %doc doc/*.html doc/*.jpg doc/new_file_type.HOWTO
159 %attr(755,root,root) %{_libdir}/libsndfile.so
160 %{_libdir}/libsndfile.la
161 %{_includedir}/sndfile.h*
162 %{_pkgconfigdir}/sndfile.pc
163
164 %if %{with static_libs}
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/libsndfile.a
168 %endif
169
170 %files progs
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_bindir}/sndfile-*
173 %{_mandir}/man1/sndfile-*.1*
174
175 %if %{with octave}
176 %files -n octave-sndfile
177 %defattr(644,root,root,755)
178 %{_datadir}/octave/site/m/sndfile_*.m
179 %dir %{_libdir}/octave/*/site/oct/*/sndfile
180 %{_libdir}/octave/*/site/oct/*/sndfile/PKG_ADD
181 %attr(755,root,root) %{_libdir}/octave/*/site/oct/*/sndfile/sndfile.oct
182 %endif
This page took 0.06686 seconds and 3 git commands to generate.