]> git.pld-linux.org Git - packages/libsndfile.git/blob - libsndfile.spec
- updated to 1.0.25 (fixes heap overflow in PAF file handler, Secunia SA45125)
[packages/libsndfile.git] / libsndfile.spec
1 # TODO:
2 #       - who needs sndfile-regtest?
3 #
4 # Conditional build:
5 %bcond_with     regtest         # build sndfile-regtest program
6 %bcond_without  octave          # don't build octave binding
7 %bcond_without  static_libs     # don't build static library
8 %bcond_without  tests           # don't build tests
9 #
10 Summary:        C library for reading and writing files containing sampled sound
11 Summary(pl.UTF-8):      Biblioteka obsługi plików dźwiękowych
12 Name:           libsndfile
13 Version:        1.0.25
14 Release:        1
15 License:        LGPL v2.1+
16 Group:          Libraries
17 Source0:        http://www.mega-nerd.com/libsndfile/files/%{name}-%{version}.tar.gz
18 # Source0-md5:  e2b7bb637e01022c7d20f95f9c3990a2
19 Patch0:         octave32.patch
20 URL:            http://www.mega-nerd.com/libsndfile/
21 BuildRequires:  alsa-lib-devel
22 BuildRequires:  autoconf >= 2.57
23 BuildRequires:  automake
24 BuildRequires:  flac-devel >= 1.2.1
25 BuildRequires:  gcc-fortran
26 BuildRequires:  libogg-devel >= 2:1.1.3
27 %{?with_tests:BuildRequires:    libstdc++-devel}
28 BuildRequires:  libtool
29 BuildRequires:  libvorbis-devel >= 1:1.2.3
30 %{?with_octave:BuildRequires:   octave-devel}
31 BuildRequires:  pkgconfig
32 BuildRequires:  sed >= 4.0
33 %{?with_regtest:BuildRequires:  sqlite3-devel >= 3.2}
34 Requires:       flac >= 1.2.1
35 Requires:       libogg >= 2:1.1.3
36 Requires:       libvorbis >= 1:1.2.3
37 Obsoletes:      libsndfile1
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Libsndfile is a C library for reading and writing files containing
42 sampled sound (such as MS Windows WAV and the Apple/SGI AIFF format)
43 through one standard library interface.
44
45 %description -l pl.UTF-8
46 Libsndfile to biblioteką napisaną w C, służąca do czytania i
47 zapisywania plików zawierających zsamplowany dźwięk (np. w formacie MS
48 Windows WAV czy Apple/SGI AIFF) poprzez jednolity, standardowy
49 interfejs.
50
51 %package devel
52 Summary:        libsndfile header files and development documentation
53 Summary(pl.UTF-8):      Pliki nagłówkowe oraz dokumentacja do libsndfile
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       flac-devel >= 1.2.1
57 Requires:       libogg-devel >= 2:1.1.3
58 Requires:       libvorbis-devel >= 1:1.2.3
59 Obsoletes:      libsndfile1-devel
60
61 %description devel
62 Header files and development documentation for libsndfile.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe oraz dokumentacja do biblioteki libsndfile.
66
67 %package static
68 Summary:        libsndfile static libraries
69 Summary(pl.UTF-8):      Biblioteki statyczne libsndfile
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 libsndfile static libraries.
75
76 %description static -l pl.UTF-8
77 Biblioteki statyczne libsndfile.
78
79 %package progs
80 Summary:        libsndfile utility programs
81 Summary(pl.UTF-8):      Narzędzia korzystające z biblioteki libsndfile
82 Group:          Applications/Sound
83 Requires:       %{name} = %{version}-%{release}
84
85 %description progs
86 libsndfile utility programs:
87 - sndfile-convert - convert a sound files from one format to another
88 - sndfile-info - display information about a sound file
89 - sndfile-play - play a sound file
90
91 %description progs -l pl.UTF-8
92 Narzędzia z biblioteki libsndfile:
93 - sndfile-convert - kowertertuje pliki dźwiękowe
94 - sndfile-info - wyświetla informacje o pliku dźwiękowym
95 - sndfile-play - odtwarza pliki dźwiękowe
96
97 %package -n octave-sndfile
98 Summary:        sndfile module for Octave
99 Summary(pl.UTF-8):      Moduł sndfile dla Octave
100 Group:          Applications/Math
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       octave
103 Obsoletes:      libsndfile-octave
104
105 %description -n octave-sndfile
106 A couple of script files for loading, saving, and playing sound files
107 from within Octave.
108
109 %description -n octave-sndfile -l pl.UTF-8
110 Kilka skryptów Octave do ładowania, zapisywania i odtwarzania plików
111 dźwiękowych.
112
113 %prep
114 %setup -q
115 %patch0 -p1
116
117 %if %{without tests}
118 %{__sed} -i 's, tests$,,' Makefile.am
119 %endif
120
121 %build
122 %{__libtoolize}
123 %{__aclocal} -I M4
124 %{__autoconf}
125 %{__automake}
126 %configure \
127         %{!?with_static_libs:--disable-static} \
128         %{!?with_regtest:--disable-sqlite}
129
130 %{__make} \
131         V=1
132 %{?with_tests: %{__make} test}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libsndfile1-dev
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files
149 %defattr(644,root,root,755)
150 %doc AUTHORS ChangeLog NEWS README
151 %attr(755,root,root) %{_libdir}/libsndfile.so.*.*.*
152 %attr(755,root,root) %ghost %{_libdir}/libsndfile.so.1
153
154 %files devel
155 %defattr(644,root,root,755)
156 %doc doc/*.html doc/*.jpg doc/new_file_type.HOWTO
157 %attr(755,root,root) %{_libdir}/libsndfile.so
158 %{_libdir}/libsndfile.la
159 %{_includedir}/sndfile.h*
160 %{_pkgconfigdir}/sndfile.pc
161
162 %if %{with static_libs}
163 %files static
164 %defattr(644,root,root,755)
165 %{_libdir}/libsndfile.a
166 %endif
167
168 %files progs
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_bindir}/sndfile-*
171 %{_mandir}/man1/sndfile-*.1*
172
173 %if %{with octave}
174 %files -n octave-sndfile
175 %defattr(644,root,root,755)
176 %{_datadir}/octave/site/m/sndfile_*.m
177 %dir %{_libdir}/octave/*/site/oct/*/sndfile
178 %{_libdir}/octave/*/site/oct/*/sndfile/PKG_ADD
179 %attr(755,root,root) %{_libdir}/octave/*/site/oct/*/sndfile/sndfile.oct
180 %endif
This page took 0.087197 seconds and 3 git commands to generate.