]> git.pld-linux.org Git - packages/libsmi.git/blob - libsmi.spec
- added using %%{__make} macro.
[packages/libsmi.git] / libsmi.spec
1 Summary:        Structure of Management Information library
2 Name:           libsmi
3 Version:        0.2.1
4 Release:        1
5 Copyright:      distributable (see COPYING file)
6 Group:          Libraries
7 Group(fr):      Librairies
8 Group(pl):      Biblioteki
9 Source0:        ftp://ftp.ibr.cs.tu-bs.de/pub/local/libsmi/%{name}-%{version}.tar.gz
10 URL:            http://www.ibr.cs.tu-bs.de/projects/libsmi/
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %define         _prefix         /usr
14
15 %description
16 Libsmi is a C library that allows network management applications to
17 access MIB module information through a well defined API that hides
18 the nasty details of locating and parsing SMIv1/v2 MIB modules.
19
20 Libsmi supports exact and iterative retrieval functions for all major
21 SMIv1 and SMIv2 constructs (except the AGENT-CAPABILITIES statement).
22
23 The layered concept of libsmi allows to add further methods to
24 retrieve MIB information from persistent repositories. In fact,
25 besides the SMIv1/v2 MIB file parser an additional parser for `SMIng'
26 is included. Both parsers are built on flex/bison grammar
27 specifications.
28
29 SMIng is a research project concerned with the definition of a MIB
30 module language that is semantically fully compatible with SMIv2 but
31 avoids many problems of the ASN.1 based SMI versions.
32
33 Included with the library, there are three tools that make use of
34 libsmi: Smiquery allows simple queries of single MIB module items.
35 Smilint allows to increase the verbosity of the parser(s), so that MIB
36 modules can be checked for syntax and semantic errors. Finally,
37 smidump can be used to dump MIB modules. Currently, SMIng and SMIv2
38 are supported as output formats, so that SMIv2 <-> SMIng conversions
39 are possible.
40
41 %package devel
42 Summary:        Header files and development documentation for libsmi
43 Summary(pl):    Pliki nag³ówkowe i dokumentacja do libsmi
44 Group:          Development/Libraries
45 Group(fr):      Development/Librairies
46 Group(pl):      Programowanie/Biblioteki
47 Requires:       %{name} = %{version}
48
49 %description devel
50 Header files and development documentation for libsmi.
51
52 %description -l pl devel
53 Pliki nag³ówkowe i dokumentacja do libsmi.
54
55 %package static
56 Summary:        Static libsmi libraries
57 Summary(pl):    Biblioteki statyczne libsmi
58 Group:          Development/Libraries
59 Group(fr):      Development/Librairies
60 Group(pl):      Programowanie/Biblioteki
61 Requires:       %{name}-devel = %{version}
62
63 %description static
64 Static libsmi libraries.
65
66 %description -l pl static
67 Biblioteki statyczne libsmi.
68
69 %prep
70 %setup -q
71
72 %build
73 LDFLAGS="-s"; export LDFLAGS
74 %configure \
75         --enable-smi \
76         --enable-sming \
77         --enable-shared \
78         --enable-static \
79         --with-mibdir=%{_datadir}/mibs
80
81 make
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install DESTDIR=$RPM_BUILD_ROOT
87
88 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
89
90 gzip -9nf $RPM_BUILD_ROOT/%{_mandir}/man?/* \
91         ChangeLog README THANKS TODO \
92         doc/draft-irtf-nmrg-sming-*.txt
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_bindir}/*
103 %attr(755,root,root) %{_libdir}/lib*.so.*.*
104 %{_datadir}/mibs
105 %{_mandir}/man1/*
106
107 %files devel
108 %defattr(644,root,root,755)
109 %doc *.gz doc/draft-irtf-nmrg-sming-*.txt.gz
110 %attr(755,root,root) %{_libdir}/lib*.so
111 %attr(755,root,root) %{_libdir}/lib*.la
112 %{_includedir}/*
113 %{_mandir}/man3/*
114
115 %files static
116 %defattr(644,root,root,755)
117 %{_libdir}/lib*.a
This page took 0.073774 seconds and 3 git commands to generate.