]> git.pld-linux.org Git - packages/libsigc++.git/blob - libsigc++.spec
- updated URL, updated to 2.10.1
[packages/libsigc++.git] / libsigc++.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  tests           # check target
5 #
6 Summary:        The Typesafe Signal Framework for C++
7 Summary(pl.UTF-8):      Środowisko sygnałów z kontrolą typów dla C++
8 Name:           libsigc++
9 Version:        2.10.1
10 Release:        1
11 Epoch:          1
12 License:        LGPL v2.1+
13 Group:          Libraries
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.10/%{name}-%{version}.tar.xz
15 # Source0-md5:  549cffbdb72fa105b782756f2713ffc7
16 URL:            https://libsigcplusplus.github.io/libsigcplusplus/
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake >= 1:1.9
19 BuildRequires:  libstdc++-devel >= 6:4.7
20 BuildRequires:  libtool >= 2:2.0
21 BuildRequires:  m4
22 BuildRequires:  mm-common >= 0.9.10
23 BuildRequires:  perl-base
24 BuildRequires:  pkgconfig
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 Obsoletes:      libsigc++-examples
28 Conflicts:      libsigc++ < 1.1.0
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This library implements a full callback system for use in widget
33 libraries, abstract interfaces, and general programming. Originally
34 part of the Gtk-- widget set, libsigc++ is now a seperate library to
35 provide for more general use. It is the most complete library of its
36 kind with the ablity to connect an abstract callback to a class
37 method, function, or function object. It contains adaptor classes for
38 connection of dissimilar callbacks and has an ease of use unmatched by
39 other C++ callback libraries.
40
41 %description -l pl.UTF-8
42 Ta biblioteka jest implementacją pełnego systemu callbacków do
43 używania w bibliotekach widgetów, interfejsach abstrakcyjnych i
44 ogólnym programowaniu. Oryginalnie była to część zestawu widgetów
45 Gtk--, ale jest teraz oddzielną biblioteką ogólniejszego
46 przeznaczenia. Jest to kompletna biblioteka tego typu z możliwością
47 łączenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
48 obiektami funkcji. Zawiera klasy adapterów do łączenia różnych
49 callbacków.
50
51 %package devel
52 Summary:        Development tools for the Typesafe Signal Framework for C++
53 Summary(pl.UTF-8):      Narzędzia programistyczne do środowiska libsig++
54 Group:          Development/Libraries
55 Requires:       %{name} = %{epoch}:%{version}-%{release}
56 Requires:       libstdc++-devel >= 6:4.7
57 Requires:       m4
58
59 %description devel
60 Development tools for the Typesafe Signal Framework for C++.
61
62 %description devel -l pl.UTF-8
63 Narzędzia programistyczne do środowiska libsigc++ - sygnałów z
64 kontrolą typów.
65
66 %package static
67 Summary:        Static Typesafe Signal Framework for C++ libraries
68 Summary(pl.UTF-8):      Statyczna biblioteka libsigc++
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
71
72 %description static
73 Static Typesafe Signal Framework for C++ libraries.
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka libsigc++ - środowiska sygnałów z kontrolą typów.
77
78 %package doc
79 Summary:        Reference documentation for libsigc++
80 Summary(pl.UTF-8):      Szczegółowa dokumentacja dla libsigc++
81 Group:          Documentation
82
83 %description doc
84 Reference documentation for libsigc++.
85
86 %description doc -l pl.UTF-8
87 Szczegółowa dokumentacja dla libsigc++.
88
89 %prep
90 %setup -q
91
92 %build
93 %{__libtoolize}
94 %{__aclocal} -I build
95 %{__autoconf}
96 %{__automake}
97 %configure \
98         --disable-silent-rules \
99         %{?with_static_libs:--enable-static}
100 %{__make}
101
102 %if %{with tests}
103 %{__make} check
104 %endif
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc AUTHORS ChangeLog NEWS README
121 %attr(755,root,root) %{_libdir}/libsigc-2.0.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libsigc-2.0.so.0
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/libsigc-2.0.so
127 %{_libdir}/libsigc-2.0.la
128 %{_includedir}/sigc++-2.0
129 %{_libdir}/sigc++-2.0
130 %{_pkgconfigdir}/sigc++-2.0.pc
131
132 %if %{with static_libs}
133 %files static
134 %defattr(644,root,root,755)
135 %{_libdir}/libsigc-2.0.a
136 %endif
137
138 %files doc
139 %defattr(644,root,root,755)
140 %{_datadir}/devhelp/books/libsigc++-2.0
141 %{_docdir}/libsigc++-2.0
This page took 0.159546 seconds and 3 git commands to generate.