]> git.pld-linux.org Git - packages/librsvg.git/blob - librsvg.spec
- updated to 2.40.19
[packages/librsvg.git] / librsvg.spec
1 #
2 # Conditional build
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  gtk2            # legacy gtk+2 support
5 %bcond_without  static_libs     # don't build static library
6 %bcond_with     vala            # Vala API (vala up to 0.30 already contains librsvg-2.0.vapi)
7
8 %define         mver    2.40
9 %define         pver    19
10 Summary:        A Raph's Library for Rendering SVG Data
11 Summary(pl.UTF-8):      Biblioteka Raph's SVG do renderowania danych SVG
12 Summary(pt_BR.UTF-8):   Biblioteca SVG
13 Summary(ru.UTF-8):      SVG библиотека
14 Summary(uk.UTF-8):      SVG бібліотека
15 Name:           librsvg
16 Version:        %{mver}.%{pver}
17 Release:        1
18 Epoch:          1
19 License:        LGPL v2+
20 Group:          X11/Libraries
21 Source0:        http://ftp.gnome.org/pub/GNOME/sources/librsvg/%{mver}/%{name}-%{version}.tar.xz
22 # Source0-md5:  934eff469b34c732fb91ddb9afd40638
23 Source1:        rsvg
24 Patch0:         x32.patch
25 URL:            http://librsvg.sourceforge.net/
26 BuildRequires:  autoconf >= 2.50
27 BuildRequires:  automake >= 1:1.9
28 BuildRequires:  cairo-devel >= 1.2.0
29 BuildRequires:  docbook-dtd412-xml
30 BuildRequires:  gdk-pixbuf2-devel >= 2.20
31 BuildRequires:  glib2-devel >= 1:2.24.0
32 BuildRequires:  gobject-introspection-devel >= 0.10.8
33 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.16.0}
34 BuildRequires:  gtk+3-devel >= 3.10.0
35 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.13}
36 %{?with_apidocs:BuildRequires:  gtk-doc-automake >= 1.13}
37 BuildRequires:  libcroco-devel >= 0.6.1
38 BuildRequires:  libtool >= 2:2.0
39 BuildRequires:  libxml2-devel >= 1:2.9.0
40 BuildRequires:  pango-devel >= 1:1.38.0
41 BuildRequires:  pkgconfig
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  tar >= 1:1.22
45 %{?with_vala:BuildRequires:     vala >= 2:0.18}
46 BuildRequires:  xz
47 Requires(post,postun):  /sbin/ldconfig
48 Requires:       cairo >= 1.2.0
49 Requires:       gdk-pixbuf2 >= 2.20
50 Requires:       glib2 >= 1:2.24.0
51 Requires:       libcroco >= 0.6.1
52 Requires:       libxml2 >= 1:2.9.0
53 Requires:       pango >= 1:1.38.0
54 Obsoletes:      browser-plugin-librsvg
55 Obsoletes:      librsvg-gtk+2
56 Obsoletes:      librsvg0
57 Obsoletes:      mozilla-plugin-rsvg
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 # see gdk-pixbuf2.spec for source of these ifdefs
61 %if "%{_lib}" != "lib"
62 %define         libext          %(lib="%{_lib}"; echo ${lib#lib})
63 %define         pqext           -%{libext}
64 %else
65 %define         pqext           %{nil}
66 %endif
67
68 %description
69 An library to render SVG (scalable vector graphics), databased upon
70 libart.
71
72 %description -l pl.UTF-8
73 Biblioteka do renderowania SVG (skalowalnej grafiki wektorowej) oparta
74 na kodzie libart.
75
76 %description -l ru.UTF-8
77 Библиотека SVG, базирующаяся на libart.
78
79 %description -l uk.UTF-8
80 Бібліотека SVG, базована на libart.
81
82 %package devel
83 Summary:        Include files for developing with librsvg
84 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia oprogramowania z użyciem librsvg
85 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento com a librsvg
86 Summary(ru.UTF-8):      Библиотечные линки и файлы заголовков для разработки с librsvg
87 Summary(uk.UTF-8):      Бібліотечні лінки та файли заголовків для розробки з librsvg
88 Group:          X11/Development/Libraries
89 Requires:       %{name} = %{epoch}:%{version}-%{release}
90 Requires:       cairo-devel >= 1.2.0
91 Requires:       gdk-pixbuf2-devel >= 2.20
92 Requires:       glib2-devel >= 1:2.24.0
93 Requires:       gtk+3-devel >= 3.10.0
94 Requires:       libcroco-devel >= 0.6.1
95 Requires:       libxml2-devel >= 1:2.9.0
96 Requires:       pango-devel >= 1:1.38.0
97 Obsoletes:      librsvg0-devel
98
99 %description devel
100 This package provides the necessary development libraries and include
101 files to allow you to develop with librsvg.
102
103 %description devel -l pl.UTF-8
104 Pakiet zawiera pliki nagłówkowe potrzebne do tworzenia oprogramowania
105 z wykorzystaniem librsvg.
106
107 %description devel -l pt_BR.UTF-8
108 Este pacote contém os arquivos necessários para desenvolver com base
109 na biblioteca librsvg.
110
111 %description devel -l ru.UTF-8
112 Этот пакет содержит необходимые файлы для разработки программ с
113 использованием librsvg.
114
115 %description devel -l uk.UTF-8
116 Цей пакет містить необхідні файли для розробки програм з використанням
117 librsvg.
118
119 %package static
120 Summary:        Static libraries for developing with librsvg
121 Summary(es.UTF-8):      Archivos estáticos necesarios para el desarrollo de aplicaciones con librsvg
122 Summary(pl.UTF-8):      Statyczne biblioteki librsvg
123 Summary(pt_BR.UTF-8):   Arquivos estáticos necessários para o desenvolvimento de aplicações com librsvg
124 Group:          X11/Development/Libraries
125 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
126
127 %description static
128 This package contains static version of librsvg libraries.
129
130 %description static -l pl.UTF-8
131 Statyczna wersja bibliotek librsvg.
132
133 %description static -l pt_BR.UTF-8
134 Bibliotecas estáticas para o desenvolvimento de aplicações com
135 librsvg.
136
137 %package apidocs
138 Summary:        librsvg API documentation
139 Summary(pl.UTF-8):      Dokumentacja API biblioteki librsvg
140 Group:          Documentation
141 Requires:       gtk-doc-common
142 %if "%{_rpmversion}" >= "5"
143 BuildArch:      noarch
144 %endif
145
146 %description apidocs
147 librsvg API documentation.
148
149 %description apidocs -l pl.UTF-8
150 Dokumentacja API biblioteki librsvg.
151
152 %package -n vala-librsvg
153 Summary:        Vala API for librsvg library
154 Summary(pl.UTF-8):      API języka Vala do biblioteki librsvg
155 Group:          Development/Libraries
156 Requires:       vala >= 2:0.18
157
158 %description -n vala-librsvg
159 Vala API for librsvg library.
160
161 %description -n vala-librsvg -l pl.UTF-8
162 API języka Vala do biblioteki librsvg.
163
164 %package gtk+3
165 Summary:        librsvg/GTK+3 based SVG viewer
166 Summary(pl.UTF-8):      Przeglądarka plików SVG oparta na bibliotekach librsvg/GTK+3
167 Group:          X11/Applications/Graphics
168 Requires:       %{name} = %{epoch}:%{version}-%{release}
169 Requires:       gtk+3 >= 3.10.0
170
171 %description gtk+3
172 librsvg/GTK+3 based SVG viewer.
173
174 %description gtk+3 -l pl.UTF-8
175 Przeglądarka plików SVG oparta na bibliotekach librsvg/GTK+3.
176
177 %prep
178 %setup -q
179 %patch0 -p1
180
181 %if %{without apidocs}
182 echo 'CLEANFILES=' > gtk-doc.make
183 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
184 %endif
185
186 %build
187 %{?with_apidocs:%{__gtkdocize}}
188 %{__libtoolize}
189 %{__aclocal}
190 %{__autoconf}
191 %{__autoheader}
192 %{__automake}
193 %configure \
194         %{__enable_disable apidocs gtk-doc} \
195         --enable-introspection \
196         --disable-silent-rules \
197         %{__enable_disable static_libs static} \
198         %{?with_vala:--enable-vala} \
199         --with-html-dir=%{_gtkdocdir}/%{name}
200 %{__make}
201
202 %install
203 rm -rf $RPM_BUILD_ROOT
204
205 %{__make} install \
206         DESTDIR=$RPM_BUILD_ROOT \
207         pkgconfigdir=%{_pkgconfigdir}
208
209 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.*.*/loaders/*.{la,a}
210 %{__rm} $RPM_BUILD_ROOT%{_libdir}/librsvg-2.la
211
212 %{__ln_s} rsvg-view-3 $RPM_BUILD_ROOT%{_bindir}/rsvg-view
213
214 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
215
216 %clean
217 rm -rf $RPM_BUILD_ROOT
218
219 %post
220 /sbin/ldconfig
221 umask 022
222 %{_bindir}/gdk-pixbuf-query-loaders%{pqext} --update-cache || :
223
224 %postun
225 /sbin/ldconfig
226 umask 022
227 if [ -x %{_bindir}/gdk-pixbuf-query-loaders%{pqext} ]; then
228         %{_bindir}/gdk-pixbuf-query-loaders%{pqext} --update-cache
229 fi
230
231 %files
232 %defattr(644,root,root,755)
233 %doc ChangeLog AUTHORS NEWS
234 %attr(755,root,root) %{_bindir}/rsvg
235 %attr(755,root,root) %{_bindir}/rsvg-convert
236 %attr(755,root,root) %{_libdir}/librsvg-2.so.*.*.*
237 %attr(755,root,root) %ghost %{_libdir}/librsvg-2.so.2
238 %{_libdir}/girepository-1.0/Rsvg-2.0.typelib
239 %attr(755,root,root) %{_libdir}/gdk-pixbuf-2.0/2.*.*/loaders/libpixbufloader-svg.so
240 %{_datadir}/thumbnailers/librsvg.thumbnailer
241 %{_mandir}/man1/rsvg-convert.1*
242
243 %files devel
244 %defattr(644,root,root,755)
245 %attr(755,root,root) %{_libdir}/librsvg-2.so
246 %{_includedir}/librsvg-2.0
247 %{_datadir}/gir-1.0/Rsvg-2.0.gir
248 %{_pkgconfigdir}/librsvg-2.0.pc
249
250 %if %{with static_libs}
251 %files static
252 %defattr(644,root,root,755)
253 %{_libdir}/librsvg-2.a
254 %endif
255
256 %if %{with apidocs}
257 %files apidocs
258 %defattr(644,root,root,755)
259 %{_gtkdocdir}/%{name}
260 %endif
261
262 %if %{with vala}
263 %files -n vala-librsvg
264 %defattr(644,root,root,755)
265 %{_datadir}/vala/vapi/librsvg-2.0.vapi
266 %endif
267
268 %files gtk+3
269 %defattr(644,root,root,755)
270 %attr(755,root,root) %{_bindir}/rsvg-view
271 %attr(755,root,root) %{_bindir}/rsvg-view-3
This page took 0.643003 seconds and 3 git commands to generate.