]> git.pld-linux.org Git - packages/librepo.git/commitdiff
- updated to 1.8.1 auto/th/librepo-1.8.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 19 Nov 2017 07:48:30 +0000 (08:48 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 19 Nov 2017 07:48:30 +0000 (08:48 +0100)
- removed obsolete python-install-dir patch
- added attr patch (use xattr.h from glibc)

librepo-attr.patch [new file with mode: 0644]
librepo.spec
python-install-dir.patch [deleted file]

diff --git a/librepo-attr.patch b/librepo-attr.patch
new file mode 100644 (file)
index 0000000..2c16753
--- /dev/null
@@ -0,0 +1,45 @@
+--- librepo-1.8.1/librepo/checksum.c.orig      2017-09-01 17:45:17.000000000 +0200
++++ librepo-1.8.1/librepo/checksum.c   2017-11-19 08:09:39.084533788 +0100
+@@ -26,7 +26,8 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
+-#include <attr/xattr.h>
++#include <errno.h>
++#include <sys/xattr.h>
+ #include <openssl/evp.h>
+ #include "cleanup.h"
+--- librepo-1.8.1/librepo/downloader.c.orig    2017-09-01 17:45:17.000000000 +0200
++++ librepo-1.8.1/librepo/downloader.c 2017-11-19 08:11:38.764532423 +0100
+@@ -30,7 +30,7 @@
+ #include <sys/stat.h>
+ #include <fcntl.h>
+ #include <curl/curl.h>
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
+ #include "downloader.h"
+ #include "downloader_internal.h"
+--- librepo-1.8.1/tests/test_checksum.c.orig   2017-09-01 17:45:17.000000000 +0200
++++ librepo-1.8.1/tests/test_checksum.c        2017-11-19 08:12:19.011198628 +0100
+@@ -6,7 +6,8 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+-#include <attr/xattr.h>
++#include <errno.h>
++#include <sys/xattr.h>
+ #include "librepo/util.h"
+ #include "librepo/checksum.h"
+--- librepo-1.8.1/CMakeLists.txt.orig  2017-09-01 17:45:17.000000000 +0200
++++ librepo-1.8.1/CMakeLists.txt       2017-11-19 08:12:38.604531738 +0100
+@@ -32,7 +32,6 @@
+ FIND_PACKAGE(EXPAT REQUIRED)
+ FIND_PACKAGE(CURL REQUIRED)
+ FIND_PACKAGE(Gpgme REQUIRED)
+-FIND_PACKAGE(Xattr REQUIRED)
+ INCLUDE_DIRECTORIES(${GLIB2_INCLUDE_DIRS})
index 0cdc0d47655bb139f0c91427aabf43ba8186592b..2b9ef91b6c19cd4060f1433904f2323beae2c35c 100644 (file)
@@ -7,21 +7,19 @@
 Summary:       Library for downloading Linux repository metadata and packages
 Summary(pl.UTF-8):     Biblioteka do pobierania metadanych repozytoriów roaz pakietów dla Linuksa
 Name:          librepo
-Version:       1.7.18
-Release:       2
+Version:       1.8.1
+Release:       1
 License:       GPL v2+
 Group:         Libraries
 #Source0Download: https://github.com/rpm-software-management/librepo/releases
-Source0:       https://github.com/rpm-software-management/librepo/archive/%{name}-%{version}.tar.gz
-# Source0-md5: 4b28cfad651110b4b033825dc8f8b7cf
-#Source0:      http://pkgs.fedoraproject.org/repo/pkgs/librepo/%{name}-%{gitrev}.tar.xz/904628ef27b512e7aed07a6d41613c87/librepo-%{gitrev}.tar.xz
+Source0:       https://github.com/rpm-software-management/librepo/archive/%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 01fe130eb421580d62e97e4991e94df7
 Patch0:                %{name}-link.patch
-Patch1:                python-install-dir.patch
+Patch1:                %{name}-attr.patch
 Patch2:                sphinx_executable.patch
 URL:           http://rpm-software-management.github.io/librepo/
-BuildRequires: attr-devel
 BuildRequires: check-devel
-BuildRequires: cmake >= 2.6
+BuildRequires: cmake >= 2.8.5
 BuildRequires: curl-devel
 %{?with_apidocs:BuildRequires: doxygen}
 BuildRequires: expat-devel >= 1.95
@@ -105,7 +103,7 @@ Python 3 binding for librepo library.
 Wiązanie Pythona 3 do biblioteki librepo.
 
 %prep
-%setup -q -n %{name}-%{name}-%{version}
+%setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
diff --git a/python-install-dir.patch b/python-install-dir.patch
deleted file mode 100644 (file)
index 24861ca..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -dur -x '*~' librepo-librepo-1.7.13.orig/librepo/python/python2/CMakeLists.txt librepo-librepo-1.7.13/librepo/python/python2/CMakeLists.txt
---- librepo-librepo-1.7.13.orig/librepo/python/python2/CMakeLists.txt  2015-01-23 15:43:51.000000000 +0100
-+++ librepo-librepo-1.7.13/librepo/python/python2/CMakeLists.txt       2015-11-30 18:37:49.354123049 +0100
-@@ -1,6 +1,5 @@
- FIND_PACKAGE (PythonLibs 2 )
- FIND_PACKAGE (PythonInterp 2 REQUIRED)
--EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} -c "from sys import stdout; from distutils import sysconfig; stdout.write(sysconfig.get_python_lib(True))" OUTPUT_VARIABLE PYTHON_INSTALL_DIR)
- INCLUDE_DIRECTORIES (${PYTHON_INCLUDE_PATH})
- MESSAGE(STATUS "Python install dir is ${PYTHON_INSTALL_DIR}")
-diff -dur -x '*~' librepo-librepo-1.7.13.orig/librepo/python/python3/CMakeLists.txt librepo-librepo-1.7.13/librepo/python/python3/CMakeLists.txt
---- librepo-librepo-1.7.13.orig/librepo/python/python3/CMakeLists.txt  2015-01-23 15:43:51.000000000 +0100
-+++ librepo-librepo-1.7.13/librepo/python/python3/CMakeLists.txt       2015-11-30 18:37:38.354048339 +0100
-@@ -10,7 +10,6 @@
- FIND_PACKAGE(PythonLibs 3.0)
- FIND_PACKAGE(PythonInterp 3.0 REQUIRED)
--EXECUTE_PROCESS(COMMAND ${PYTHON_EXECUTABLE} -c "from sys import stdout; from distutils import sysconfig; stdout.write(sysconfig.get_python_lib(True))" OUTPUT_VARIABLE PYTHON_INSTALL_DIR)
- INCLUDE_DIRECTORIES (${PYTHON_INCLUDE_PATH})
- MESSAGE(STATUS "Python3 install dir is ${PYTHON_INSTALL_DIR}")
This page took 0.197561 seconds and 4 git commands to generate.