]> git.pld-linux.org Git - packages/libreoffice.git/commitdiff
test whether hardlinks can be used and fallback to cp
authorJan Palus <atler@pld-linux.org>
Thu, 16 Feb 2023 08:09:22 +0000 (09:09 +0100)
committerJan Palus <atler@pld-linux.org>
Thu, 16 Feb 2023 08:09:22 +0000 (09:09 +0100)
libreoffice.spec

index 70eedaa8fc4d2b9fc633719b4b1d11472169cc89..cf02a7c39d07f4c3640c211a2e97cb138284883d 100644 (file)
@@ -2899,24 +2899,28 @@ for dir in *-%{version}; do
 done
 
 install -d ext_sources
-ln %{SOURCE20} ext_sources
-ln %{SOURCE21} ext_sources
-ln %{SOURCE22} ext_sources
-ln %{SOURCE23} ext_sources
-ln %{SOURCE24} ext_sources
-ln %{SOURCE25} ext_sources
-ln %{SOURCE26} ext_sources
-ln %{SOURCE27} ext_sources
-ln %{SOURCE28} ext_sources
-ln %{SOURCE30} ext_sources
-ln %{SOURCE31} ext_sources
-ln %{SOURCE32} ext_sources
+if cp -pl %{SOURCE20} ext_sources; then
+       l=l
+else
+       cp -p %{SOURCE20} ext_sources
+fi
+cp -p$l %{SOURCE21} ext_sources
+cp -p$l %{SOURCE22} ext_sources
+cp -p$l %{SOURCE23} ext_sources
+cp -p$l %{SOURCE24} ext_sources
+cp -p$l %{SOURCE25} ext_sources
+cp -p$l %{SOURCE26} ext_sources
+cp -p$l %{SOURCE27} ext_sources
+cp -p$l %{SOURCE28} ext_sources
+cp -p$l %{SOURCE30} ext_sources
+cp -p$l %{SOURCE31} ext_sources
+cp -p$l %{SOURCE32} ext_sources
 %if %{without system_cmis}
-ln %{SOURCE33} ext_sources
+cp -p$l %{SOURCE33} ext_sources
 %endif
 :> src.downloaded
 
-ln %{SOURCE34} external/skia
+cp -p$l %{SOURCE34} external/skia
 
 %build
 # Make sure we have /proc mounted - otherwise idlc will fail later.
This page took 0.251835 seconds and 4 git commands to generate.