]> git.pld-linux.org Git - packages/libreoffice.git/commitdiff
upstream fix for gcc11
authorJan Palus <atler@pld-linux.org>
Fri, 25 Jun 2021 14:56:09 +0000 (14:56 +0000)
committerJan Palus <atler@pld-linux.org>
Fri, 25 Jun 2021 14:56:09 +0000 (14:56 +0000)
gcc11.patch [new file with mode: 0644]
libreoffice.spec

diff --git a/gcc11.patch b/gcc11.patch
new file mode 100644 (file)
index 0000000..b7d5eb8
--- /dev/null
@@ -0,0 +1,28 @@
+From 8830cf86b146b1252ac37f351a23246088d569b0 Mon Sep 17 00:00:00 2001
+From: Jeff Law <law@redhat.com>
+Date: Tue, 3 Nov 2020 08:05:03 -0700
+Subject: [PATCH] include cstddef for gcc11
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Change-Id: I2f845ce9bb660ad6c1eea80ea81dd71add2c0db1
+Reviewed-on: https://gerrit.libreoffice.org/c/core/+/107191
+Tested-by: Jenkins
+Reviewed-by: Caolán McNamara <caolanm@redhat.com>
+---
+ include/o3tl/lru_map.hxx | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/o3tl/lru_map.hxx b/include/o3tl/lru_map.hxx
+index c7132fd079c43..96fb3161782d7 100644
+--- a/include/o3tl/lru_map.hxx
++++ b/include/o3tl/lru_map.hxx
+@@ -14,6 +14,7 @@
+ #include <cassert>
+ #include <list>
+ #include <unordered_map>
++#include <cstddef>
+ namespace o3tl
+ {
index e8926e9873d7403a6e6e3cc1947c75d1d16b4851..2a799418223b219904223e0150cb6bb461d7074b 100644 (file)
@@ -99,6 +99,7 @@ Source30:     https://dev-www.libreoffice.org/extern/8249374c274932a21846fa7629c2aa9
 
 Patch0:                disable-failing-test.patch
 Patch1:                %{name}-upgrade-liborcus-to-0.16.0.patch
+Patch2:                gcc11.patch
 
 URL:           http://www.documentfoundation.org/
 BuildRequires: /usr/bin/getopt
@@ -2842,6 +2843,7 @@ oraz narzędzie ui-previewer do sprawdzania wyglądu okien dialogowych.
 %setup -q -a1 -a2 -a3
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 for dir in *-%{version}; do
        [ -f $dir/ChangeLog ] && %{__mv} $dir/ChangeLog ChangeLog-$dir
This page took 0.062652 seconds and 4 git commands to generate.