]> git.pld-linux.org Git - packages/libpsl.git/blob - libpsl.spec
- updated gettext BR
[packages/libpsl.git] / libpsl.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        C library for the Publix Suffix List
6 Summary(pl.UTF-8):      Biblioteka C do obsługi listy przyrostków publicznych (Public Suffix List)
7 Name:           libpsl
8 Version:        0.6.0
9 Release:        1
10 License:        MIT
11 Group:          Networking
12 Source0:        https://github.com/rockdaboot/libpsl/archive/%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  3fc6e6701c92216f2cae0340704dba2e
14 URL:            https://rockdaboot.github.io/libpsl
15 BuildRequires:  autoconf >= 2.59
16 BuildRequires:  automake >= 1:1.10
17 BuildRequires:  gettext-tools >= 0.18.1
18 BuildRequires:  glib2-devel
19 BuildRequires:  gtk-doc >= 1.15
20 BuildRequires:  libicu-devel
21 BuildRequires:  libtool >= 2:2
22 BuildRequires:  libxslt-progs
23 BuildRequires:  sed >= 4.0
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 libpsl is a C library to handle the Public Suffix List. A "public
28 suffix" is a domain name under which Internet users can directly
29 register own names.
30
31 Browsers and other web clients can use it to
32 - Avoid privacy-leaking "supercookies";
33 - Avoid privacy-leaking "super domain" certificates;
34 - Domain highlighting parts of the domain in a user interface;
35 - Sorting domain lists by site;
36
37 Libpsl...
38 - has built-in PSL data for fast access;
39 - allows to load PSL data from files;
40 - checks if a given domain is a "public suffix";
41 - provides immediate cookie domain verification;
42 - finds the longest public part of a given domain;
43 - finds the shortest private part of a given domain;
44 - works with international domains (UTF-8 and IDNA2008 Punycode);
45 - is thread-safe;
46 - handles IDNA2008 UTS#46;
47
48 %description -l pl.UTF-8
49 libpsl to biblioteka C do obsługi listy przyrostków publicznych
50 (Public Suffix List). "Przyrostek publiczny" to nazwa domeny, poniżej
51 której bezpośrednio użytkownicy Internetu mogą rejestrować własne
52 nazwy.
53
54 Przeglądarki i inni klienci WWW mogą jej używać w celu:
55 - zapobieganiu "superciasteczek" naruszającym prywatność
56 - zapobieganiu certyfikatom "superdomenowym" naruszającym prywatność
57 - podświetlania części domen w interfejsie użytkownika
58 - sortowania listy domen według serwisu.
59
60 Libpsl:
61 - ma wbudowane dane PSL dla szybkiego dostępu
62 - pozwala na wczytywanie danych PSL z plików
63 - sprawdza, czy dana domena jest "przyrostkiem publicznym"
64 - zapewnia natychmiastową weryfikację domeny ciasteczka
65 - znajduje najdłuższą publiczną część podanej domeny
66 - znajduje najkrótszą prywatną część podanej domeny
67 - działa z domenami międzynarodowymi (UTF-8 i IDNA2008 Punycode)
68 - jest bezpieczna względem wątków
69 - obsługuje IDNA2008 UTS#46.
70
71 %package devel
72 Summary:        Development files for libpsl
73 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libpsl
74 Group:          Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76
77 %description devel
78 This package contains the header file for developing applications that
79 use libpsl.
80
81 %description devel -l pl.UTF-8
82 Ten pakiet zawiera plik nagłówkowy do tworzenia aplikacji
83 wykorzystujących bibliotekę libpsl.
84
85 %package static
86 Summary:        Static libpsl library
87 Summary(pl.UTF-8):      Statyczna biblioteka libpsl
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Static libpsl library.
93
94 %description static -l pl.UTF-8
95 Statyczna biblioteka libpsl.
96
97 %package apidocs
98 Summary:        API documentation for libpsl library
99 Summary(pl.UTF-8):      Dokumentacja API biblioteki libpsl
100 Group:          Documentation
101
102 %description apidocs
103 API documentation for libpsl library.
104
105 %description apidocs -l pl.UTF-8
106 Dokumentacja API biblioteki libpsl.
107
108 %package utils
109 Summary:        Commandline utility to explore the Public Suffix List
110 Summary(pl.UTF-8):      Narzędzie linii poleceń do eksplorowania listy przyrostków publicznych
111 Group:          Applications/Networking
112 Requires:       %{name} = %{version}-%{release}
113
114 %description utils
115 This package contains a commandline utility to explore the Public
116 Suffix List, for example it checks if domains are public suffixes,
117 checks if cookie-domain is acceptable for domains and so on.
118
119 %description utils -l pl.UTF-8
120 Ten pakiet zawiera narzędzie linii poleceń do eksplorowania listy
121 przyrostków publicznych (Public Suffix List); sprawdza ono na
122 przykład, czy domeny są przyrostkami publicznymi, czy domena
123 ciasteczka jest akceptowalna dla domen itp.
124
125 %prep
126 %setup -q
127
128 # gettextize workaround
129 %{__sed} -i -e 's,po/Makefile\.in,,' configure.ac
130
131 %build
132 %{__gettextize}
133 %{__gtkdocize}
134 %{__libtoolize}
135 %{__aclocal} -I m4
136 %{__autoconf}
137 %{__autoheader}
138 %{__automake}
139
140 %configure \
141         --disable-silent-rules \
142         %{!?with_static_libs:--disable-static} \
143         --enable-gtk-doc \
144         --enable-man \
145         --with-html-dir=%{_gtkdocdir}
146
147 %{__make}
148
149 %{?with_tests:%{__make} check}
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153 %{__make} install \
154         DESTDIR=$RPM_BUILD_ROOT
155
156 %{__rm} $RPM_BUILD_ROOT%{_datadir}/libpsl/test_psl.txt
157 # obsoleted by pkg-config
158 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libpsl.la
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post   -p /sbin/ldconfig
164 %postun -p /sbin/ldconfig
165
166 %files
167 %defattr(644,root,root,755)
168 %doc AUTHORS COPYING NEWS README.md
169 %attr(755,root,root) %{_libdir}/libpsl.so.*.*.*
170 %attr(755,root,root) %ghost %{_libdir}/libpsl.so.0
171
172 %files devel
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_libdir}/libpsl.so
175 %{_includedir}/libpsl.h
176 %{_pkgconfigdir}/libpsl.pc
177 %{_mandir}/man3/libpsl.3*
178 %{_datadir}/%{name}
179
180 %files static
181 %defattr(644,root,root,755)
182 %{_libdir}/libpsl.a
183
184 %files apidocs
185 %defattr(644,root,root,755)
186 %{_gtkdocdir}/libpsl
187
188 %files utils
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_bindir}/psl
This page took 0.113202 seconds and 4 git commands to generate.