]> git.pld-linux.org Git - packages/libprelude.git/blob - libprelude.spec
- rel 1
[packages/libprelude.git] / libprelude.spec
1 #
2 # Conditional build:
3 %bcond_without  perl    # don't build perl bindings
4 %bcond_without  python  # don't build python bindings (required by prewikka)
5 #
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        The Prelude library
8 Summary(pl.UTF-8):      Biblioteka Prelude
9 Name:           libprelude
10 Version:        0.9.24.1
11 Release:        1
12 License:        GPL v2 or commercial
13 Group:          Libraries
14 #Source0Download: http://www.prelude-ids.com/developpement/telechargement/index.html
15 Source0:        http://www.prelude-ids.com/download/releases/libprelude/%{name}-%{version}.tar.gz
16 # Source0-md5:  07868b3d54fa8243455a27da6b87239c
17 URL:            http://www.prelude-ids.com/
18 BuildRequires:  autoconf >= 2.59
19 BuildRequires:  automake
20 BuildRequires:  bison
21 BuildRequires:  flex
22 BuildRequires:  gnutls-devel >= 1.0.17
23 BuildRequires:  gtk-doc >= 1.0
24 BuildRequires:  libgcrypt-devel >= 1.1.94
25 BuildRequires:  libltdl-devel
26 BuildRequires:  libtool
27 %{?with_perl:BuildRequires:     perl-devel}
28 %{?with_python:BuildRequires:   python-devel >= 1:2.5}
29 BuildRequires:  rpm-perlprov
30 BuildRequires:  rpm-pythonprov
31 BuildRequires:  rpmbuild(macros) >= 1.219
32 Requires:       %{name}-libs = %{version}-%{release}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 The Prelude library is a collection of generic functions providing
37 communication between the Prelude Hybrid IDS suite components. It
38 provides a convenient interface for sending alerts to Prelude Manager
39 with transparent SSL, failover and replication support, asynchronous
40 events and timer interfaces, an abstracted configuration API (hooking
41 at the commandline, the configuration line, or wide configuration,
42 available from the Manager), and a generic plugin API. It allows you
43 to easily turn your favorite security program into a Prelude sensor.
44
45 %description -l pl.UTF-8
46 Biblioteka Prelude to zbiór ogólnych funkcji zapewniających
47 komunikację pomiędzy komponentami zestawu Prelude Hybrid IDS.
48 Dostarcza wygodny interfejs do wysyłania alarmów do zarządcy Prelude z
49 przezroczystą obsługę SSL, failover i replikacji, interfejsy do
50 zdarzeń asynchronicznych i zegarów, abstrakcyjne API konfiguracyjne
51 (obsługujące linię poleceń, linię konfiguracji i konfigurację dostępną
52 z zarządcy) oraz ogólne API wtyczek. Pozwala łatwo zamienić ulubiony
53 program związany z bezpieczeństwem na czujnik Prelude.
54
55 %package libs
56 Summary:        The Prelude library
57 Summary(pl.UTF-8):      Biblioteka Prelude
58 Group:          Libraries
59 Requires:       gnutls >= 1.0.17
60 Requires:       libgcrypt >= 1.1.94
61
62 %description libs
63 The Prelude library.
64
65 %description libs -l pl.UTF-8
66 Biblioteka Prelude.
67
68 %package devel
69 Summary:        Header files and development documentation for libprelude
70 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja programistyczna dla libprelude
71 Group:          Development/Libraries
72 Requires:       %{name}-libs = %{version}-%{release}
73 Requires:       gnutls-devel >= 1.0.17
74 Requires:       libgcrypt-devel >= 1.1.94
75 Requires:       libltdl-devel
76
77 %description devel
78 Header files and development documentation for libprelude.
79
80 %description devel -l pl.UTF-8
81 Pliki nagłówkowe i dokumentacja programistyczna dla libprelude.
82
83 %package static
84 Summary:        Static libprelude library
85 Summary(pl.UTF-8):      Statyczna biblioteka libprelude
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88
89 %description static
90 Static libprelude library.
91
92 %description static -l pl.UTF-8
93 Statyczna biblioteka libprelude.
94
95 %package -n perl-libprelude
96 Summary:        libprelude Perl bindings
97 Summary(pl.UTF-8):      Dowiązania Perla do libprelude
98 Group:          Development/Languages/Perl
99 Requires:       %{name}-libs = %{version}-%{release}
100
101 %description -n perl-libprelude
102 libprelude Perl bindings.
103
104 %description -n perl-libprelude -l pl.UTF-8
105 Dowiązania Perla dla libprelude.
106
107 %package -n python-libprelude
108 Summary:        libprelude Python bindings
109 Summary(pl.UTF-8):      Dowiązania Pythona dla libprelude
110 Group:          Development/Languages/Python
111 Requires:       %{name}-libs = %{version}-%{release}
112
113 %description -n python-libprelude
114 libprelude Python bindings.
115
116 %description -n python-libprelude -l pl.UTF-8
117 Dowiązania Pythona dla libprelude.
118
119 %prep
120 %setup -q
121
122 %build
123 %{__libtoolize}
124 %{__aclocal} -I m4 -I libmissing/m4
125 %{__autoconf}
126 %{__autoheader}
127 %{__automake}
128 %configure \
129         --enable-static \
130         --enable-gtk-doc \
131         --with%{!?with_perl:out}-perl \
132         --with%{!?with_python:out}-python \
133         --with-html-dir=%{_gtkdocdir}/libprelude \
134         --with-perl-installdirs=vendor
135
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 %if %{with python}
145 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
146 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
147 %py_postclean
148 %endif
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post   libs -p /sbin/ldconfig
154 %postun libs -p /sbin/ldconfig
155
156 %files
157 %defattr(644,root,root,755)
158 %doc AUTHORS ChangeLog LICENSE.README NEWS README
159 %attr(755,root,root) %{_bindir}/prelude-adduser
160 %attr(755,root,root) %{_bindir}/prelude-admin
161 %dir %{_sysconfdir}/prelude
162 %dir %{_sysconfdir}/prelude/default
163 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/prelude/default/*.conf
164 %dir %{_sysconfdir}/prelude/profile
165 %{_mandir}/man1/prelude-admin.1*
166
167 %files libs
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/libprelude.so.*.*.*
170 %attr(755,root,root) %ghost %{_libdir}/libprelude.so.2
171
172 %files devel
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_bindir}/libprelude-config
175 %attr(755,root,root) %{_libdir}/libprelude.so
176 %{_libdir}/libprelude.la
177 %{_includedir}/libprelude
178 %{_aclocaldir}/libprelude.m4
179 %{_gtkdocdir}/libprelude
180 %{_pkgconfigdir}/libprelude.pc
181
182 %files static
183 %defattr(644,root,root,755)
184 %{_libdir}/libprelude.a
185
186 %if %{with perl}
187 %files -n perl-libprelude
188 %defattr(644,root,root,755)
189 %{perl_vendorarch}/Prelude.pm
190 %dir %{perl_vendorarch}/auto/Prelude
191 %{perl_vendorarch}/auto/Prelude/Prelude.bs
192 %attr(755,root,root) %{perl_vendorarch}/auto/Prelude/Prelude.so
193 %endif
194
195 %if %{with python}
196 %files -n python-libprelude
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{py_sitedir}/_prelude.so
199 %{py_sitedir}/prelude.py[co]
200 %{py_sitedir}/prelude-*.egg-info
201 %endif
This page took 0.509957 seconds and 4 git commands to generate.