]> git.pld-linux.org Git - packages/libprelude.git/blob - libprelude.spec
db7b8c18cc96e9bdf68422da89ad9736293b531c
[packages/libprelude.git] / libprelude.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        The Prelude library
3 Summary(pl):    Biblioteka Prelude
4 Name:           libprelude
5 Version:        0.9.0
6 Release:        1
7 License:        GPL
8 Group:          Libraries
9 Source0:        http://www.prelude-ids.org/download/releases/%{name}-%{version}.tar.gz
10 # Source0-md5:  95fe75b77b8be8992bc87274d6e2283a
11 URL:            http://www.prelude-ids.org/
12 BuildRequires:  bison
13 BuildRequires:  flex
14 BuildRequires:  gnutls-devel >= 1.2.5
15 BuildRequires:  gtk-doc
16 BuildRequires:  perl-devel
17 BuildRequires:  python-devel
18 BuildRequires:  rpm-perlprov
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 The Prelude library is a collection of generic functions providing
23 communication between the Prelude Hybrid IDS suite components. It
24 provides a convenient interface for sending alerts to Prelude Manager
25 with transparent SSL, failover and replication support, asynchronous
26 events and timer interfaces, an abstracted configuration API (hooking
27 at the commandline, the configuration line, or wide configuration,
28 available from the Manager), and a generic plugin API. It allows you
29 to easily turn your favorite security program into a Prelude sensor.
30
31 %description -l pl
32 Biblioteka Prelude to zbiór ogólnych funkcji zapewniaj±cych
33 komunikacjê pomiêdzy komponentami zestawu Prelude Hybrid IDS.
34 Dostarcza wygodny interfejs do wysy³ania alarmów do zarz±dcy Prelude z
35 przezroczyst± obs³ugê SSL, failover i replikacji, interfejsy do
36 zdarzeñ asynchronicznych i zegarów, abstrakcyjne API konfiguracyjne
37 (obs³uguj±ce liniê poleceñ, liniê konfiguracji i konfiguracjê
38 dostêpn± z zarz±dcy) oraz ogólne API wtyczek. Pozwala ³atwo zamieniæ
39 ulubiony program zwi±zany z bezpieczeñstwem na czujnik Prelude.
40
41 %package libs
42 Summary:        The Prelude library
43 Summary(pl):    Biblioteka Prelude
44 Group:          Libraries
45
46 %description libs
47 The Prelude library.
48
49 %description libs -l pl
50 Biblioteka Prelude.
51
52 %package devel
53 Summary:        Header files and development documentation for libprelude
54 Summary(pl):    Pliki nag³ówkowe i dokumentacja programistyczna dla libprelude
55 Group:          Development/Libraries
56 Requires:       %{name}-libs = %{version}-%{release}
57 Requires:       gnutls-devel
58
59 %description devel
60 Header files and development documentation for libprelude.
61
62 %description devel -l pl
63 Pliki nag³ówkowe i dokumentacja programistyczna dla libprelude.
64
65 %package static
66 Summary:        Static libprelude library
67 Summary(pl):    Statyczna biblioteka libprelude
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static libprelude library.
73
74 %description static -l pl
75 Statyczna biblioteka libprelude.
76
77 %package -n perl-libprelude
78 Summary:        libprelude Perl bindings
79 Summary(pl):    Dowi±zania Perla do libprelude
80 Group:          Development/Languages/Perl
81
82 %description -n perl-libprelude
83 libprelude Perl bindings.
84
85 %description -n perl-libprelude -l pl
86 Dowi±zania Perla dla libprelude.
87
88 %package -n python-libprelude
89 Summary:        libprelude Python bindings
90 Summary(pl):    Dowi±zania Pythona dla libprelude
91 Group:          Development/Languages/Python
92
93 %description -n python-libprelude
94 libprelude Python bindings.
95
96 %description -n python-libprelude -l pl
97 Dowi±zania Pythona dla libprelude.
98
99 %prep
100 %setup -q
101
102 %build
103 %configure \
104         --enable-shared \
105         --enable-static \
106         --enable-perl \
107         --enable-python \
108         --enable-gtk-doc \
109         --with-html-dir=%{_gtkdocdir}/libprelude
110
111 # first make the perl makefile otherwise with jobserver strange things happen:
112 # Makefile out-of-date with respect to Makefile.PL
113 %{__make} -C bindings perl/Makefile
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 cd bindings/perl && %{__perl} Makefile.PL \
124         INSTALLDIRS=vendor
125 cd ../..
126 %{__make} -C bindings/perl install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
130 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   libs -p /sbin/ldconfig
136 %postun libs -p /sbin/ldconfig
137
138 %files
139 %defattr(644,root,root,755)
140 %doc AUTHORS ChangeLog NEWS README
141 %dir %{_sysconfdir}/prelude
142 %dir %{_sysconfdir}/prelude/default
143 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/prelude/default/*.conf
144 %dir %{_sysconfdir}/prelude/profile
145
146 %files libs
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_bindir}/prelude-adduser
149 %attr(755,root,root) %{_libdir}/lib*.so.*.*
150
151 %files devel
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_bindir}/libprelude-config
154 %attr(755,root,root) %{_libdir}/lib*.so
155 %{_libdir}/lib*.la
156 %{_includedir}/libprelude
157 %{_aclocaldir}/*.m4
158 %{_gtkdocdir}/libprelude
159
160 %files static
161 %defattr(644,root,root,755)
162 %{_libdir}/lib*.a
163
164 %files -n perl-libprelude
165 %defattr(644,root,root,755)
166 %dir %{perl_vendorarch}/auto/Prelude
167 %attr(755,root,root) %{perl_vendorarch}/auto/Prelude/*.so
168 %{perl_vendorarch}/auto/Prelude/*.bs
169 %{perl_vendorarch}/Prelude.pm
170
171 %files -n python-libprelude
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{py_sitedir}/*.so
174 %{py_sitedir}/*.py[co]
This page took 0.050815 seconds and 2 git commands to generate.