]> git.pld-linux.org Git - packages/libprelude.git/blob - libprelude.spec
- release 2 (against libltdl-2.2.6-1)
[packages/libprelude.git] / libprelude.spec
1 #
2 # Conditional build:
3 %bcond_without  perl    # don't build perl bindings
4 %bcond_without  python  # don't build python bindings (required by prewikka)
5 #
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        The Prelude library
8 Summary(pl.UTF-8):      Biblioteka Prelude
9 Name:           libprelude
10 Version:        0.9.17.2
11 Release:        2
12 License:        GPL v2 or commercial
13 Group:          Libraries
14 #Source0Download: http://www.prelude-ids.com/developpement/telechargement/index.html
15 Source0:        http://www.prelude-ids.com/download/releases/libprelude/%{name}-%{version}.tar.gz
16 # Source0-md5:  7c769293b4d79be2667993b8a88d42ac
17 Patch0:         %{name}-libdir.patch
18 URL:            http://www.prelude-ids.com/
19 BuildRequires:  autoconf >= 2.59
20 BuildRequires:  automake
21 BuildRequires:  bison
22 BuildRequires:  flex
23 BuildRequires:  gnutls-devel >= 1.0.17
24 BuildRequires:  gtk-doc >= 1.0
25 BuildRequires:  libgcrypt-devel >= 1.1.94
26 BuildRequires:  libltdl-devel
27 BuildRequires:  libtool
28 %{?with_perl:BuildRequires:     perl-devel}
29 %{?with_python:BuildRequires:   python-devel >= 1:2.5}
30 BuildRequires:  rpm-perlprov
31 BuildRequires:  rpm-pythonprov
32 BuildRequires:  rpmbuild(macros) >= 1.219
33 Requires:       %{name}-libs = %{version}-%{release}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 The Prelude library is a collection of generic functions providing
38 communication between the Prelude Hybrid IDS suite components. It
39 provides a convenient interface for sending alerts to Prelude Manager
40 with transparent SSL, failover and replication support, asynchronous
41 events and timer interfaces, an abstracted configuration API (hooking
42 at the commandline, the configuration line, or wide configuration,
43 available from the Manager), and a generic plugin API. It allows you
44 to easily turn your favorite security program into a Prelude sensor.
45
46 %description -l pl.UTF-8
47 Biblioteka Prelude to zbiór ogólnych funkcji zapewniających
48 komunikację pomiędzy komponentami zestawu Prelude Hybrid IDS.
49 Dostarcza wygodny interfejs do wysyłania alarmów do zarządcy Prelude z
50 przezroczystą obsługę SSL, failover i replikacji, interfejsy do
51 zdarzeń asynchronicznych i zegarów, abstrakcyjne API konfiguracyjne
52 (obsługujące linię poleceń, linię konfiguracji i konfigurację
53 dostępną z zarządcy) oraz ogólne API wtyczek. Pozwala łatwo zamienić
54 ulubiony program związany z bezpieczeństwem na czujnik Prelude.
55
56 %package libs
57 Summary:        The Prelude library
58 Summary(pl.UTF-8):      Biblioteka Prelude
59 Group:          Libraries
60 Requires:       gnutls >= 1.0.17
61 Requires:       libgcrypt >= 1.1.94
62
63 %description libs
64 The Prelude library.
65
66 %description libs -l pl.UTF-8
67 Biblioteka Prelude.
68
69 %package devel
70 Summary:        Header files and development documentation for libprelude
71 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja programistyczna dla libprelude
72 Group:          Development/Libraries
73 Requires:       %{name}-libs = %{version}-%{release}
74 Requires:       gnutls-devel >= 1.0.17
75 Requires:       libgcrypt-devel >= 1.1.94
76 Requires:       libltdl-devel
77
78 %description devel
79 Header files and development documentation for libprelude.
80
81 %description devel -l pl.UTF-8
82 Pliki nagłówkowe i dokumentacja programistyczna dla libprelude.
83
84 %package static
85 Summary:        Static libprelude library
86 Summary(pl.UTF-8):      Statyczna biblioteka libprelude
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89
90 %description static
91 Static libprelude library.
92
93 %description static -l pl.UTF-8
94 Statyczna biblioteka libprelude.
95
96 %package -n perl-libprelude
97 Summary:        libprelude Perl bindings
98 Summary(pl.UTF-8):      Dowiązania Perla do libprelude
99 Group:          Development/Languages/Perl
100 Requires:       %{name}-libs = %{version}-%{release}
101
102 %description -n perl-libprelude
103 libprelude Perl bindings.
104
105 %description -n perl-libprelude -l pl.UTF-8
106 Dowiązania Perla dla libprelude.
107
108 %package -n python-libprelude
109 Summary:        libprelude Python bindings
110 Summary(pl.UTF-8):      Dowiązania Pythona dla libprelude
111 Group:          Development/Languages/Python
112 Requires:       %{name}-libs = %{version}-%{release}
113
114 %description -n python-libprelude
115 libprelude Python bindings.
116
117 %description -n python-libprelude -l pl.UTF-8
118 Dowiązania Pythona dla libprelude.
119
120 %prep
121 %setup -q
122 %patch0 -p1
123
124 %build
125 %{__libtoolize}
126 %{__aclocal} -I m4 -I libmissing/m4
127 %{__autoconf}
128 %{__autoheader}
129 %{__automake}
130 %configure \
131         --enable-static \
132         --enable-gtk-doc \
133         --with%{!?with_perl:out}-perl \
134         --with%{!?with_python:out}-python \
135         --with-html-dir=%{_gtkdocdir}/libprelude \
136         --with-perl-installdirs=vendor
137
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 %if %{with python}
147 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
148 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
149 %py_postclean
150 %endif
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post   libs -p /sbin/ldconfig
156 %postun libs -p /sbin/ldconfig
157
158 %files
159 %defattr(644,root,root,755)
160 %doc AUTHORS ChangeLog LICENSE.README NEWS README
161 %attr(755,root,root) %{_bindir}/prelude-adduser
162 %attr(755,root,root) %{_bindir}/prelude-admin
163 %dir %{_sysconfdir}/prelude
164 %dir %{_sysconfdir}/prelude/default
165 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/prelude/default/*.conf
166 %dir %{_sysconfdir}/prelude/profile
167 %{_mandir}/man1/prelude-admin.1*
168
169 %files libs
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_libdir}/libprelude.so.*.*.*
172 %attr(755,root,root) %ghost %{_libdir}/libprelude.so.2
173
174 %files devel
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_bindir}/libprelude-config
177 %attr(755,root,root) %{_libdir}/libprelude.so
178 %{_libdir}/libprelude.la
179 %{_includedir}/libprelude
180 %{_aclocaldir}/libprelude.m4
181 %{_gtkdocdir}/libprelude
182
183 %files static
184 %defattr(644,root,root,755)
185 %{_libdir}/libprelude.a
186
187 %if %{with perl}
188 %files -n perl-libprelude
189 %defattr(644,root,root,755)
190 %{perl_vendorarch}/Prelude.pm
191 %dir %{perl_vendorarch}/auto/Prelude
192 %{perl_vendorarch}/auto/Prelude/Prelude.bs
193 %attr(755,root,root) %{perl_vendorarch}/auto/Prelude/Prelude.so
194 %endif
195
196 %if %{with python}
197 %files -n python-libprelude
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{py_sitedir}/_prelude.so
200 %{py_sitedir}/prelude.py[co]
201 %{py_sitedir}/prelude-*.egg-info
202 %endif
This page took 0.05118 seconds and 3 git commands to generate.