]> git.pld-linux.org Git - packages/libprelude.git/blob - libprelude.spec
3cdc48a636fb93003cafee0d5371c524bc53e249
[packages/libprelude.git] / libprelude.spec
1 %bcond_without  perl
2 %bcond_without  python          # required by prewikka
3
4 %include        /usr/lib/rpm/macros.perl
5 Summary:        The Prelude library
6 Summary(pl):    Biblioteka Prelude
7 Name:           libprelude
8 Version:        0.9.12
9 Release:        1
10 License:        GPL
11 Group:          Libraries
12 Source0:        http://www.prelude-ids.org/download/releases/%{name}-%{version}.tar.gz
13 # Source0-md5:  2e8769cd05d51d3e69380bf234e6efef
14 URL:            http://www.prelude-ids.org/
15 BuildRequires:  bison
16 BuildRequires:  flex
17 BuildRequires:  gnutls-devel >= 1.0.17
18 BuildRequires:  gtk-doc
19 %{?with_perl:BuildRequires:     perl-devel}
20 %{?with_python:BuildRequires:   python-devel}
21 BuildRequires:  rpm-perlprov
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The Prelude library is a collection of generic functions providing
26 communication between the Prelude Hybrid IDS suite components. It
27 provides a convenient interface for sending alerts to Prelude Manager
28 with transparent SSL, failover and replication support, asynchronous
29 events and timer interfaces, an abstracted configuration API (hooking
30 at the commandline, the configuration line, or wide configuration,
31 available from the Manager), and a generic plugin API. It allows you
32 to easily turn your favorite security program into a Prelude sensor.
33
34 %description -l pl
35 Biblioteka Prelude to zbiór ogólnych funkcji zapewniaj±cych
36 komunikacjê pomiêdzy komponentami zestawu Prelude Hybrid IDS.
37 Dostarcza wygodny interfejs do wysy³ania alarmów do zarz±dcy Prelude z
38 przezroczyst± obs³ugê SSL, failover i replikacji, interfejsy do
39 zdarzeñ asynchronicznych i zegarów, abstrakcyjne API konfiguracyjne
40 (obs³uguj±ce liniê poleceñ, liniê konfiguracji i konfiguracjê
41 dostêpn± z zarz±dcy) oraz ogólne API wtyczek. Pozwala ³atwo zamieniæ
42 ulubiony program zwi±zany z bezpieczeñstwem na czujnik Prelude.
43
44 %package libs
45 Summary:        The Prelude library
46 Summary(pl):    Biblioteka Prelude
47 Group:          Libraries
48
49 %description libs
50 The Prelude library.
51
52 %description libs -l pl
53 Biblioteka Prelude.
54
55 %package devel
56 Summary:        Header files and development documentation for libprelude
57 Summary(pl):    Pliki nag³ówkowe i dokumentacja programistyczna dla libprelude
58 Group:          Development/Libraries
59 Requires:       %{name}-libs = %{version}-%{release}
60 Requires:       gnutls-devel
61
62 %description devel
63 Header files and development documentation for libprelude.
64
65 %description devel -l pl
66 Pliki nag³ówkowe i dokumentacja programistyczna dla libprelude.
67
68 %package static
69 Summary:        Static libprelude library
70 Summary(pl):    Statyczna biblioteka libprelude
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static libprelude library.
76
77 %description static -l pl
78 Statyczna biblioteka libprelude.
79
80 %package -n perl-libprelude
81 Summary:        libprelude Perl bindings
82 Summary(pl):    Dowi±zania Perla do libprelude
83 Group:          Development/Languages/Perl
84
85 %description -n perl-libprelude
86 libprelude Perl bindings.
87
88 %description -n perl-libprelude -l pl
89 Dowi±zania Perla dla libprelude.
90
91 %package -n python-libprelude
92 Summary:        libprelude Python bindings
93 Summary(pl):    Dowi±zania Pythona dla libprelude
94 Group:          Development/Languages/Python
95
96 %description -n python-libprelude
97 libprelude Python bindings.
98
99 %description -n python-libprelude -l pl
100 Dowi±zania Pythona dla libprelude.
101
102 %prep
103 %setup -q
104
105 %build
106 %configure \
107         --enable-shared \
108         --enable-static \
109         --enable-gtk-doc \
110         --with-perl%{!?with_perl:=no} \
111         --with-python%{!?with_python:=no} \
112         --with-html-dir=%{_gtkdocdir}/libprelude
113
114 # first make the perl makefile otherwise with jobserver strange things happen:
115 # Makefile out-of-date with respect to Makefile.PL
116 %if %{with perl}
117 %{__make} -C bindings perl/Makefile
118 %endif
119
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 %if %{with perl}
129 cd bindings/perl && %{__perl} Makefile.PL \
130         INSTALLDIRS=vendor
131 cd ../..
132 %{__make} -C bindings/perl install \
133         DESTDIR=$RPM_BUILD_ROOT
134 %endif
135
136 %if %{with python}
137 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
138 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
139 %endif
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   libs -p /sbin/ldconfig
145 %postun libs -p /sbin/ldconfig
146
147 %files
148 %defattr(644,root,root,755)
149 %doc AUTHORS ChangeLog NEWS README
150 %dir %{_sysconfdir}/prelude
151 %dir %{_sysconfdir}/prelude/default
152 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/prelude/default/*.conf
153 %dir %{_sysconfdir}/prelude/profile
154
155 %files libs
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_bindir}/prelude-adduser
158 %attr(755,root,root) %{_libdir}/lib*.so.*.*
159 # needed in normal operational
160 %{_libdir}/lib*.la
161
162 %files devel
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/libprelude-config
165 %attr(755,root,root) %{_libdir}/lib*.so
166 %{_includedir}/libprelude
167 %{_aclocaldir}/*.m4
168 %{_gtkdocdir}/libprelude
169
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/lib*.a
173
174 %if %{with perl}
175 %files -n perl-libprelude
176 %defattr(644,root,root,755)
177 %dir %{perl_vendorarch}/auto/Prelude
178 %attr(755,root,root) %{perl_vendorarch}/auto/Prelude/*.so
179 %{perl_vendorarch}/auto/Prelude/*.bs
180 %{perl_vendorarch}/Prelude.pm
181 %endif
182
183 %if %{with python}
184 %files -n python-libprelude
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{py_sitedir}/*.so
187 %{py_sitedir}/*.py[co]
188 %endif
This page took 0.044524 seconds and 2 git commands to generate.