]> git.pld-linux.org Git - packages/libplist.git/commitdiff
package plist.pxd for cython
authorElan Ruusamäe <glen@delfi.ee>
Thu, 6 Sep 2012 17:06:32 +0000 (20:06 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 6 Sep 2012 17:06:32 +0000 (20:06 +0300)
or we get error:
$ python -c "import imobilesync"
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/share/python2.7/site-packages/imobilesync/__init__.py", line 1, in <module>
  File "/usr/share/python2.7/site-packages/imobilesync/data/__init__.py", line 1, in <module>
  File "/usr/share/python2.7/site-packages/imobilesync/data/base.py", line 2, in <module>
  File "/usr/share/python2.7/site-packages/imobilesync/sync.py", line 1, in <module>
  File "plist.pxd", line 6, in init imobiledevice (imobiledevice.c:29961)
ValueError: plist.Node has the wrong size, try recompiling

libplist.spec

index 5e2c7767cbf791979e3ac7a7c775f43049588b72..b435a0a12b482f4404bdbe59abf7e09bcfa5799d 100644 (file)
@@ -7,7 +7,7 @@ Summary:        Library for manipulating Apple Property Lists
 Summary(pl.UTF-8):     Biblioteka do manipulowania Apple Property Lists
 Name:          libplist
 Version:       1.8
-Release:       3
+Release:       4
 License:       LGPL v2+
 Group:         Libraries
 #Source0-Download: http://www.libimobiledevice.org/
@@ -87,6 +87,7 @@ rm -rf $RPM_BUILD_ROOT
 # cmake sucks, fix perms
 %if %{with cython}
 chmod a+x $RPM_BUILD_ROOT%{py_sitedir}/plist.so
+cp -p cython/plist.pxd $RPM_BUILD_ROOT%{py_sitedir}
 %endif
 %if %{with swig}
 chmod a+x $RPM_BUILD_ROOT%{py_sitedir}/plist/_plist.so
@@ -120,6 +121,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %if %{with cython}
 %attr(755,root,root) %{py_sitedir}/plist.so
+%attr(755,root,root) %{py_sitedir}/plist.pxd
 %endif
 %if %{with swig}
 %dir %{py_sitedir}/plist
This page took 0.107982 seconds and 4 git commands to generate.