]> git.pld-linux.org Git - packages/libplist.git/commitdiff
- updated to 2.3.0 (new soname)
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 26 Nov 2023 07:27:26 +0000 (08:27 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 26 Nov 2023 07:27:26 +0000 (08:27 +0100)
libplist-sh.patch
libplist.spec

index e01a916bb7105d55af7134cf8734e381e02005ce..eb36e705bf1977a6c04682e0c8c0f4d3763a55f4 100644 (file)
@@ -1,15 +1,6 @@
---- libplist-2.2.0/configure.ac.orig   2020-06-15 14:45:49.000000000 +0200
-+++ libplist-2.2.0/configure.ac        2020-09-12 08:15:33.382297575 +0200
-@@ -154,7 +154,7 @@
- GLOBAL_LDFLAGS="$PTHREAD_LIBS"
- if test "x$ac_cv_fmin_builtin" != "xyes"; then
--      GLOBAL_LDFLAGS+=" -lm"
-+      GLOBAL_LDFLAGS="$GLOBAL_LDFLAGS -lm"
- fi
- AC_ARG_ENABLE(debug,
-@@ -169,7 +169,7 @@
+--- libplist-2.3.0/configure.ac.orig   2023-04-21 14:07:43.000000000 +0200
++++ libplist-2.3.0/configure.ac        2023-11-25 21:12:09.871666005 +0100
+@@ -179,7 +179,7 @@ esac],
  
  if (test "x$debug" = "xyes"); then
         AC_DEFINE(DEBUG, 1, [Define if debug message output code should be built.])
@@ -18,7 +9,7 @@
  fi
  
  AC_SUBST(GLOBAL_CFLAGS)
-@@ -201,23 +201,23 @@
+@@ -211,23 +211,23 @@ fi
  
  if test "x$build_sanitizers" = "xyes"; then
      AS_COMPILER_FLAG([-fsanitize=address], [
@@ -47,7 +38,7 @@
      fi
  
      if test -z "$SANITIZER_FLAGS"; then
-@@ -230,13 +230,13 @@
+@@ -240,13 +240,13 @@ if test "x$build_sanitizers" = "xyes"; t
              if test -z "$SAN_COV_FLAGS"; then
                  SAN_COV_FLAGS="$COV_CHECK"
              else
@@ -64,7 +55,7 @@
      else
          AC_MSG_WARN([No sanitizer coverage supported by compiler])
      fi
-@@ -244,20 +244,20 @@
+@@ -254,20 +254,20 @@ if test "x$build_sanitizers" = "xyes"; t
      CFLAGS="-O1"
  
      AS_COMPILER_FLAG([-fno-omit-frame-pointer], [
@@ -90,9 +81,9 @@
      CXXFLAGS="$CFLAGS -std=c++11"
  fi
  
-@@ -266,9 +266,9 @@
-         AC_MSG_WARN([building fuzzers requires clang/clang++ (continuing anyway)])
-     fi
+@@ -281,9 +281,9 @@ if test "x$build_fuzzers" = "xyes"; then
+         ;;
+     esac
  
 -    CFLAGS+=" -DFUZZING_BUILD_MODE_UNSAFE_FOR_PRODUCTION"
 +    CFLAGS="$CFLAGS -DFUZZING_BUILD_MODE_UNSAFE_FOR_PRODUCTION"
index fdac979cdf56c437f102a2014756e17305d253de..c1ed960037e1ebc781f0e73524bc95ad3a484689 100644 (file)
 Summary:       Library for manipulating Apple Property Lists
 Summary(pl.UTF-8):     Biblioteka do manipulowania Apple Property Lists
 Name:          libplist
-Version:       2.2.0
-Release:       5
+Version:       2.3.0
+Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
 # Source0Download: https://libimobiledevice.org/
 Source0:       https://github.com/libimobiledevice/libplist/releases/download/%{version}/%{name}-%{version}.tar.bz2
-# Source0-md5: 63cc49401521662c94cd4107898c744c
+# Source0-md5: d6e2b9f713f18ae0a0f3353c03315bfd
 Patch0:                %{name}-sh.patch
 URL:           https://libimobiledevice.org/
-BuildRequires: autoconf >= 2.64
+BuildRequires: autoconf >= 2.68
 BuildRequires: automake
 BuildRequires: libstdc++-devel
-BuildRequires: libtool
+BuildRequires: libtool >= 2:2
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.600
 %if %{with cython}
@@ -195,16 +195,14 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with cython}
 install -d $RPM_BUILD_ROOT%{_includedir}/plist/cython
 cp -p cython/plist.pxd $RPM_BUILD_ROOT%{_includedir}/plist/cython/plist.pxd
-%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/plist.la \
-       %{?with_static_libs:$RPM_BUILD_ROOT%{py_sitedir}/plist.a}
+%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/plist.la
 
 %if %{with python3}
 %{__make} -C build-py3/cython install \
        DESTDIR=$RPM_BUILD_ROOT \
        top_builddir="$(pwd)/build"
 
-%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/plist.la \
-       %{?with_static_libs:$RPM_BUILD_ROOT%{py3_sitedir}/plist.a}
+%{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/plist.la
 %endif
 %endif
 
@@ -222,7 +220,7 @@ rm -rf $RPM_BUILD_ROOT
 %doc AUTHORS NEWS README.md
 %attr(755,root,root) %{_bindir}/plistutil
 %attr(755,root,root) %{_libdir}/libplist-2.0.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libplist-2.0.so.3
+%attr(755,root,root) %ghost %{_libdir}/libplist-2.0.so.4
 %{_mandir}/man1/plistutil.1*
 
 %files devel
@@ -241,7 +239,7 @@ rm -rf $RPM_BUILD_ROOT
 %files c++
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libplist++-2.0.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libplist++-2.0.so.3
+%attr(755,root,root) %ghost %{_libdir}/libplist++-2.0.so.4
 
 %files c++-devel
 %defattr(644,root,root,755)
This page took 0.157821 seconds and 4 git commands to generate.