]> git.pld-linux.org Git - packages/liborcus.git/commitdiff
upstream patches fixing build with gcc 11
authorJan Palus <atler@pld-linux.org>
Tue, 10 Aug 2021 17:11:59 +0000 (19:11 +0200)
committerJan Palus <atler@pld-linux.org>
Tue, 10 Aug 2021 17:11:59 +0000 (19:11 +0200)
liborcus-gcc11.patch [new file with mode: 0644]
liborcus.spec

diff --git a/liborcus-gcc11.patch b/liborcus-gcc11.patch
new file mode 100644 (file)
index 0000000..f1dda13
--- /dev/null
@@ -0,0 +1,72 @@
+From 50506d534230d90de2b0a2af3fb072428c942a4e Mon Sep 17 00:00:00 2001
+From: hedmo <hedmoo@yahoo.com>
+Date: Fri, 8 Jan 2021 07:30:16 +0000
+Subject: [PATCH] Update orcus_xlsx.cpp to build with gcc-11
+
+---
+ src/liborcus/orcus_xlsx.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/liborcus/orcus_xlsx.cpp b/src/liborcus/orcus_xlsx.cpp
+index 6df72a32..a59b2b9d 100644
+--- a/src/liborcus/orcus_xlsx.cpp
++++ b/src/liborcus/orcus_xlsx.cpp
+@@ -32,6 +32,7 @@
+ #include <cstdlib>
+ #include <iostream>
++#include <limits>
+ #include <string>
+ #include <cstring>
+ #include <sstream>
+-- 
+GitLab
+
+From 3bfa1a000e4639fe68781c584356ceea7c6b1a72 Mon Sep 17 00:00:00 2001
+From: hedmo <hedmoo@yahoo.com>
+Date: Fri, 8 Jan 2021 07:32:53 +0000
+Subject: [PATCH] Update xls_xml_context.cpp to build with gcc-11
+
+---
+ src/liborcus/xls_xml_context.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/liborcus/xls_xml_context.cpp b/src/liborcus/xls_xml_context.cpp
+index 538f5607..ca3dc4d0 100644
+--- a/src/liborcus/xls_xml_context.cpp
++++ b/src/liborcus/xls_xml_context.cpp
+@@ -16,6 +16,7 @@
+ #include <mdds/sorted_string_map.hpp>
+ #include <iostream>
++#include <limits>
+ using namespace std;
+ namespace ss = orcus::spreadsheet;
+-- 
+GitLab
+
+From 5e8fb255dc6bc9b7084a05b8dc24f31417542e5e Mon Sep 17 00:00:00 2001
+From: hedmo <hedmoo@yahoo.com>
+Date: Fri, 8 Jan 2021 07:34:17 +0000
+Subject: [PATCH] Update xlsx_revision_context.cpp to build with gcc-11
+
+---
+ src/liborcus/xlsx_revision_context.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/liborcus/xlsx_revision_context.cpp b/src/liborcus/xlsx_revision_context.cpp
+index edfd9eed..0b6ec0af 100644
+--- a/src/liborcus/xlsx_revision_context.cpp
++++ b/src/liborcus/xlsx_revision_context.cpp
+@@ -16,6 +16,7 @@
+ #include "orcus/global.hpp"
+ #include <iostream>
++#include <limits>
+ using namespace std;
+-- 
+GitLab
+
index 92fe794356e20d6546b4ba6eb8c07a613b974eb4..079ec6ee1333a51d663f5f4461311e3720858908 100644 (file)
@@ -16,6 +16,7 @@ Group:                Libraries
 Source0:       http://kohei.us/files/orcus/src/%{name}-%{version}.tar.xz
 # Source0-md5: be30a66fa4249e5fea90db2872c5be68
 Patch0:                %{name}-flags.patch
+Patch1:                %{name}-gcc11.patch
 URL:           https://gitlab.com/orcus/orcus
 BuildRequires: autoconf >= 2.65
 BuildRequires: automake >= 1:1.11
@@ -142,6 +143,7 @@ Wiązanie Pythona 3 do biblioteki liborcus.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
This page took 0.224541 seconds and 4 git commands to generate.